Subject: [Dhcpv6bis] [dhcpv6bis] #153 (XML 3315): requirement level of DAD is inconsistent between RFC3315(and bis) and RFC4862

From: "dhcpv6bis issue tracker" <[email-masked]>
Date: Fri, 06 Nov 2015 00:56:55 -0000

#153: requirement level of DAD is inconsistent between RFC3315(and bis) and
RFC4862

 RFC4862 requires DAD for any address with a MUST:

    Duplicate Address Detection MUST be performed on all unicast
    addresses prior to assigning them to an interface, regardless of
    whether they are obtained through stateless autoconfiguration,
    DHCPv6, or manual configuration, with the following exceptions:

 (the exceptions are irrelevant to whether the address is configured
 via DHCPv6 or some other means)

 while RFC3315 uses a SHOULD:

    The client SHOULD perform duplicate address detection [17] on each of
    the addresses in any IAs it receives in the Reply message before
    using that address for traffic.

 this is still essentially the same in rfc3315bis-02:

    The client SHOULD perform duplicate address detection [RFC4862] on
    each of the received addresses in any IAs, on which it has not
    performed duplicate address detection during processing of any of the
    previous Reply messages from the server.

 Obviously this should be consistent.  And, in my opinion, RFC4862
 should be a normative reference on this point, and this should be
 a MUST in rfc3315bis.

-- 
-------------------------------+-----------------
 Reporter:  [email-masked]  |      Owner:
     Type:  errata             |     Status:  new
 Priority:  P3 major           |  Milestone:
Component:  XML 3315           |   Keywords:
 Due Date:  31/12/2015         |
-------------------------------+-----------------

Ticket URL: <http://trac.tools.ietf.org/group/dhcpv6bis/ticket/153>
dhcpv6bis <http://tools.ietf.org/group/dhcpv6bis/>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 6 Nov 2015 01:04:49 +0000

Hi Jinmei - good find (and since 4862 was after 3315 and earlier 2462 was not as clear, this was probably why 3315 ended up with what it has).

I think we need to go thru 3315bis and current v6 rfc & 6man's bis documents to make sure we are all in sync. 

So keep comments coming & create tickets.  

BTW: nice if we can reduce text in 3315bis and reference other docs.

- Bernie (from iPhone)

> On Nov 6, 2015, at 9:57 AM, dhcpv6bis issue tracker <[email-masked]> wrote:
> 
> _______________________________________________
> Dhcpv6bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: "dhcpv6bis issue tracker" <[email-masked]>
Date: Fri, 06 Nov 2015 01:07:33 -0000

Comment (by [email-masked]):

 Previous discussions at the 6man ML may also help.  See
 https://mailarchive.ietf.org/arch/msg/ipv6/hZn982K2BuYVc9C0coqYTOZ8Sr0 and
 some of its followups.

-- 
-------------------------------+-------------------------
 Reporter:  [email-masked]  |       Owner:
     Type:  errata             |      Status:  new
 Priority:  P3 major           |   Milestone:
Component:  XML 3315           |  Resolution:
 Keywords:                     |    Due Date:  31/12/2015
-------------------------------+-------------------------

Ticket URL: <http://trac.tools.ietf.org/group/dhcpv6bis/ticket/153#comment:1>
dhcpv6bis <http://tools.ietf.org/group/dhcpv6bis/>