Subject: [Dhcpv6bis] Proposed slide deck for Berlin presentation

From: Tomek Mrugalski <[email-masked]>
Date: Tue, 12 Jul 2016 17:32:07 +0200

Folks,
Here's a proposed slide deck for the Berlin presentation. Please review.

As discussed on the call last week, some o us volunteered to cover part
of the things we did change. I went over the changelog and picked the
changes I think are worth mentioning. Each of the volunteers have 2
slides with 7 bullets on each. Feel free to adjust you slides as you
want. The idea here is to mention the spirit of the change and possibly
why we did it, not necessarily go into too much details. Obviously, some
changes require more technical explanation than others.

Thanks to Tim, Marcin, Bernie and I suppose myself :) for volunteering.

Please update your slides and send them back to either Bernie or myself.
We will merge your changes and will go through the updated slide deck in
Berlin during dhcpv6bis meeting.

Although the agenda says 15 minutes, we will actually have much more
time. If you think it's useful, feel free to add extra slides.

Details are TBD, but I was thinking that everyone could present their
own slides. That's the reason why my part is first as I'll be likely the
one doing the initial part of the presentation.

Tomek

p.s.
If you haven't done so, please vote in the doodle Bernie sent couple
days ago (http://doodle.com/poll/znese2i3edh7vnp6).

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 12 Jul 2016 17:23:30 +0000

Tomek, et al:

Here's a slightly updated version -- added reviewers that volunteered at IETF-95 and also revised the change log entries (removed returns/spaces which generally made the text larger).

I'm not sure what you want us to do with the changelog items. Is the intent for us to prune this list further or modify the material in some way?

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Tuesday, July 12, 2016 11:32 AM
To: [email-masked]
Subject: [Dhcpv6bis] Proposed slide deck for Berlin presentation

Folks,

As discussed on the call last week, some o us volunteered to cover part of the things we did change. I went over the changelog and picked the changes I think are worth mentioning. Each of the volunteers have 2 slides with 7 bullets on each. Feel free to adjust you slides as you want. The idea here is to mention the spirit of the change and possibly why we did it, not necessarily go into too much details. Obviously, some changes require more technical explanation than others.

Please update your slides and send them back to either Bernie or myself.
We will merge your changes and will go through the updated slide deck in Berlin during dhcpv6bis meeting.

Although the agenda says 15 minutes, we will actually have much more time. If you think it's useful, feel free to add extra slides.

Details are TBD, but I was thinking that everyone could present their own slides. That's the reason why my part is first as I'll be likely the one doing the initial part of the presentation.

Tomek

p.s.
If you haven't done so, please vote in the doodle Bernie sent couple days ago (http://doodle.com/poll/znese2i3edh7vnp6).

---

From: Tomek Mrugalski <[email-masked]>
Date: Tue, 12 Jul 2016 19:48:01 +0200

> Here's a slightly updated version -- added reviewers that volunteered at IETF-95 and also revised the change log entries (removed returns/spaces which generally made the text larger).
Thanks!
> I'm not sure what you want us to do with the changelog items. Is the intent for us to prune this list further or modify the material in some way?
I simply copy-pasted the text from appendix. If you think it's ok as it
is, no need to change anything, but I thought that rewording and
reformatting in some cases would be useful. Also, please familiarize
yourself with the issues, so you're comfortable explaining what the
issue was about. I did participate in most of the discussions, but I
don't recall the details of many of them. So I'll need to go through
items on my slides to recap some of the details.

Tomek

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Jul 2016 16:37:16 -0400

This looks like a good thing to share on the mailing list.   What's the
goal of presenting it to the WG?

On Tue, Jul 12, 2016 at 1:48 PM, Tomek Mrugalski <[email-masked]
> wrote:

> > Here's a slightly updated version -- added reviewers that volunteered at
> IETF-95 and also revised the change log entries (removed returns/spaces
> which generally made the text larger).
> Thanks!
> > I'm not sure what you want us to do with the changelog items. Is the
> intent for us to prune this list further or modify the material in some way?
> _______________________________________________
> Dhcpv6bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcpv6bis
>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 12 Jul 2016 20:43:30 +0000

Ted:

I think the first and last part is good as it gives people a reminder of what this work was about, where it stands, and where people should focus their attending during the review AND that we are now asking for the careful reviews!!

The list of changes (which is already in the I-D) is less interesting and we either should drop most of it (since it really was already described in the high level review). I do think a review of the list is warranted and there may be a few items to note (but very few).

I haven’t scheduled the meeting yet for Berlin to review this, but that would be the place to finalize the materials.

-          Bernie

From: Ted Lemon [mailto:[email-masked]]
Sent: Tuesday, July 12, 2016 4:37 PM
To: Tomek Mrugalski <[email-masked]>
Cc: Bernie Volz (volz) <[email-masked]>; [email-masked]
Subject: Re: [Dhcpv6bis] Proposed slide deck for Berlin presentation

This looks like a good thing to share on the mailing list.   What's the goal of presenting it to the WG?

On Tue, Jul 12, 2016 at 1:48 PM, Tomek Mrugalski <[email-masked]<mailto:[email-masked]>> wrote:
Thanks!

Tomek

_______________________________________________
Dhcpv6bis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Jul 2016 16:52:45 -0400

The reason I'm bugging you about this is that it comes across as "we did
this, it's done, please drink some cod liver oil for us."   If there are
ideas that you want discussed, then it's worth bringing them up in the
meeting, but if it's just a status update, why is the mailing list not the
right place for that?

On Tue, Jul 12, 2016 at 4:43 PM, Bernie Volz (volz) <[email-masked]> wrote:

> Ted:
>
>
>
> I think the first and last part is good as it gives people a reminder of
> what this work was about, where it stands, and where people should focus
> their attending during the review AND that we are now asking for the
> careful reviews!!
>
>
>
> The list of changes (which is already in the I-D) is less interesting and
> we either should drop most of it (since it really was already described in
> the high level review). I do think a review of the list is warranted and
> there may be a few items to note (but very few).
>
>
>
> I haven’t scheduled the meeting yet for Berlin to review this, but that
> would be the place to finalize the materials.
>
>
>
> -          Bernie
>
>
>
> *From:* Ted Lemon [mailto:[email-masked]]
> *Sent:* Tuesday, July 12, 2016 4:37 PM
> *To:* Tomek Mrugalski <[email-masked]>
> *Cc:* Bernie Volz (volz) <[email-masked]>; [email-masked]
> *Subject:* Re: [Dhcpv6bis] Proposed slide deck for Berlin presentation
>
>
>
> On Tue, Jul 12, 2016 at 1:48 PM, Tomek Mrugalski <
> [email-masked]> wrote:
>

---

From: Sheng Jiang <[email-masked]>
Date: Wed, 13 Jul 2016 03:38:47 +0000

Hi, Bernie and all,

The slide looks good. As Bernie mentioned by himself. The list of changes should be mostly dropped unless there are discussion we would like to raise.

A small type in the title of page 5, “Wait, buy why?”. I guess it should be “but”.

Cheers,

Sheng

From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Wednesday, July 13, 2016 4:44 AM
To: Ted Lemon; Tomek Mrugalski
Cc: [email-masked]
Subject: Re: [Dhcpv6bis] Proposed slide deck for Berlin presentation

Ted:

-          Bernie

From: Ted Lemon [mailto:[email-masked]]
Sent: Tuesday, July 12, 2016 4:37 PM
To: Tomek Mrugalski <[email-masked]<mailto:[email-masked]>>
Cc: Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dhcpv6bis] Proposed slide deck for Berlin presentation

Thanks!

Tomek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 13 Jul 2016 03:44:47 +0000

We have plenty of time in WG session (we got 2.5h when we asked for 2h). Drumming up reviewers is important for this work. It is a large document so providing folks a roadmap and where the likely landmines are is important. Reminding folks what the goal was is important.

I do agree we need do not need to go thru each of the edits but as Tomek says there may be a few worth pointing out and that is what we are tasked to do - review and drop those unnecessary to discuss which should be most (if not all).

- Bernie (from iPhone)

On Jul 12, 2016, at 4:53 PM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

The reason I'm bugging you about this is that it comes across as "we did this, it's done, please drink some cod liver oil for us."   If there are ideas that you want discussed, then it's worth bringing them up in the meeting, but if it's just a status update, why is the mailing list not the right place for that?

On Tue, Jul 12, 2016 at 4:43 PM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:
Ted:

I haven't scheduled the meeting yet for Berlin to review this, but that would be the place to finalize the materials.

-          Bernie

From: Ted Lemon [mailto:[email-masked]<mailto:[email-masked]>]

Thanks!

Tomek

---

From: Marcin Siodelski <[email-masked]>
Date: Wed, 13 Jul 2016 17:04:43 +0200

My quick reading of the current slide deck.

Slide 2: there is "what was the goal" and "what was not the goal", but
it strikes me that at this stage we should also say whether the goal has
been achieved, partially achieved or we're still heading towards the goal.

Part of the goal was to promote to internet standard. Given we have
reasons to not pursue promoting it to internet standard anymore, perhaps
we should at this point mention that and state why this is the case, or
perhaps defer it to some later slide?

"3363" => 3633

Slide 4: Careful audience would instantly see that, although we have
resolved large number of tickets, there are still 6 that we haven't. I
think we should explain why.

Slide 5: "Wait buy why" => "Wait but why"

Slide 16: Possible solutions: It seems to me that "Changing default DUID
type to DUID-LL" must go together with "Remove restriction: server MUST
NOT look into DUID content" to solve the problem. Even if you force
clients to use DUID-LL by default, you still need to interpret the DUID
contents.

Marcin

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 13 Jul 2016 15:06:42 +0000

Here's the latest version (I think). Fixed the issue Sheng raised (buy why) and also removed the slides of issues "assigned" to me. I think these are already covered in the material earlier and as the list is in the document, people can review it there -- there's nothing I think really has any additional worth mentioning.

- Bernie

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 14 Jul 2016 14:22:17 +0000

Here's a revised version that hopefully addresses Marcin's issues.

I'm wondering if for now we should remove the rest of the Changes slides and publish that version as part of the agenda. Those with assigned changes to review/discuss can always look at older slide deck to review and create new slides for what to discuss (if anything). Again, my feeling is we don't need to provide most of the details as they are already covered in the more general scope (slide 2, 6, and 7). Rehashing these items (especially as they are already in the document) is probably not productive. However, if we missed something on those slides, by all means we should considering mentioning it if important.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Marcin Siodelski
Sent: Wednesday, July 13, 2016 11:05 AM
To: Bernie Volz (volz) <[email-masked]>; Tomek Mrugalski <[email-masked]>; [email-masked]
Subject: Re: [Dhcpv6bis] Proposed slide deck for Berlin presentation

Slide 2: there is "what was the goal" and "what was not the goal", but it strikes me that at this stage we should also say whether the goal has been achieved, partially achieved or we're still heading towards the goal.

Part of the goal was to promote to internet standard. Given we have reasons to not pursue promoting it to internet standard anymore, perhaps we should at this point mention that and state why this is the case, or perhaps defer it to some later slide?

"3363" => 3633

Slide 4: Careful audience would instantly see that, although we have resolved large number of tickets, there are still 6 that we haven't. I think we should explain why.

Slide 16: Possible solutions: It seems to me that "Changing default DUID type to DUID-LL" must go together with "Remove restriction: server MUST NOT look into DUID content" to solve the problem. Even if you force clients to use DUID-LL by default, you still need to interpret the DUID contents.

Marcin

---

From: Marcin Siodelski <[email-masked]>
Date: Tue, 19 Jul 2016 12:12:14 +0200

The most recent version sent by Bernie does resolve my issues. Thanks!
I revised slides assigned to me, which contain detailed list of changes,
and I am ok to remove these slides, as they are covered by slide 6 or
include minor changes.

Marcin

On 14.07.2016 16:22, Bernie Volz (volz) wrote:
> I'm wondering if for now we should remove the rest of the Changes
> slides and publish that version as part of the agenda. Those with
> assigned changes to review/discuss can always look at older slide deck
> to review and create new slides for what to discuss (if anything).
> Again, my feeling is we don't need to provide most of the details as
> they are already covered in the more general scope (slide 2, 6, and
> 7). Rehashing these items (especially as they are already in the
> document) is probably not productive. However, if we missed something
> on those slides, by all means we should considering mentioning it if
> important.
>
> - Bernie
>
> To: Bernie Volz (volz) <[email-masked]>; Tomek Mrugalski
> <[email-masked]>; [email-masked]
> it strikes me that at this stage we should also say whether the goal
> has been achieved, partially achieved or we're still heading towards
> the goal.
>
> reasons to not pursue promoting it to internet standard anymore,
> perhaps we should at this point mention that and state why this is the
> case, or perhaps defer it to some later slide?
>
> "3363" => 3633
>
> Slide 16: Possible solutions: It seems to me that "Changing default
> DUID type to DUID-LL" must go together with "Remove restriction:
> server MUST NOT look into DUID content" to solve the problem. Even if
> you force clients to use DUID-LL by default, you still need to
> interpret the DUID contents.
>
> Marcin
>
> > Here's a slightly updated version -- added reviewers that
> volunteered at IETF-95 and also revised the change log entries
> (removed returns/spaces which generally made the text larger).
> >
> > As discussed on the call last week, some o us volunteered to cover
> part of the things we did change. I went over the changelog and picked
> the changes I think are worth mentioning. Each of the volunteers have
> 2 slides with 7 bullets on each. Feel free to adjust you slides as you
> want. The idea here is to mention the spirit of the change and
> possibly why we did it, not necessarily go into too much details.
> Obviously, some changes require more technical explanation than others.
> >
> > Details are TBD, but I was thinking that everyone could present
> their own slides. That's the reason why my part is first as I'll be
> likely the one doing the initial part of the presentation.
> >
> > Tomek
> >
> > p.s.