Subject: RE: [dhcwg] Router option, in DHCPv6

From: "Bound, Jim" <[email-masked]>
Date: Wed, 15 Sep 2004 06:46:00 -0400

IPv6 was designed to support router failover and avoid putting this
state in a stateful server. This was extensively discussed back in 1996
and then again in 1998.  Here is why and the reason why such idea(s)
have been rejected in the past.  A host can receive multiple RAs from
two different routers.  How the host defines its default or preferred
route from two routes is implementation defined.  Yes there is work for
router preferences I realize that, but that is not an issue, as whether
that is done or not implicit failover is achieved from the IPv6 link and
Neighbor Discovery architecture and protocol messaging.  Adding more
superferlous state to a stateless link is not congruent with the IPv6
architecture or with existing practice for IPv6 deployment and use
cases.  I suggest we leave RAs/RSs to routers and stateless, and
stateful to DHCPv6 which could be on a platform that can support holding
light state or serious heavy weight state like bzillions of records and
data.  So not only do I not see a compelling reason for this option or
thought process, but now after thinking about it believe it is in
conflict with the IPv6 architecture principals that are imperative to
the proper functioning of nodes for IPv6 deployment in practice.

Thanks
/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Ralph Droms
> Sent: Wednesday, September 15, 2004 4:00 AM
> To: Anil Kumar Reddy
> Cc: [email-masked]; 'Bernie Volz'; 'Robert Elz'
> Subject: RE: [dhcwg] Router option, in DHCPv6 
> 
> Anil - the scenario you describe falls, I think, in the class 
> of scenarios kre described:
> 
> >But, it might be perhaps useful to be able to configure a particular 
> >router on a net with several - and perhaps different routers for 
> >different hosts, which is something that RAs cannot achieve, so the 
> >option shouldn't necessarily simply be discarded as 
> completely useless.
> 
> Do we have any reason to believe, at this point, that load 
> balancing through explicit default router assignment will be 
> used in practice?
> 
> - Ralph
> 
> At 12:10 PM 9/15/2004 +0530, Anil Kumar Reddy wrote:
> 
> >Thanks for your responses. Sorry for the delay in my response.
> >
> >I have a question :
> >Take a case of load balancing, where two routers present and
> >  we want to manage/configure few set of hosts (address range)
> >  to use one router and others to use a different one (two
> >  paths), how do we achieve this using RAs ?
> >
> >--
> >Thanks,
> >Anil
> >
> >: -----Original Message-----
> >: From: Bernie Volz [mailto:[email-masked]]
> >: Sent: Saturday, September 11, 2004 7:36 PM
> >: To: 'Robert Elz'; 'Anil Kumar Reddy'
> >: Cc: [email-masked]
> >: Subject: RE: [dhcwg] Router option, in DHCPv6
> >:
> >: I agree. We do not need this option.
> >:
> >: If someone can demonstrate a solid need for this (either a
> >: list of default routers or list of static routes), we will
> >: consider this. But if you have no solid use case, this should
> >: be outside the scope of DHCPv6.
> >:
> >: In IPv4, there was no basic mechanism for a host to find
> >: router(s) and to discover whether addresses are on or off
> >: link (ICMP messages were added later, but I think they've
> >: been little used). This is a basic feature of IPv6.
> >:
> >: - Bernie
> >:
> >: > -----Original Message-----
> >: > From: [email-masked]
> >: [mailto:[email-masked]] On Behalf
> >: > Of Robert Elz
> >: > Sent: Friday, September 10, 2004 3:00 PM
> >: > To: Anil Kumar Reddy
> >: > Cc: [email-masked]
> >: > Subject: Re: [dhcwg] Router option, in DHCPv6
> >: >
> >: >
> >: >     Date:        Fri, 10 Sep 2004 19:32:22 +0530
> >: >     From:        "Anil Kumar Reddy" <[email-masked]>
> >: >     Message-ID:  <[email-masked]>
> >: >
> >: >   |         I feel, having a router configuration option
> >: (similar to
> >: >   |         DNS, SIP, NIS) would help the client's network
> >: connectivity
> >: >   |         in the absence of RA.
> >: >
> >: > As a rationale, that's useless.   If there are no RAs, 
> there are no
> >: > routers, RAs in v6 aren't optional.
> >: >
> >: > But, it might be perhaps useful to be able to configure a
> >: particular
> >: > router on a net with several - and perhaps different routers for
> >: > different hosts, which is something that RAs cannot 
> achieve, so the
> >: > option shouldn't necessarily simply be discarded as completely
> >: > useless.
> >: >
> >: > Whether the benefit in allowing this is worth the extra
> >: complexity I'm
> >: > not sure I'd like to take a position on at the minute.
> >: >
> >: > kre
> >: >
> >: >
> >: > _______________________________________________
> >: > dhcwg mailing list
> >: > [email-masked]
> >: > https://www1.ietf.org/mailman/listinfo/dhcwg
> >: >
> >:
> >:
> >
> >
> >
> >_______________________________________________
> >dhcwg mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/dhcwg
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Anil Kumar Reddy" <[email-masked]>
Date: Wed, 15 Sep 2004 18:45:06 +0530

Jim et. al, 

: A host can receive multiple RAs from two different 
: routers.  How the host defines its default or preferred route 
: from two routes is implementation defined.  Yes there is work 
: for router preferences I realize that, but that is not an 
: issue, as whether that is done or not implicit failover is 
: achieved from the IPv6 link and Neighbor Discovery 
: architecture and protocol messaging.

This leaves hosts to decide which path to take, so I feel, there
 is no control over "managing the network". This also makes me to
 ask one basic question: why do we need stateful, dhcpv6, mechanism ?

And, just to be clear from my side, here the case is not with 
 respect to failover mechanism and it is with respect to load
 balancing/distribution over two paths.

Please clarify if I am wrong on any point.

--
Thanks,
Anil

: Adding more 
: superferlous state to a stateless link is not congruent with 
: the IPv6 architecture or with existing practice for IPv6 
: deployment and use cases.  I suggest we leave RAs/RSs to 
: routers and stateless, and stateful to DHCPv6 which could be 
: on a platform that can support holding light state or serious 
: heavy weight state like bzillions of records and data.  So 
: not only do I not see a compelling reason for this option or 
: thought process, but now after thinking about it believe it 
: is in conflict with the IPv6 architecture principals that are 
: imperative to the proper functioning of nodes for IPv6 
: deployment in practice.
: 
: Thanks
: /jim
: 
: > -----Original Message-----
: > From: [email-masked] 
: [mailto:[email-masked]] On Behalf 
: > Of Ralph Droms
: > Sent: Wednesday, September 15, 2004 4:00 AM
: > To: Anil Kumar Reddy
: > Cc: [email-masked]; 'Bernie Volz'; 'Robert Elz'
: > Subject: RE: [dhcwg] Router option, in DHCPv6
: > 
: > Anil - the scenario you describe falls, I think, in the class of 
: > scenarios kre described:
: > 
: > >But, it might be perhaps useful to be able to configure a 
: particular 
: > >router on a net with several - and perhaps different routers for 
: > >different hosts, which is something that RAs cannot 
: achieve, so the 
: > >option shouldn't necessarily simply be discarded as
: > completely useless.
: > 
: > Do we have any reason to believe, at this point, that load 
: balancing 
: > through explicit default router assignment will be used in practice?
: > 
: > - Ralph
: > 
: > At 12:10 PM 9/15/2004 +0530, Anil Kumar Reddy wrote:
: > 
: > >Thanks for your responses. Sorry for the delay in my response.
: > >
: > >I have a question :
: > >Take a case of load balancing, where two routers present and
: > >  we want to manage/configure few set of hosts (address range)
: > >  to use one router and others to use a different one (two
: > >  paths), how do we achieve this using RAs ?
: > >
: > >--
: > >Thanks,
: > >Anil
: > >
: > >: -----Original Message-----
: > >: From: Bernie Volz [mailto:[email-masked]]
: > >: Sent: Saturday, September 11, 2004 7:36 PM
: > >: To: 'Robert Elz'; 'Anil Kumar Reddy'
: > >: Cc: [email-masked]
: > >: Subject: RE: [dhcwg] Router option, in DHCPv6
: > >:
: > >: I agree. We do not need this option.
: > >:
: > >: If someone can demonstrate a solid need for this (either a
: > >: list of default routers or list of static routes), we will
: > >: consider this. But if you have no solid use case, this should
: > >: be outside the scope of DHCPv6.
: > >:
: > >: In IPv4, there was no basic mechanism for a host to find
: > >: router(s) and to discover whether addresses are on or off
: > >: link (ICMP messages were added later, but I think they've
: > >: been little used). This is a basic feature of IPv6.
: > >:
: > >: - Bernie
: > >:
: > >: > -----Original Message-----
: > >: > From: [email-masked]
: > >: [mailto:[email-masked]] On Behalf
: > >: > Of Robert Elz
: > >: > Sent: Friday, September 10, 2004 3:00 PM
: > >: > To: Anil Kumar Reddy
: > >: > Cc: [email-masked]
: > >: > Subject: Re: [dhcwg] Router option, in DHCPv6
: > >: >
: > >: >
: > >: >     Date:        Fri, 10 Sep 2004 19:32:22 +0530
: > >: >     From:        "Anil Kumar Reddy" <[email-masked]>
: > >: >     Message-ID:  <[email-masked]>
: > >: >
: > >: >   |         I feel, having a router configuration option
: > >: (similar to
: > >: >   |         DNS, SIP, NIS) would help the client's network
: > >: connectivity
: > >: >   |         in the absence of RA.
: > >: >
: > >: > As a rationale, that's useless.   If there are no RAs, 
: > there are no
: > >: > routers, RAs in v6 aren't optional.
: > >: >
: > >: > But, it might be perhaps useful to be able to configure a
: > >: particular
: > >: > router on a net with several - and perhaps different 
: routers for
: > >: > different hosts, which is something that RAs cannot
: > achieve, so the
: > >: > option shouldn't necessarily simply be discarded as completely
: > >: > useless.
: > >: >
: > >: > Whether the benefit in allowing this is worth the extra
: > >: complexity I'm
: > >: > not sure I'd like to take a position on at the minute.
: > >: >
: > >: > kre
: > >: >
: > >: >
: > >: > _______________________________________________
: > >: > dhcwg mailing list
: > >: > [email-masked]
: > >: > https://www1.ietf.org/mailman/listinfo/dhcwg
: > >: >
: > >:
: > >:
: > >
: > >
: > >
: > >_______________________________________________
: > >dhcwg mailing list
: > >[email-masked]
: > >https://www1.ietf.org/mailman/listinfo/dhcwg
: > 
: > 
: > _______________________________________________
: > dhcwg mailing list
: > [email-masked]
: > https://www1.ietf.org/mailman/listinfo/dhcwg
: > 
: 
:

---

From: "Bernie Volz" <[email-masked]>
Date: Wed, 15 Sep 2004 09:36:18 -0400

How about this:

     Inbound load balancing - Nodes with replicated interfaces may want
           to load balance the reception of incoming packets across
           multiple network interfaces on the same link.  Such nodes
           have multiple link-layer addresses assigned to the same
           interface.  For example, a single network driver could
           represent multiple network interface cards as a single
           logical interface having multiple link-layer addresses.

-->        Load balancing is handled by allowing routers to omit the
-->        source link-layer address from Router Advertisement packets,
-->        thereby forcing neighbors to use Neighbor Solicitation
-->        messages to learn link-layer addresses of routers.  Returned
-->        Neighbor Advertisement messages can then contain link-layer
-->        addresses that differ depending on who issued the
-->        solicitation.

See http://www.ietf.org/internet-drafts/draft-ietf-ipv6-2461bis-00.txt.

There is no need to duplicate functionality that already exists elsewhere.

- Bernie Volz

> From: Anil Kumar Reddy [mailto:[email-masked]] 
> Sent: Wednesday, September 15, 2004 9:15 AM
> To: 'Bound, Jim'; 'Ralph Droms'
> This leaves hosts to decide which path to take, so I feel, 
> there  is no control over "managing the network". This also 
> makes me to  ask one basic question: why do we need stateful, 
> dhcpv6, mechanism ?
> 
> : > >: >     Message-ID:  
> <[email-masked]>
> : > >: >