Subject: [dhcwg] Server Unicast Option in DCHPv6

From: Suman <[email-masked]>
Date: Fri, 03 Sep 2004 10:50:09 +0530

Hi,
 
      I need some clarification on the Server Unicast Option, in DHCPv6,
RFC 3315. 
 
In particular, when the client receives a Server Unicast option in an
advertise message and it has to send a request message to that server,
it unicasts the message to the server. That apart, should the client
include Server Unicast Option in the Request message that it sends? 
 
Also, all the subsequent transaction between the client and that server
has to be unicast, if I have got it right! Does the client need to
include this option in all the subsequent message exchanges, Request
message in particular?
 
Any insight into this would be greatly appreciated. 
 
Regards,
Suman.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz" <[email-masked]>
Date: Sat, 4 Sep 2004 16:31:43 -0400

The unicast option is only server to client; not client to server. So, no
the client does not send the option.

There is no hard requirement for a client to use unicast. From the option
description in RFC 3315:

   The server specifies the IPv6 address to which the client is to send
   unicast messages in the server-address field.  When a client receives
   this option, where permissible and appropriate, the client sends
                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   messages directly to the server using the IPv6 address specified in
   the server-address field of the option.

   When the server sends a Unicast option to the client, some messages
   from the client will not be relayed by Relay Agents, and will not
   include Relay Agent options from the Relay Agents.  Therefore, a
   server should only send a Unicast option to a client when Relay
   Agents are not sending Relay Agent options.  A DHCP server rejects
   any messages sent inappropriately using unicast to ensure that
   messages are relayed by Relay Agents when Relay Agent options are in
   use.

   Details about when the client may send messages to the server using
   unicast are in section 18.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Suman
Sent: Friday, September 03, 2004 1:20 AM
To: [email-masked]
Subject: [dhcwg] Server Unicast Option in DCHPv6

Hi,
 
      I need some clarification on the Server Unicast Option, in DHCPv6, RFC
3315. 
 
In particular, when the client receives a Server Unicast option in an
advertise message and it has to send a request message to that server, it
unicasts the message to the server. That apart, should the client include
Server Unicast Option in the Request message that it sends? 
 
Also, all the subsequent transaction between the client and that server has
to be unicast, if I have got it right! Does the client need to include this
option in all the subsequent message exchanges, Request message in
particular?

Regards,
Suman.

---

From: "Anil Kumar Reddy" <[email-masked]>
Date: Fri, 10 Sep 2004 19:32:22 +0530

Hi All,

	I would like to know your inputs on having the router 
	option in dhcpv6.

	I feel, having a router configuration option (similar to 
	DNS, SIP, NIS) would help the client's network connectivity 
	in the absence of RA.

	Are there any reasons, not to consider this ?

	Let me know if this topic is already discussed and I should
	refer to that before discussing this, in WG.

--
Thanks & Regards,
Anil

---

From: Robert Elz <[email-masked]>
Date: Sat, 11 Sep 2004 02:00:08 +0700

Date:        Fri, 10 Sep 2004 19:32:22 +0530
    From:        "Anil Kumar Reddy" <[email-masked]>
    Message-ID:  <[email-masked]>

  | 	I feel, having a router configuration option (similar to 
  | 	DNS, SIP, NIS) would help the client's network connectivity 
  | 	in the absence of RA.

As a rationale, that's useless.   If there are no RAs, there are no
routers, RAs in v6 aren't optional.

But, it might be perhaps useful to be able to configure a particular
router on a net with several - and perhaps different routers for
different hosts, which is something that RAs cannot achieve, so the
option shouldn't necessarily simply be discarded as completely useless.

Whether the benefit in allowing this is worth the extra complexity I'm
not sure I'd like to take a position on at the minute.

kre

---

From: "Bernie Volz" <[email-masked]>
Date: Sat, 11 Sep 2004 10:05:57 -0400

I agree. We do not need this option.

If someone can demonstrate a solid need for this (either a list of default
routers or list of static routes), we will consider this. But if you have no
solid use case, this should be outside the scope of DHCPv6. 

In IPv4, there was no basic mechanism for a host to find router(s) and to
discover whether addresses are on or off link (ICMP messages were added
later, but I think they've been little used). This is a basic feature of
IPv6.

- Bernie

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Robert Elz
> Sent: Friday, September 10, 2004 3:00 PM
> To: Anil Kumar Reddy
> Cc: [email-masked]
> Subject: Re: [dhcwg] Router option, in DHCPv6 
> 
> 
> But, it might be perhaps useful to be able to configure a 
> particular router on a net with several - and perhaps 
> different routers for different hosts, which is something 
> that RAs cannot achieve, so the option shouldn't necessarily 
> simply be discarded as completely useless.
> 
> Whether the benefit in allowing this is worth the extra 
> complexity I'm not sure I'd like to take a position on at the minute.
> 
> kre
> 
>

---

From: "Anil Kumar Reddy" <[email-masked]>
Date: Wed, 15 Sep 2004 12:10:56 +0530

Thanks for your responses. Sorry for the delay in my response.

I have a question :
Take a case of load balancing, where two routers present and 
 we want to manage/configure few set of hosts (address range)
 to use one router and others to use a different one (two 
 paths), how do we achieve this using RAs ?

--
Thanks,
Anil

: -----Original Message-----
: From: Bernie Volz [mailto:[email-masked]] 
: Sent: Saturday, September 11, 2004 7:36 PM
: To: 'Robert Elz'; 'Anil Kumar Reddy'
: Cc: [email-masked]
: Subject: RE: [dhcwg] Router option, in DHCPv6 
: 
: I agree. We do not need this option.
: 
: If someone can demonstrate a solid need for this (either a 
: list of default routers or list of static routes), we will 
: consider this. But if you have no solid use case, this should 
: be outside the scope of DHCPv6. 
: 
: In IPv4, there was no basic mechanism for a host to find 
: router(s) and to discover whether addresses are on or off 
: link (ICMP messages were added later, but I think they've 
: been little used). This is a basic feature of IPv6.
: 
: - Bernie
: 
: > -----Original Message-----
: > From: [email-masked] 
: [mailto:[email-masked]] On Behalf 
: > Of Robert Elz
: > Sent: Friday, September 10, 2004 3:00 PM
: > To: Anil Kumar Reddy
: > Cc: [email-masked]
: > Subject: Re: [dhcwg] Router option, in DHCPv6
: > 
: > 
: >     Date:        Fri, 10 Sep 2004 19:32:22 +0530
: >     From:        "Anil Kumar Reddy" <[email-masked]>
: >     Message-ID:  <[email-masked]>
: > 
: >   | 	I feel, having a router configuration option 
: (similar to 
: >   | 	DNS, SIP, NIS) would help the client's network 
: connectivity 
: >   | 	in the absence of RA.
: > 
: > As a rationale, that's useless.   If there are no RAs, there are no
: > routers, RAs in v6 aren't optional.
: > 
: > But, it might be perhaps useful to be able to configure a 
: particular 
: > router on a net with several - and perhaps different routers for 
: > different hosts, which is something that RAs cannot achieve, so the 
: > option shouldn't necessarily simply be discarded as completely 
: > useless.
: > 
: > Whether the benefit in allowing this is worth the extra 
: complexity I'm 
: > not sure I'd like to take a position on at the minute.
: > 
: > kre
: > 
: > 
: > _______________________________________________
: > dhcwg mailing list
: > [email-masked]
: > https://www1.ietf.org/mailman/listinfo/dhcwg
: > 
: 
:

---

From: Ralph Droms <[email-masked]>
Date: Wed, 15 Sep 2004 03:59:51 -0400

Anil - the scenario you describe falls, I think, in the class

>option shouldn't necessarily simply be discarded as completely useless.

Do we have any reason to believe, at this point, that load balancing
through explicit default router assignment will be used in practice?

- Ralph