Subject: [dhcwg] get a DHCP server to send me a NAK

From: Malek John-AJM240 <[email-masked]>
Date: Mon, 14 Feb 2005 15:55:03 -0600

Can anyone tell  me how I can get a DHCP server to send me a NAK response to a request.

What I am doing is testing a DHCP quick response feature. The router sends out DHCP Discover then gets DHCP Offer back takes the ip address and gives it to client and then sends out DHCP Request and gets DHCP ACK back. This all works good but if we get a DHCP NACK we will tear down the tunnel and the ip address will not be used and client will resend DHCP Discover.

 My problem is I cannot figure out a way to get this NACK.

If I capture the ACK could I just change a field in the packet and then replay it back?

What field would I change?

Any other ideas?

Thanks in advance to anyone that could help me with this problem.

Ps we do the quick response because some times the clients context would time out befor getting the DHCP ACK.

John/

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Tue, 15 Feb 2005 08:39:42 -0800

> Can anyone tell  me how I can get a DHCP server to send me a NAK response to a request.

The not-implementation-specific ways to get a server to generate a
NAK is to make a REQUEST with a requested-address which is either not on
the subnet to which the device is attached, or an address that is already
in use (doesn't belong to the client).

There are also usually implementation-specific ways of generating a NAK,
usually some form of access list or prohibition...how to do this is
specific to each DHCP server implementation.

> If I capture the ACK could I just change a field in the packet and then replay it back?

Not quite.  Look at rfc2131 table 3.  ACKs and NAKs may very well be
formed entirely differently.

> Any other ideas?

If the client is participating in DHCP, wouldn't it be cleaner for the
router to participate as a DHCP Relay rather than trying to proxy
responses?

-- 
David W. Hankins		"If you don't do it right the first time,
Software Engineer			you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg