Subject: Re: [dhcwg] IPv6 prefix delegation extension

From: Mark Thompson <[email-masked]>
Date: Tue, 15 Feb 2005 18:21:58 +0000

On Feb 15, 2005, at 18:10, Changming Liu wrote:

> Is it typical that the prefix from r1 to r2 is manually assigned by ISP
> and r2 to r3 is assigned via DHCP PD (if r3 is a CPE router)?

I think it is reasonable for an ISP to assign by DHCP PD, and likewise 
reasonable for the Enterprise to assign to sites using DHCP PD also. It 
strikes me as a useful feature if this could work in such a chain.

> Or if the r2's DHCP implementation allows, r2 can act as the requesting
> router while r1 is the delegating router in the 1st PD and r2 acts as
> the delegating router and r3 acts as the requesting router in the 2nd
> PD. Will this work?

That was my question, but worded better.

Mark/

> -----Original Message-----
>>
>
> What would the signalling look like for R2 to announce (renumber?) to
> its downstream (R3) when R1 delegates to R2?
>
> +---------------+
> |    R1 (ISP)   |
> +-------+-------+      |
>          |              |   2001:db8::/48
>          |              |
>          |              V
> +-------+-------+
> |   R2 (Ent.)   |
> +-------+-------+
>          |              |
>          |              |   2001:db8:babe::/52
>          |              |
> +-------+-------+      V
> |   R3 (Site)   |
> +---------------+

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Changming Liu" <[email-masked]>
Date: Tue, 15 Feb 2005 10:10:16 -0800

CHangming

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Mark Thompson
Sent: Tuesday, February 15, 2005 5:05 AM
To: <[email-masked]> <[email-masked]>
Subject: Re: [dhcwg] IPv6 prefix delegation extension

On Feb 14, 2005, at 17:53, Changming Liu wrote:

> Will this make the PD more complicated, hard to implement and hard to
> configure as well? Is it possible to run DHCP PD at each hop down the
> tree?

+---------------+
|    R1 (ISP)   |
+-------+-------+      |
         |              |   2001:db8::/48
         |              |
         |              V
+-------+-------+
|   R2 (Ent.)   |
+-------+-------+
         |              |
         |              |   2001:db8:babe::/52
         |              |
+-------+-------+      V
|   R3 (Site)   |
+---------------+

Mark/