Subject: RE: [dhcwg] Re: One more question

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sat, 5 Nov 2005 10:37:20 -0500

Isn't perhaps considering revising 3315 to move it along the standards
track perhaps a better option? There are a few other errata we can
include?

Perhaps something to discuss at the DHC WG meeting next week?

- Bernie 

> -----Original Message-----
> From: Ralph Droms (rdroms) 
> Sent: Saturday, November 05, 2005 7:42 AM
> To: Ted Lemon
> Cc: Bernie Volz (volz); [email-masked]; JINMEI Tatuya / ????; 
> Shengyou Zeng (szeng); D. R. Evans
> Subject: Re: [dhcwg] Re: One more question
> 
> I would prefer to extend RFC 3315 to allow the server to 
> specify Rebind
> as well as Renew (and Information-request).
> 
> Any volunteers to write up a one-pager draft for this extension?
> 
> - Ralph
> 
> On Sat, 2005-11-05 at 01:23 -0700, Ted Lemon wrote:
> > I think what you are proposing is an optimization, Bernie.  
>  That is, the 
> > downside to doing a REBIND every time is that in some cases 
> it creates 
> > slightly more work, but the outcome is still correct.   
> Whereas putting 
> > intelligence in the client to decide complicates the client 
> a bit, and 
> > increases the likelihood of non-conforming implementations 
> which actually 
> > behave incorrectly, in order to avoid the slightly less 
> optimal behavior.
> > 
> > I don't see any reason to think that it's worth making the 
> client more 
> > complicated here.   I think that what Jinmei proposes is 
> the right answer.
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Sat, 5 Nov 2005 10:19:28 -0700

> track perhaps a better option? There are a few other errata we can

I don't think it's time to try to advance the protocol yet, although a 
non-advancing revision would be okay by me - I don't know what the procedure 
is, though.   I seem to be done with all my current drafts; I don't mind 
writing your one-pager if you want me to, Ralph.