Subject: Re: [Geopriv] RE: [dhcwg] Re: I-D ACTION:draft-ietf-geopriv-dhcp-civil-07.txt

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 21 Nov 2005 18:02:47 -0500

Winterbottom, James wrote:
>>This does mean that a client has to make a possibly unpleasant choice
>>between not sending the information, and thus possibly making it
>>harder be located in an emergency or possibly having poorer service
>>in some other area, and sending it with no redistribution/retention
>>limits.
> 
> 
> [AJW] I simply don't understand this statement. If the end-point has its
> location, how is providing that location to a DHCP server going to
> assist with emergency call routing?

It's a bit of a stretch, but the logic would be something like:

- End point knows location, but client application doesn't know how to 
retrieve or use it (this would include all current IP telephony soft 
clients, for example);

- in an enterprise environment, the proxy server gets to ask the DHCP 
server for location information (and uses it for emergency call routing).

I agree that this is not a deployment scenario we should make the 
preferred outcome.

The more likely case is that this is used for network management ("find 
the misbehaving PC or phone").

> 
> My personal opinion is that allowing the transfer of location from the
> client to the server in this manner is a significant stretch of the
> intentions laid out in RFC-3694 and quite far reaching application and
> security implications. 
> 
> 
> Cheers
> James
> 
> ------------------------------------------------------------------------------------------------
> This message is for the designated recipient only and may
> contain privileged, proprietary, or otherwise private information.  
> If you have received it in error, please notify the sender
> immediately and delete the original.  Any unauthorized use of
> this email is prohibited.
> ------------------------------------------------------------------------------------------------
> [mf2]
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 21 Nov 2005 16:45:34 -0600

Cheers
James

---

From: Randall Gellens <[email-masked]>
Date: Mon, 21 Nov 2005 16:23:26 -0800

>  assist with emergency call routing?

I think you're right; I mentioned it because (IIRC) one of the 
arguments made here for using SHOULD NOT instead of MUST NOT for 
client->server was emergency services.

But the issue is the same either way: should the client have to 
choose between "ravish me" and a lower level of service?
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
I employ no person who smokes.      --- Thomas Edison
[Handwritten note by Edison to Henry Ford, April 26, 1914