Subject: [dhcwg] [Fwd: RFC-to-be: draft-ietf-dhc-bcmc-options-05.txt [I05-050617-0003]]

From: Ralph Droms <[email-masked]>
Date: Tue, 01 Nov 2005 06:54:25 -0500

I see where IANA is assigning new option codes from the options codes
newly made available by RFC 3942.  My instinct, not backed up my any
significant reasons, is to reuse option codes in the 0-127 range that
have been returned to the list of available options codes such as 88-89
(RFC 3679) first, before we go into the 128-254 range.

Any thoughts on this intuition before we make the assigned of 136-137
official?

- Ralph

-------- Forwarded Message --------
> From: [email-masked]
> Reply-To: [email-masked]
> To: [email-masked], [email-masked],
> [email-masked]
> Cc: [email-masked], [email-masked], [email-masked],
> [email-masked]
> Subject: RFC-to-be: draft-ietf-dhc-bcmc-options-05.txt
> [I05-050617-0003]
> Date: Mon, 31 Oct 2005 13:23:48 -0800
> Authors:
> 
> We have completed the IANA Actions for RFC-to-be:
> draft-ietf-dhc-bcmc-options-05.txt
> 
> We have registered the following:
> 
>    136     BCMCS Controller Domain Name list         
>    137     BCMCS Controller IPv4 address option
> 
> See: http://www.iana.org/assignments/bootp-dhcp-parameters
> 
>    33     OPTION_BCMCS_SERVER_D         
>    34     OPTION_BCMCS_SERVER_A 
> 
> See: http://www.iana.org/assignments/dhcpv6-parameters
> 
> Please take a look and let us know if these registrations are OK.  As soon as we receive your confirmation we will notify the RFC-Editor that the IANA Actions have been completed.
> 
> Thank you,
> 
> Michelle Cotton
> IANA
>                 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Tue, 1 Nov 2005 12:32:16 -0800

> (RFC 3679) first, before we go into the 128-254 range.

This isn't instinct; options this body has released from allocation in
the 0-127 range are measurably not well used.  We should all remember
the document, it was recent enough, and none of its contents stand out
in my mind as alarming.

Use of 136 in the wild is _not measurable_, which is not better.

As for option code 137, I believe that has been fielded by Neoware, as
part of some sort of "ezUpdate" type thing for their thin clients, and
use of it would be right out in my book.  At least for awhile.

> Any thoughts on this intuition before we make the assigned of 136-137

I am in strong support of using no 128+ options until all 0-127 reused
options are exhausted.

-- 
David W. Hankins		"If you don't do it right the first time,
Software Engineer			you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Fri, 04 Nov 2005 08:19:24 -0500

Having heard a couple of expressions of support and no objections, I
will contact IANA to ask that the currently unused option codes in the
range 1-127 be assigned first before any new assignments are made in the
128-254 range.

- Ralph