Subject: [dhcwg] Is the "Success" option neccessary?

From: "haoda" <[email-masked]>
Date: Tue, 31 Jan 2006 15:41:21 +0900

Hi,

I have a problem of Status Code option of DHCPv6.
We assume the DHCP messages exchange is running now.

The client send a Renew message to the server. If the server
cannot find  a client entry for the IA, the server returns the 
IA with "NoBinding" in the Reply message. 

At this time, does the Reply message need add a status code in the 
main part for the whole message?
Like this,

Reply
|
*----------Status Code option "Success"
|
|
*-----------IA option
             |
            *--------Status Code option "NoBinding"

I think at this time, the "Success" give the user 
not properly information. At other hand, the "Success"
status code looks no any use. So it can not appears in
the main part.

Is my understanding right?

Haoda

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Tue, 31 Jan 2006 11:52:01 -0500

There is no need to add a Success Status Code option to most of the
messages (only the Decline and Release explicitly indicate that a
Success Status Code option should be added).

- Bernie 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of haoda
> Sent: Tuesday, January 31, 2006 1:41 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [dhcwg] Is the "Success" option neccessary?
> 
> Hi,
>