Subject: RE: [dhcwg] re: Can IA_PD and IA_NA be transfered in one DHCPv6session?

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sat, 14 Jan 2006 09:23:36 -0500

The Cisco Network Registrar (6.2) DHCP server does allow you to do this.
You can request both stateful addresses and delegated prefixes in a
single request.

- Bernie 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of CTO YAN Renxiang
> Sent: Monday, January 09, 2006 1:12 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [dhcwg] re: Can IA_PD and IA_NA be transfered in one 
> DHCPv6session? 
> 
>  
> In your previous mail you wrote:
> 
> > 
> >    Can IA_PD and IA_NA options be transfered in one DHCPv6 session?
> > 
> > => I can't see any reasons this may not be supported.
> > 
> >    It seems some Prefix delegation do not support such feature. 
> > 
> > => you mean some implementations? IMHO there are some limited
> > (i.e., very lazy :-) implementations which don't support 
> multiple IAs
> > but this is far from to be the rule.
> 
> DHCP-0.10 (from sourceforge.net), which is based on KAME's 
> DHCP implementation,
> support only IA_PD or IA_NA. 
> 
> I try to allocate an IPv6 address for CPE, and an IPv6 prefix 
> for the home network during
> CPE's interaction with DHCP server, but I failed when use 
> DHCP-0.10 as an
> experimental test. 
> 
> I will check to see if other implementations have similar problem.
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Sun, 15 Jan 2006 11:50:10 -0700

> You can request both stateful addresses and delegated prefixes in a

Yup, that makes sense to me too.