Subject: [dhcwg] Can IA_PD and IA_NA be transfered in one DHCPv6 session?

From: "CTO YAN Renxiang" <[email-masked]>
Date: Fri, 6 Jan 2006 14:16:40 +0800

Hi, all,

Can IA_PD and IA_NA options be transfered in one DHCPv6 session?
It seems some Prefix delegation do not support such feature. 
Which RFC define or recommend it? Why?

RGs,
-Renxiang

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Francis Dupont <[email-masked]>
Date: Fri, 06 Jan 2006 09:35:09 +0100

In your previous mail you wrote:

=> I can't see any reasons this may not be supported.

=> you mean some implementations? IMHO there are some limited
(i.e., very lazy :-) implementations which don't support multiple IAs
but this is far from to be the rule.

=> RFC 3315 which defines IAs. As there should be at least one IA per
used type (NA/TA/PD) and per client interface, and IAs are identified
by IAIDs, this suggests multiple IAs are common...

Regards
   
[email-masked]

PS: TAHI DHCPv6 tests have a multiple IA configuration flag (I remember
because this flag is not documented so I'd to find what it is :-).