Subject: RE: [dhcwg] DHCP and HoA

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 3 Feb 2006 11:57:13 -0500

Ralph,

Thanks for the response. Basically, the scenario is this:

1. the mobile device attaches to the access router/NAS.

2. the mobile device sends a DHCPDISCOVER message.

3. upon receiving the DHCPDISCOVER, the DHCP server goes to the home AAA
or a DHCP server in the home domain (may be a different administrative
domain) and fetches an IP address that it can offer to the mobile
device.

4. the DHCP server responds back to mobile device with a DHCPOFFER
including the IP address it fetched from the home domain.

5. the mobile device sends back the DHCPREQUEST selecting the IP address
from DHCPOFFER....

So, in this scenario, the DHCP server in the visited domain has to
assign an IP address (HoA) which is from a different administrative
domain, and the IP address does not belong to any of its provisioned
pools.

Also, please see inline...

> -----Original Message-----
> From: Ralph Droms [mailto:[email-masked]]
> Sent: Thursday, February 02, 2006 2:27 PM
> To: Chowdhury, Kuntal; [email-masked]
> Subject: Re: [dhcwg] DHCP and HoA
> 
> Technically, a DHCP server can assign any address at all to a DHCP
client.
[KC>] OK

> Administratively, for a server belonging to admin domain B to hand out
an
> address belonging to admin domain A, there must be some sort of
mechanism
> (not defined in any DHCP sepcs) through which A informs B of what
> addresses
> to assign according and what policies to use for assigning those
> addresses.
> 
[KC>] In your example, is domain A telling domain B's DHCP server to
handout an IP address from a pool that is provisioned in domain B's DHCP
server or it is giving out an IP address (which is unknown to domain B)
to be assigned to the client? 

> The mechaimns could be anything - a phone call through which A tells B
> about
> a pool fof addresses to use or some TBD protocol through the
assignment
> process can be automated.
> 
[KC>] The scenario that I am talking about does not assume that domain A
and domain B's address spaces are closely coordinated. Also, domain A
doesn't necessarily specify an address range or a pool. It likely hands
out an IP address to be assigned to the client.

> Is this scenario the case in which a mobile device is attached to a
> foreign
> network without knowing what its HoA is?
> 
[KC>] Yes, most of the mobile devices are configured with dynamic
addresses (even HoAs) today. Hence, it is likely that the HoA is
dynamically assigned by the home domain and the visited domain has no
prior knowledge about the possible address that will be assigned.

> - Ralph
> 
> 
> On 2/2/06 1:31 PM, "Chowdhury, Kuntal"
<[email-masked]>
> wrote:
> 
> > Hi all,
> >
> > I have a question regarding the role of DHCP Server and IP address
> assignment
> > e.g. Mobile IP home address (HoA).
> >
> > Can a DHCP server in the visited domain handle an IP address (HoA)
that
> is
> > assigned by a different domain e.g. the home domain? By "handle" I
mean:
> can
> > it include this address (HoA) in the DHCP offer message (v4) or DHCP
> Reply
> > message (v6)?
> >
> > In some SDOs people are defining specs with this scenario, and I
want to
> check
> > with the experts on this mailing list whether this is perfectly
alright
> or
> > there are issues.
> >
> > Regards,
> > Kuntal Chowdhury
> > Starent Networks
> > +1-214-550-1416
> > [email-masked]
> >
> >
> >
> >
> >
> > _______________________________________________
> > dhcwg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Shengyou Zeng \(szeng\)" <[email-masked]>
Date: Mon, 6 Feb 2006 22:11:58 -0500

Hi Kuntal,
 
You seem to suggest that 
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Chowdhury, Kuntal
> Sent: Friday, February 03, 2006 11:57 AM
> To: Ralph Droms (rdroms); [email-masked]
> Subject: RE: [dhcwg] DHCP and HoA
> 
> Ralph,
> 

When does a mobile device send a DHCPDISCOVER?  The way I 
understand it, if a mobile device requests dynamically assigned 
IP address, it puts 0.0.0.0 in the HoA field of its RRQ.  The 
HAAA, upon receiving an RRQ with 0.0.0.0 in HoA, may acquire
an IP address from a DHCP server (dynamically) and then put
the dynamically assigned IP address in the RRP.  In other
words, the mobile device is not really acting as a DHCP client,
rather the AAA server acting as a DHCP client on behalf of the
client (proxy if you want to call it that).  

Is there some work modifying MIPv4 to make the mobile device
a DHCP client to directly acquire IP address from the home 
network (and the FA as a relay agent)?  If so, I might directly 
help there as I am involved in some mobile IP work.

> 
> 3. upon receiving the DHCPDISCOVER, the DHCP server 

This reference of "DHCP server" apparently is to a DHCP server
in the visited network?

> goes to the home AAA or a DHCP server in the home domain 

Here you seem to suggest one DHCP server acting as a client 
to another DHCP server.  Perhaps the first reference of DHCP 
server above you really mean the FA as a relay agent? 

> (may be a different administrative domain) and fetches an 
> IP address that it can offer to the mobile device.
> 
> 5. the mobile device sends back the DHCPREQUEST selecting the 
> IP address from DHCPOFFER....
> 

There are a lot of unresolved issues in this statement of yours.  
If you would like, unicast me and we can have a chat over phone.

-Shengyou

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Tue, 7 Feb 2006 14:11:16 -0500

Hello Shengyou,

Thanks for the response and please see inline...

> From: Shengyou Zeng (szeng) [mailto:[email-masked]]
> Sent: Monday, February 06, 2006 9:12 PM
> To: Chowdhury, Kuntal; Ralph Droms (rdroms); [email-masked]
[KC>] The MN is NOT running a Mobile IP Client. The MN is doing is
trying to acquire an IP address from the access network via DHCP. The
access node (AR or an access gateway) is receiving the DHCP message and
using a network based Mobile IP client (aka PMIP) to fetch an IP address
(HoA) from the home network (HA). Since the MN is exchanging DHCP
messages here with the access network, somehow the DHCP relay/server is
involved in this scenario. I am trying to clarify the correct behavior
of the DHCP nodes for this scenario.

> This reference of "DHCP server" apparently is to a DHCP server
[KC>] Yes. People seem to prefer using the term "DHCP proxy" for this
node instead. AFAIK, I don't think DHCP proxy is a well defined term in
IETF.

> server above you really mean the FA as a relay agent?
[KC>] The FA/NAS/PMIP Client cannot really have a DHCP relay function
here. If the HoA is assigned by the HA (from a local pool instead of a
DHCP server in the home network), there is no way for the DHCP relay to
change DHCPOFFER message to suggest the HoA instead (relay cannot modify
the IP address included in the DHCPOFFER.

> If you would like, unicast me and we can have a chat over phone.
[KC>] OK...you can call me at 214-550-1416. I am in US Central time
zone.