Subject: [dhcwg] DHCP and HoA

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 2 Feb 2006 13:31:23 -0500

Hi all,

I have a question regarding the role of DHCP Server and IP address assignment e.g. Mobile IP home address (HoA). 

Can a DHCP server in the visited domain handle an IP address (HoA) that is assigned by a different domain e.g. the home domain? By "handle" I mean: can it include this address (HoA) in the DHCP offer message (v4) or DHCP Reply message (v6)? 

In some SDOs people are defining specs with this scenario, and I want to check with the experts on this mailing list whether this is perfectly alright or there are issues.

Regards,
Kuntal Chowdhury
Starent Networks
+1-214-550-1416
[email-masked]

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Thu, 02 Feb 2006 15:27:01 -0500

Technically, a DHCP server can assign any address at all to a DHCP client.

Administratively, for a server belonging to admin domain B to hand out an
address belonging to admin domain A, there must be some sort of mechanism
(not defined in any DHCP sepcs) through which A informs B of what addresses
to assign according and what policies to use for assigning those addresses.

The mechaimns could be anything - a phone call through which A tells B about
a pool fof addresses to use or some TBD protocol through the assignment
process can be automated.

Is this scenario the case in which a mobile device is attached to a foreign
network without knowing what its HoA is?

- Ralph

On 2/2/06 1:31 PM, "Chowdhury, Kuntal" <[email-masked]>
wrote:

> Can a DHCP server in the visited domain handle an IP address (HoA) that is
> assigned by a different domain e.g. the home domain? By "handle" I mean: can
> it include this address (HoA) in the DHCP offer message (v4) or DHCP Reply
> message (v6)? 
> 
> In some SDOs people are defining specs with this scenario, and I want to check
> with the experts on this mailing list whether this is perfectly alright or
> there are issues.
> 
> Regards,
> Kuntal Chowdhury
> Starent Networks
> +1-214-550-1416