Subject: RE: [dhcwg] Is the "Success" option neccessary?

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Thu, 2 Feb 2006 08:51:43 -0500

Hi:

Let's look at this a bit differently ... As the "main" part of the
message has only a Success Status Code option and as the lack of a
Status Code option implies Success, I guess this would be OK.

While the IA's binding wasn't found, the remaining options in the Reply
and the Renew/Rebind of non-IA's was successful. (From 18.2.3 - "The
server includes other options containing configuration information to be
returned to the client as described in section 18.2.")

Likely, the client will transition to Request or Solicit because of the
NoBinding status anyway for at least that binding?

So, I'd guess it is acceptable. However, convention has it that expect
for a few cases, a Success Status Code option is not usually returned.

- Bernie

> -----Original Message-----
> From: haoda [mailto:[email-masked]] 
> Sent: Thursday, February 02, 2006 2:46 AM
> To: Bernie Volz (volz)
> Cc: [email-masked]
> Subject: RE: [dhcwg] Is the "Success" option neccessary?
> 
> Mr. Volz,
> 
> Thanks for your reply.
> Would you like to give me more detail info of this question.
> When Renew/Reply.
> If the server's reply message is like this,
> ("NoBinding" and "Success" are co-exist)
> > > Reply
> > > |
> > > *----------Status Code option "Success"
> > > |
> > > |
> > > *-----------IA option
> > >              |
> > >             *--------Status Code option "NoBinding"
> 
> Is the Reply message acceptble?
> Can I judge it is a invalid message?
> 
> Best regard yours,
> Haoda
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "haoda" <[email-masked]>
Date: Fri, 3 Feb 2006 11:16:09 +0900

Ｈｉ，Mr, Volz,

I'm very glad to get your reply so quickly.
Thanks.

> While the IA's binding wasn't found, the remaining options in 
> the Reply and the Renew/Rebind of non-IA's was successful. 
> (From 18.2.3 - "The server includes other options containing 
> configuration information to be returned to the client as 
> described in section 18.2.")
Based up, the "Success" can be thinked as a reply of other configuration
information for the client. But if the Reply message only includes
SID,CID, and IA options, it looks no other informations for client,
now dose the server still need reply a "Success" status code option 
in the Main part ?

> Likely, the client will transition to Request or Solicit 
> because of the NoBinding status anyway for at least that binding?
Sorry, I'm not very clear to the above text.
Dose it means actually the "NoBinding"status code is also a kind of
configuration information?So if the client receive the "Success" status
code, then it will send the next Request or Solicit message to get a
new address.

Is my understanding right?

Best regard yours,
Haoda