Subject: RE: [dhcwg] draft-ietf-dhc-server-override-03.txt returned to dhcWG for review (2nd call for review)

From: "Woundy, Richard" <[email-masked]>
Date: Sat, 18 Mar 2006 20:34:44 -0500

David,
 
I think it sets a very VERY BAD precedent to debate the technical validity and viability of an internet-draft, based *solely* on whether an individual software developer, or even multiple software developers from one company, are permitted to implement the specification.
 
In the very worst case, that means there is one less implementation of the specification.
 
Nothing forces the ISC to implement every IETF RFC, even as a non-profit 501(c)(3) corporation. ISC is beholden to its donation sources, not the IETF in general.
 
A number of companies that are active supporters today of TCP/IP and the IETF, were vigorously opposed to both in the late '80s and early '90s, through their non-participation in the IETF and non-implementation of TCP/IP and various related standards. But the IETF continued through "rough consensus and running code" -- and not through unanimous consent.
 
I would strongly urge folks to focus on technical issues (e.g. perceived conflicts with prior specifications) than on management issues.
 
-- Rich

________________________________

From: David W. Hankins [mailto:[email-masked]]
Sent: Fri 3/17/2006 2:08 PM
To: Ted Lemon
Cc: Margaret Wasserman; [email-masked]; Ralph Droms; Stig Venaas; Mark Townsley (townsley)
Subject: Re: [dhcwg] draft-ietf-dhc-server-override-03.txt returned to dhcWG for review (2nd call for review)

<snip>

> and as far as I can recall, Paul never fired me for it. 

Oddly enough, Paul has fired me. 

He hired me back shortly afterwards.  Something about not being able 
to find a replacement "crazy enough" to work on the codebase in 
question. 

But the message was pretty clear. 

It's not quite fair of me to impart that anecdote, however, since Paul 
was also never my boss at ISC (he said it, but he and I both knew he 
had to get someone else to agree to actually do it, or fire both of 
us). 

<snip>

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Sun, 19 Mar 2006 03:36:39 +0000

> I think it sets a very VERY BAD precedent to debate the technical validity and viability of an internet-draft, based *solely* on whether an individual software developer, or even multiple software…

If you believe that to be the case ("*solely*"), then I am afraid you
have very poorly read my missives on the subject.

-- 
David W. Hankins		"If you don't do it right the first time,
Software Engineer			you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins