Subject: RE: [dhcwg] dhc wg last call on "DHCPRelayAgentAssignmentNotification Option"

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Mon, 15 May 2006 12:09:04 -0400

David:

Most relay agents are in routers. That's what this option essentially
assumes.

If the relay agent isn't in the router, this option isn't very useful
unless the relay agent will take steps to perform the injection of the
routing information (and/or ACLs). This does require some out-of-scope
communication.

The point of this option is to avoid the need for the relay agent to
parse the Reply to the client (i.e., look inside that message). This
option is no worse than packet snooping and is better because the relay
doesn't have to look inside the client's packet. The server can "tell"
the relay (router) explicitly what to do (including providing all
prefixes or addresses the client may have on that link, rather than just
the ones that may be implicitly or explicitly in the Reply) -- for
example, in a Reply for a Release we DON'T include the addresses or
prefixes released. Yet, this option to the Relay CAN include that.

End of story.

If you want a reliable multiple-relay agent technique, please feel free
to design it. That isn't what we attempted to do here. We just felt it
useful to avoid the need for packet snooping.

- Bernie

> -----Original Message-----
> From: David W. Hankins [mailto:[email-masked]] 
> Sent: Monday, May 15, 2006 11:53 AM
> To: [email-masked]
> Subject: Re: [dhcwg] dhc wg last call on 
> "DHCPRelayAgentAssignmentNotification Option"
> 
> On Sat, May 13, 2006 at 10:03:26AM -0400, Bernie Volz (volz) wrote:
> > > So I think the question is: Does the Release only absolve 
> the client
> > > address binding, and not the prefix delegation binding?
> > 
> > The Release is supposed to "clear out" everything. As the client has
> > indicated that it is no longer using this information, it should be
> > removed and available to be potentially used by another 
> client (though
> > how soon thereafter is a matter of policy and allocation 
> algorithms on
> > the server).
> 
> Then Thomas is right: the reliability (or lack thereof) of the message
> passing channel is a problem you need to solve reliably, or else this
> doesn't work.
> 
> > > At IETF 64 (I think), I thought you told me the whole 
> question about
> > > how routing injection/withdrawal would work would be 
> completely out
> > > of scope for this work.
> > 
> > I think what I was talking about was the multiple 
> relay/router issue?
> 
> You honestly believe only 5% of DHCPv6 deployments with relay agents
> will use more than one relay on each network segment?
> 
> That's the largest reason I thought you jumped topics.
> 
> I'm really interested to know why you think 95% of networks want
> single points of failure in their DHCPv6 relay agent infrastructure.
> 
> This point of view is completely disjoint from my own.
> 
> > As
> > the draft proposes including information in the Relay-Reply 
> it will only
> > be seen by one of the routers and the issue of communicating this to
> > multiple redundant routers is what is out of scope for DHCP.
> 
> Sounds like yet another thing to gum up or break to me, but it also
> doesn't sound like my problem.
> 
> > Redundant
> > routers already have to deal with these kinds of issue?
> 
> Redundant DHCPv6 relays you mean?
> 
> Either way: not that I'm aware of.
> 
> Distributing routing information among multiple routers, sure, that's
> the whole point of routing protocols.
> 
> Distributing the need to inject that routing information?  Not that I
> know of.
> 
> Distributing held-state between relay agents?  Well, as relay agents
> are inherently stateless, that hasn't really been a need so far...
> 
> -- 
> David W. Hankins		"If you don't do it right the 
> first time,
> Software Engineer			you'll just have to do 
> it again."
> Internet Systems Consortium, Inc.		-- Jack T. Hankins
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Mon, 15 May 2006 09:28:21 -0700

> Most relay agents are in routers. That's what this option essentially

Am I to take this as an assertion, by a Cisco employee, that 95%
of networks use single point of failure routers?  Only 5% of networks
use redundant routers (and therefore redundant relay agents)?

I still can't follow this trail of bread crumbs you're leaving me.

> useful to avoid the need for packet snooping.

Fine, fine.

-- 
David W. Hankins		"If you don't do it right the first time,
Software Engineer			you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg