Subject: [dhcwg] RFC 4388: DHCP Leasequery

From: "pavan_kurapati" <[email-masked]>
Date: Tue, 2 May 2006 16:57:01 +0530

Hello,

I was going through RFC 4388 and I have a few queries regarding the same.

1. In case of Access concentrator being rebooted, sending lease query for each IP packet sent in downstream seems to be a performance hit. Can't it be done onetime when the access concentrator comes up. For eg, introduce another Leasequery type wherein server should respond with *ALL* the ip addresses belonging to that agent based on the giaddr field. Even if the subscriber list is huge the packet can still be fragmented and the relay agent can re-assemble the packet to get the subscriber information. This way, as soon as the access concentrator comes up it will get all the lease and IP binding information from the server before it starts forwarding the traffic.

2. Most of the DSLAMs in current deployments operate in Layer 2 mode hence doing only switching. They do DHCP snooping and maintain binding information but does not act as L3 relay agent. In such case, adding giaddr will not be possible by the DSLAM though it might still be interested in lease information after it resets. Such a case is not addressed in this RFC.

3. In case of L2 DSLAMs, if it wants to have information of all the clients connected to itself, it cannot query based on giaddr (as mentioned in point 1 ). In such case, the information of DSLAM should be checked from the Option 82 string itself by the server, provided that all the relay agent implementations concat the relay agent's information(like system name) along with remote-id information in the option 82. Is there any problem in this approach?

Thanks,
Pavan

Pavan Kumar Kurapati
Infosys Technologies Ltd,
Electronics city,
Hosur road, Bangalore
9448613789(M)
080-56646575(R)
080-51167492(O) or 28520261 Ext : 67492

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Andre Kostur <[email-masked]>
Date: Tue, 02 May 2006 06:44:31 -0700

> 1. In case of Access concentrator being rebooted, sending lease query for each IP packet sent in downstream seems to be a performance hit. Can't it be done onetime when the access concentrator come…

There would only be a leasequery for the first packet that a CPE sends, 
not every packet.  And, in probably any normal deployment, there is no 
way you're going to fit your entire population into one UDP packet.