Subject: [dhcwg] I-D ACTION:draft-ietf-dhc-implementation-02.txt

From: [email-masked]
Date: Fri, 16 Jun 2006 18:50:01 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration Working Group of the IETF.

	Title		: Implementation Issues with RFC 2131, "Dynamic Host Configuration Protocol (DHCPv4)"
	Author(s)	: R. Stevens, R. Hibbs
	Filename	: draft-ietf-dhc-implementation-02.txt
	Pages		: 41
	Date		: 2006-6-16
	
This memo identifies implementation issues with RFC 2131, "Dynamic 
Host Configuration Protocol," reported by a number of implementers, 
assesses the severity of the problem, then proposes changes to RFC 
2131 intended to overcome the issues.  This is intended for use as 
the basis for discussion of RFC 2131 before it is proposed for 
Internet Standard status.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-dhc-implementation-02.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-dhc-implementation-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-dhc-implementation-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Barr Hibbs" <[email-masked]>
Date: Sun, 18 Jun 2006 14:46:32 -0700

The RFC2131 Implementation Issues draft (based on work by
Mike Carney, then titled RFC2131 Nits) has been updated,
incorporating most of the major discussion topics from the
Working Group mailing list over the past few years.

The work item to produce the memo came from the need to
review RFC2131 before it is proposed as an
Internet-Standard.  The authors make no claim as what form,
if any, RFC2131 should be updated or the issues raised in
this memo are addressed by the DHC Working Group.

We have tried to present our recommendations in a simple,
straightforward way, with suggested text or replacement
diagrams where appropriate.

Please give this memo your attention and respond with
comments to the Mailing List.

Thanks,

--Barr

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Friday, June 16, 2006 15:50
To: [email-masked]
Cc: [email-masked]
Subject: [dhcwg] I-D
ACTION:draft-ietf-dhc-implementation-02.txt

---

From: "Barr Hibbs" <[email-masked]>
Date: Tue, 20 Jun 2006 09:43:12 -0700

Thanks for your reply, Shane....

I'll let Kim speak to the full underlying purposes of
Leasequery, but its original intent was to supply STATE
information about an existing or expired lease.

Inform, on the other hand, makes NO assumptions about the
existence of a lease, in fact, one fundamental purpose was
to configure clients that had been assigned a fixed address
and DID NOT use DHCP (or BOOTP) for address assignment, but
to gather useful client configuration information (e.g.,
addresses of NTP servers) from a DHCP server.

DHCPINFORM is rather widely used, in fact.

The authors fully recognize the impossibility of making
fundamental changes to a mature, widely used protocol and
intend no such interpretation.

The use of DHCP Authentication with Inform would be
problematic:  a DHCP server might not have ANY
client-specific identification information about the
requestor, in fact, it might be an application rather than
the host system requesting configuration data through
Inform.

There is a companion Internet-Draft recently published that
updates the DHCPv4 Threat Analysis and suggests using a
Pseudo-Random Number key generator instead of the Shared
Secret method for authenticating messages.  Although a PRN
could simplify key exchange significantly, it would still
require a registration process for clients and servers,
putting it at odds with the principle use of Inform.

--Barr

> From: Shane Kerr [mailto:[email-masked]]
> Sent: Tuesday, June 20, 2006 01:06
> To: Barr Hibbs; Rob Stevens
> Subject: Re: [dhcwg] I-D
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hello,
>
> In the RFC 2131 Implementation Issues draft, I
> saw the section on
> DHCPINFORM, and 3rd party DHCPINFORM requests. My
> first thought is that
> they were not necessary, as we have
> DHCPLEASEQUERY now. OTOH, DHCPINFORM
> is not about leases, it's about configuration information.
>
> The LEASEQUERY RFC kind of worked around the
> issue of exposing data by
> recommending DHCP authentication be used. Perhaps
> this is the correct
> approach for the DHCPINFORM section of your draft?
>
> Not 100% sure about how good DHCP authentication
> is in general, and I
> think it's pretty worthless for LEASEQUERY in
> particular, but I guess
> it's better than nothing. :)
>
> - --
> Shane
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.2.2 (GNU/Linux)
> Comment: Using GnuPG with Mozilla -
http://enigmail.mozdev.org

iD8DBQFEl6x7MsfZxBO4kbQRAlSjAJ9hD0NWdbO8kz4yUOxGU6THy42KywCe
OL8f
wKm6GqMMnTeZ9zP858FkKSQ=
=RPZQ

---

From: "Barr Hibbs" <[email-masked]>
Date: Tue, 20 Jun 2006 18:22:04 -0700

-----Original Message-----
From: Barr Hibbs [mailto:[email-masked]]
Sent: Tuesday, June 20, 2006 09:43
To: [email-masked]
Cc: Dhcwg
Subject: RE: [dhcwg] I-D

--Barr