Subject: [dhcwg] [Updated] DHCP Option for Home Information Discovery in MIPv6

From: Heejin Jang <[email-masked]>
Date: Tue, 20 Jun 2006 09:25:41 +0900

Hello folks,
We posted an I-D that proposes new DHCP Options for Home Information
Discovery in MIPv6.

Kindly note that the previous version of this draft is 
"draft-jang-dhc-haopt-02.txt" but the name is slightly changed into
"draft-jang-mip6-hiopt-00.txt" while keeping almost the same contents.

The drafts referencing this draft such as
draft-ietf-mip6-bootstrapping-split-02.txt and
draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt need to be revised
accordingly.

We would appreciate to hear your comments.

-------------------------------------------------------------------- 
Document title : DHCP Option for Home Information Discovery in MIPv6
Working group  : MIP6 & DHC
Authors : Hee Jin Jang, Alper Yegin, JinHyeock Choi and Kuntal Chowdhury
Filename : draft-jang-mip6-hiopt-00.txt

 Abstract : 
   This draft defines a DHCP-based scheme to enable dynamic discovery of
   Mobile IPv6 home agent address, home address, and home subnet.  New
   DHCP options are defined to carry the information from a DHCP server 
   to the DHCP client running on the mobile node.

-----------------------------------------------------------------------

Regards
- Heejin Jang

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Alper Yegin" <[email-masked]>
Date: Mon, 19 Jun 2006 22:36:21 -0700

Vijay,

As far as I remember you were the only one who didn't give up on pushing for
integration. It'd only be a circular discussion if I had repeated the
reasons for not bundling a bunch of protocol extensions in a single
document. 

But I hope this data point helps: WiMAX Forum NWG architecture is using
draft-jang. 

Alper

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: Monday, June 19, 2006 6:17 PM
> To: Heejin Jang
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Mip6] [Updated] DHCP Option for Home Information Discovery
> inMIPv6
> 
> Heejin Jang wrote:
> > Hello folks,
> when this draft was discussed in the MIP6 bootstrapping
> design team, many people wanted to integrate the two DHCP
> options into
> draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt.
> this was mainly because the options defined in the document
> have limited applicability beyond the integrated scenario
> solution document. the only other mechanism is to manually
> configure the DHCP servers in the visited link with
> information like home agent address, home address and home
> prefix. this is a bad idea.
> 
> there was some opposition and we never reached an agreement.
> 
> so I suggest including these options into the integrated
> scenario solution document for these options to get
> standardized quickly.
> 
> Vijay
> 
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Alper Yegin" <[email-masked]>
Date: Tue, 20 Jun 2006 11:27:23 -0700

> > integration.
> I think you remember wrong.

Can we hear from someone else who insists we shall bundle up the I-Ds?

> It'd only be a circular discussion if I had repeated the
> let the MIP6 WG hear the arguments again, since we couldn't
> reach a conclusion in the design team.

You really want us to circle around, don't you :-)

> in what context and how are they planning to use it? 

The MIP info is brought to the DHCP server via RADIUS and delivered to the
MN via DHCP.

> the
> WiMAX forum NWG can still use the DHCP options wherever
> they are defined.

Yes. And WiMAX Forum could also use it even if IETF had concatenated all of
the RFCs and I-Ds under a single document too.... This I-D being referenced
whereas the draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt wasn't is a
solid proof that the former I-D is useful without having to be integrated
into the latter.

> >>the only other mechanism is to manually

You know that one does not have to put DHCP servers on every subnet, instead
one can rely on DHCP relays. And that's the used technique for many
enterprise networks. So, I don't see why this is a bad idea.

Alper

---

From: "Alper Yegin" <[email-masked]>
Date: Tue, 20 Jun 2006 12:51:48 -0700

> and DHCP relay messages cross firewalls and network boundaries?
> come on...

I'm not talking about deploying DHCP across the Internet. Please see my text
above: enterprise networks.

Alper

---

From: "Gerardo Giaretta" <[email-masked]>
Date: Wed, 21 Jun 2006 10:17:35 +0200

Alper,

just one question below in order to understand if there is a real
technical reason to keep the docs separated..

> The MIP info is brought to the DHCP server via RADIUS and delivered to the

Can you please explain which are the technical differences between the
solution in the DT draft for integrated scenario and the solution
developped in WiMAX?

I guess in WiMAX MIP info are brought to DHCP relay (i.e. NAS) and
then draft-jang is applied. Is this really different from what is
described in the DT draft?

--Gerardo

---

From: "Alper Yegin" <[email-masked]>
Date: Wed, 21 Jun 2006 14:48:10 -0700

Gerardo,

I think it helps to understand the components of the full picture.

[a] Delivery of the info from home AAA to the NAS
[b] Delivery of the info from the NAS (DHCP relay) to the DHCP server.
[c] Delivery of the info from the DHCP server to the DHCP client
[d] Plumbing of all these components

[a], [b], and [c] are all protocol work. [d] is just informational. 

The document draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt covers [b]
and [d].

WiMAX does not use [b]. For that there is no need to have a normative
reference to draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt. It could
have an informative reference to it, but it does not have to.

Alper

> From: Gerardo Giaretta [mailto:[email-masked]]
> Sent: Wednesday, June 21, 2006 1:18 AM
> To: Alper Yegin
> Cc: Vijay Devarapalli; [email-masked]; Heejin Jang; [email-masked]
> Subject: Re: [dhcwg] RE: [Mip6] [Updated] DHCP Option for Home Information
> Discovery inMIPv6
> 
> Alper,
>

---

From: "Alper Yegin" <[email-masked]>
Date: Wed, 21 Jun 2006 23:17:04 -0700

Hi James,

> Hi Alper,
> I think this is a very good and clear description.
> 
> Lately, I've become really interested in seeing IETF do stuff that
> actually
> gets deployed. So, given that WiMax Forum doesn't need [b], do you think
> they might be willing to reference this document (and thereby we could see
> it deployed) if [b] were deleted?

I presume you are suggesting splitting [b] from the
draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt to a separate document.

In fact this was my original proposal: To have separate documents.

At the end of the day, what matters for interoperability is [a], [b], and
[c]. These are the components we want the SDOs to use (normatively
referenced). [d] is informational.

Alper

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 20 Jun 2006 11:42:32 -0700

> You really want us to circle around, don't you :-)

well, now you want the MIP6 WG to adopt draft-jang as a WG document,
right? then you need to make a case for it.

> The MIP info is brought to the DHCP server via RADIUS and delivered to the

this is very bad. the draft that describes how to use DHCPv6 for MIP6
bootstrapping is draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt. 
not *any other* draft. WiMAX NWG needs to be told that. the following
figure in draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt very
important for someone to understand how to use DHCPv6 for MIP6
bootstrapping.

    The following diagram shows the network elements and layout in the
    integrated scenario:

                                       |
                   ASP(/MSP)           |   ASA/MSA(/MSP)
                                       |
                                       |
                   +-------+           |        +-------+
                   |       |           |        |       |
                   |AAAV   |-----------|--------|AAAH   |
                   |       |           |        |       |
                   |       |           |        |       |
                   +-------+           |        +-------+
                       |               |
                       |               |
                       |               |
                       |               |
                       |               |
                       |               |
                       |               |
                   +-----+    +------+ |
       +----+      |     |    |DHCP  | |
       | MN |------| NAS/|----|Server| |
       +----+      |Relay|    |      | |
                   +-----+    +------+ |
                                       |
                                       |
                   +--------+          |      +--------+
                   | HA     |          |      | HA     |
                   | in ASP |          |      |in MSP  |
                   +--------+          |      +--------+

> solid proof that the former I-D is useful without having to be integrated

I am afraid the WiMAX NWG is referring to the wrong document. the
use of DHCPv6 for MIP6 bootstrapping is defined in
draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 20 Jun 2006 10:48:51 -0700

> But I hope this data point helps: WiMAX Forum NWG architecture is using

in what context and how are they planning to use it? the
WiMAX forum NWG can still use the DHCP options wherever
they are defined.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 20 Jun 2006 11:42:32 -0700

|

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 20 Jun 2006 10:48:51 -0700

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 21 Jun 2006 16:12:15 -0700

James Kempf wrote:
> actually gets deployed. 

this is hard. IETF does not move fast enough when somebody
sees a problem in a particular deployment. we are better off
designing good solutions. ;)

So, given that WiMax Forum doesn't need [b], do
> you think they might be willing to reference this document (and thereby 
> we could see it deployed) if [b] were deleted?

draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt specifies
[b] because someone brought up an issue of the NAS and the
DHCP server being not on the same box. [b] is not used if
the NAS and the DHCP server are on the same box. it would be
good to know if in WiMAX the NAS and the DHCP server are on
the same box?

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 21 Jun 2006 15:09:50 -0700

> The document draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt covers [b]

section 3.6 and 3.7 of 
draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt seem to describe [c].

Vijay

>>>>>But I hope this data point helps: WiMAX Forum NWG architecture is
>>
>>using
>>
>>>>>draft-jang.
>>>>
>>>The MIP info is brought to the DHCP server via RADIUS and delivered to
>>
>>the
>>
>>>MN via DHCP.
>>>
>>
>>>Yes. And WiMAX Forum could also use it even if IETF had concatenated all
>>
>>of
>>
>>>the RFCs and I-Ds under a single document too.... This I-D being
>>
>>referenced
>>
>>>whereas the draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt wasn't
>>
>>is a
>>
>>>solid proof that the former I-D is useful without having to be
>>
>>integrated
>>
>>>into the latter.
>>>
>>>
>>>
>>>You know that one does not have to put DHCP servers on every subnet,
>>
>>instead
>>
>>>>>>Subject: Re: [Mip6] [Updated] DHCP Option for Home Information
>>
>>Discovery
>>
>>>>>>inMIPv6
>>>>>>
>>>>>>Heejin Jang wrote:
>>>>>>
>>>>>>
>>>>>>>Hello folks,
>>>>>>>We posted an I-D that proposes new DHCP Options for Home
>>
>>Information
>>
>>>>>>>Discovery in MIPv6.
>>>>>>>
>>>>>>>"draft-jang-mip6-hiopt-00.txt" while keeping almost the same
>>
>>contents.
>>
>>>>>>>draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt need to be
>>
>>revised
>>
>>>>>>>accordingly.
>>>>>>>

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 21 Jun 2006 16:12:15 -0700

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 21 Jun 2006 15:09:50 -0700

section 3.6 and 3.7 of 

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 19 Jun 2006 18:17:23 -0700

Vijay