Subject: RE: [dhcwg] DHCP - VLANS

From: "Davis, Jesse M" <[email-masked]>
Date: Fri, 24 Feb 2006 20:10:07 -0800

Hi Sasi,

	In a multiple VLAN (subnet) design, one or more relay agents are
required to forward BBOTP/DHCP messages from each VLAN/subnet to the DHCP
server. Upon receiving a BOOTP/DHCP packet forwarded from a relay agent, the
GIADDR field reflects the source VLAN/subnet of the relay agent responsible
for forwarding DHCP/BOOTP packets to the server. The DHCP server can then
offer an appropriate IP address based on criteria such as available IP
address pool, pre-reserved reservation, VLAN to IP subnet mapping, etc.

Thanks,
Jesse 

-----Original Message-----
From: Sasi Kiran [mailto:[email-masked]] 
Sent: Tuesday, December 27, 2005 5:12 AM
To: [email-masked]
Subject: [dhcwg] DHCP - VLANS

Hi,

How would DHCP differentiates requests which are coming from different  
vlans and assign appropriate vlan base address to clients.

Thanks,
Sasi.

-- 
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Francis White" <[email-masked]>
Date: Wed, 27 Sep 2006 20:49:29 -0600

Some VLAN capable switches are also capable as being configured to act as
DHCP servers themselves.  This can be very handy for reducing overall
network congestion.

Francis
-----Original Message-----
From: Davis, Jesse M [mailto:[email-masked]] 
Sent: Friday, February 24, 2006 9:10 PM
To: 'Sasi Kiran'; [email-masked]
Subject: RE: [dhcwg] DHCP - VLANS

Hi Sasi,

Thanks,
Jesse 

-----Original Message-----
From: Sasi Kiran [mailto:[email-masked]] 
Sent: Tuesday, December 27, 2005 5:12 AM
To: [email-masked]
Subject: [dhcwg] DHCP - VLANS

Hi,

Thanks,
Sasi.

---

From: "David W. Hankins" <[email-masked]>
Date: Thu, 28 Sep 2006 09:09:51 -0700

> address pool, pre-reserved reservation, VLAN to IP subnet mapping, etc.

It is also not uncommon to attach the DHCP server directly to all
VLANs through the use of 802.1q trunking on one DHCP server-interface,
avoiding relays entirely.

This is very frequently used for example on a college campus where
VLANs are not scoped by region ("vlan for office 5") but rather
use-oriented ("student network" "teacher network" "lab network" "server
network") and span the entire campus.  So locating relays at the
'head end' of each VLAN probably places that 5 feet to the left of
the DHCP server - in the central network hub where the 'root ethernet
switch' lives, and probably the only routers in the campus.

In this case, each vlan appears as a virtual subinterface to the
DHCP server software.

> vlans and assign appropriate vlan base address to clients.

VLANs are just like any other network, there's nothing psecial about
them...giaddr or source interface.

But it does present some unique challenges to the software
implementation (I know that ISC DHCP could use improvement here).

Some of these are intuitive (software that uses 'raw' sockets need
the packets 'cooked' for them to remove and place the 802.1q
trunking).  Some are not (the server now has the same MAC address
on every VLAN, so will receive renewal unicasts from clients that
have changed networks...this excercises code in unusual ways).

-- 
ISC Training!  October 16-20, 2006, in the San Francisco Bay Area,
covering topics from DNS to DDNS & DHCP.  Email [email-masked].
-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		you'll just have to do it again."
Internet Systems Consortium, Inc.	-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg