Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS) Option

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Thu, 21 Sep 2006 08:23:17 -0400

Amy:

Bud, David, and Ted all share the same concern I have, though they
expressed it better.

You are trying to have the relay make decisions that are better left to
the server. We usually assume that the DHCP server is the place where
complexity lives and many servers (as David pointed out for the ISC
server and we have similar facilities in the Cisco Network Registrar
server) already provide mechanisms to do this -- either for specific
(preconfigured) clients or based on information (from client or relay)
in the packet.

If you put this information in the relay, you've got to configure it and
also any other relays that those clients may use. Generally there are
many relays for each DHCP server.

If you put this information in the DHCP server, you've got fewer
"devices" to configure and update as changes are made.

And, DHCP servers usually run on general purpose hosts and have APIs or
other capabilities that are often lacking on relay agents which are
typically on routers.

The bottom line is that as the relay must be configured with some set of
rules (ie, POLICY) to apply to clients (so that it can set your
link-selection option accordingly), we feel it better to move that logic
into the DHCP server.

If you don't have rules (policy) but instead the relay is extracting
this information from the network in some manner that is unavailable to
the DHCP server, then I suggest we look at an option for the relay to
communicate this information to the server so that the server can apply
appropriate policy. That is a much more powerful system as perhaps
others want to do more than just determine the prefixes to assign.

You might look at what DOCSIS provides for DHCPv4 and DHCPv6 as a model
-- capabilities and other data are communicated to the DHCP server so
that it can apply appropriate policy.

- Bernie 

-----Original Message-----
From: Amy Zhao [mailto:[email-masked]] 
Sent: Thursday, September 21, 2006 5:07 AM
To: 'Bud Millwood'; 'David W. Hankins'
Cc: [email-masked]
Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS)
Option

Hello!

Thanks.

Sorry, maybe I used an inappropriate example. I am not trying to make
relay
agent dictate policy, I just want to express 
that the information the link-address provides is per-link, and the
information that lin-selection option provides can be not only 
per-link,but also per-client.

B.R.
Amy 

E-mail: [email-masked]

> -----Original Message-----
> From: Bud Millwood [mailto:[email-masked]] 
> Sent: Thursday, September 21, 2006 4:03 PM
> To: [email-masked]
> Subject: Re: [dhcwg] [New I-D] DHCPv6 Relay Agent Link 
> Selection(RALS) Option
> 
> On Wednesday 20 September 2006 17:14, David W. Hankins wrote:
> > On Wed, Sep 20, 2006 at 04:51:41PM +0800, Amy wrote:
> > >     But for some access policy, client A can not be assigned the 
> > > address in prefix A, client B can not be assigned the address in 
> > > prefix B. And in this case, onlu using link-address is 
> not sufficient.
> >
> > Traditionally, when DHCPv4 installations have been 
> presented with this 
> > problem, the determination of which subnet to allocate to 
> the client 
> > has been made on the server side.
> >
> > That is, the server identifies the client (by identifier or 
> contents 
> > of some options the client (or relay!) supplies or similar) and 
> > allocates an address the client 'is permitted'.  In ISC 
> DHCP we call 
> > these 'permit/deny' statements, and it is generally done by 
> > 'class'ifying the clients into distinct groups first.
> >
> >
> > There aren't any DHCPv6 traditions quite yet, but is there 
> some reason 
> > you think this old DHCPv4 model is not going to serve us in DHCPv6?
> >
> > It's my opinion that it would be easier to configure the 
> (small number
> > of) DHCP Servers to do what is desired in this situation, 
> and harder 
> > to configure the (larger number of) relays to produce the 
> right subnet 
> > for each client.
> 
> I'd like to weigh in here and say that I generally agree with 
> your conclusions David. It's not a bad thing for a 
> client/relay to provide a server with as much contextual 
> information as possible, but there should be a distinction 
> between providing contextual information and trying to 
> dictate policy. And I don't think relays should be dictating policy.
> 
> - Bud
> 
> Bud Millwood
> Weird Solutions, Inc.
> http://www.weird-solutions.com
> tel: +46 8 758 3700
> fax: +46 8 758 3687
> mailto:[email-masked]
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Amy Zhao <[email-masked]>
Date: Mon, 25 Sep 2006 16:11:09 +0800

Hello, Bernie,Bud,David and Ted!
       Thank you!
       I will consider your comments carefully. Maybe you're right. 
       
       Another question:
       Is there any text describing the link-address about
prefix-delegation,or it is same as the link-address about ip-address
assignment?

B.R.
Amy 

 

> From: Bernie Volz (volz) [mailto:[email-masked]] 
> Sent: Thursday, September 21, 2006 8:23 PM
> To: Amy Zhao; Bud Millwood; David W. Hankins
> Cc: [email-masked]
> Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link 
> Selection(RALS) Option
> 
> Amy:
> 
> Bud, David, and Ted all share the same concern I have, though 
> they expressed it better.
> 
> You are trying to have the relay make decisions that are 
> better left to the server. We usually assume that the DHCP 
> server is the place where complexity lives and many servers 
> (as David pointed out for the ISC server and we have similar 
> facilities in the Cisco Network Registrar
> (preconfigured) clients or based on information (from client 
> or relay) in the packet.
> 
> If you put this information in the relay, you've got to 
> configure it and also any other relays that those clients may 
> use. Generally there are many relays for each DHCP server.
> 
> If you put this information in the DHCP server, you've got 
> fewer "devices" to configure and update as changes are made.
> 
> And, DHCP servers usually run on general purpose hosts and 
> have APIs or other capabilities that are often lacking on 
> relay agents which are typically on routers.
> 
> The bottom line is that as the relay must be configured with 
> some set of rules (ie, POLICY) to apply to clients (so that 
> it can set your link-selection option accordingly), we feel 
> it better to move that logic into the DHCP server.
> 
> If you don't have rules (policy) but instead the relay is 
> extracting this information from the network in some manner 
> that is unavailable to the DHCP server, then I suggest we 
> look at an option for the relay to communicate this 
> information to the server so that the server can apply 
> appropriate policy. That is a much more powerful system as 
> perhaps others want to do more than just determine the 
> prefixes to assign.
> 
> -- capabilities and other data are communicated to the DHCP 
> server so that it can apply appropriate policy.
> 
> - Bernie 
> 
> Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link 
> Selection(RALS) Option
> 
> 
> Hello!
> 
> Thanks.
>