Subject: RE: [dhcwg] RFC4361 adoption stumbling block.

From: "Kostur, Andre" <[email-masked]>
Date: Wed, 27 Sep 2006 10:42:25 -0700

> The problem is that the IETF's licensing model is what 
> created this nightmare. If the IETF mandated that anyone 
> using its protocols maintain their compliance to 'full and 
> current' standards then this would not be an issue per se.

Not quite.  In this situation (crashing DHCP server due to 4361-style Client
Ids), the DHCP server isn't even compliant to 2131.  The Client ID was never
restricted to 7 bytes.  Heck, put up a Microsoft RRAS server (either NT, or
2k, possibly others) on that network, it emits 16-byte Client IDs.

I'm more inclined towards the "break the DHCP server" side of things.  The
server shouldn't be blowing up.
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Thu, 28 Sep 2006 14:10:26 -0700

> server shouldn't be blowing up.

Sounds like we're approaching a consensus.

The absence of support for the contrary approach is more reassuring.

Thank you, gentlemen.

-- 
ISC Training!  October 16-20, 2006, in the San Francisco Bay Area,
covering topics from DNS to DDNS & DHCP.  Email [email-masked].
-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		you'll just have to do it again."
Internet Systems Consortium, Inc.	-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg