Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS) Opt ion

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Thu, 14 Sep 2006 08:59:11 -0400

I agree with Andre. I can't see the need for this option.
 
The link-address field in the relay-forw message is addressing
information for the server to use in determine where the client is (for
address assignment/prefix-delegation purposes). There is ***NO***
requirement that this address be an address that the relay-agent has
configured.
 
The address of relay agent is in either the peer-address field (if this
isn't the first hop relay) or in the SOURCE address of the relay-forw
packet. Thus, unlike in DHCPv4 where the giaddr field is overloaded to
mean two things, that is NOT the case for DHCPv6.
 
Unless you can come up with a reason why the link-address field isn't
sufficient, I can't see supporting this work.
 
- Bernie

________________________________

From: Amy [mailto:[email-masked]] 
Sent: Wednesday, September 13, 2006 3:56 AM
To: 'Kostur, Andre'
Cc: [email-masked]
Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS)
Opt ion

Hello,Kostur
    Thank you!
    
    Yes, it is a counterpart of DHCPv4 link-selection sub-option, so we
used a similiar option name. And we missed it in the draft, sorry.
   
    I obtain the requirement from NetLMM Base protocol, the draft is
still in progress.
                     +--------------------------------+
                  |           LMM Domain           |
                  |                                |
                  |    +----+           +----+     |
                  |    |LMA |           | LMA|     |
                  |    +----+           +----+     |
                  |       \               /        |
                  |    **********************      |
                  |   *                      *     |
                  |  *      IP network        *    |
                  |   *                      *     |
                  |    **********************      |
                  |      /        |         \      |
                  |  +----+    +----+     +----+   |
                  +--|MAG1|----|MAG2|-----|MAG3|---+
                     +----+    +----+     +----+
                        |                    |
                        |                    |
                      +---+ Movement        +--+
                      |MN | ---->           |CN|
                      +---+                 +--+
 
  When a mobile mode connects to the NetLMM infrastructure, it first
needs to configure an address,i.e.NetLMM Address. This address is the
invariant IP address on the MN inside the NetLMM domain. And the IPv6
link prefix of the NetLMM address comes from LMA, not MAG. 
 
   From my understand, link-address field holds the address of the relay
agent. And so, we think that only using link-address can not satisfy the
above requirement.

________________________________

From: Kostur, Andre [mailto:[email-masked]] 
Sent: Wednesday, September 13, 2006 12:23 PM
To: Amy; [email-masked]
Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS)
Opt ion

	> -----Original Message----- 
	> From: Amy [mailto:[email-masked]] 
	> 
	> We posted a new I-D as follows.  We would appreciate your
comments. 
	> 
	> A New Internet-Draft is available from the on-line 
	> Internet-Drafts directories. 
	> 
	> 
	>       Title           : DHCPv6 Relay Agent Link
Selection(RALS) Option 
	>       Author(s)       : Y. Zhao 
	>       Filename        : 
	> draft-zhao-dhc-dhcpv6-relay-link-selection-00.txt 
	>       Pages           : 16 
	>       Date            : 2006-9-12 

	I don't understand the requirement for this draft.  From what I
understand, this is to allow the Relay Agent to select the link/prefix
from which to make an allocation.  This is basically a v6 version of the
Link Selection Suboption for dhcpv4.  However, from my reading of RFC
3315, this functionality is already supported in the link-address field
of the Relay-forward message:

	      link-address   A global or site-local address that will be
used by 
	                     the server to identify the link on which
the client 
	                     is located. 

	What behaviours does this draft cover that the link-address
field doesn't address? 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Amy <[email-masked]>
Date: Fri, 15 Sep 2006 11:37:46 +0800

Hi,Bernie:
  
   Thanks!
 
   On the first hop relay, according to Section 20.1.1. of rfc3315 , the
link-address placed by first hop relay will be used by the    server to
determine the link where the client is.
   But in IPv6, multiple subnet prefixes can be assigned to IP link, the
link-address only can determine one subnet prefix. And Link-selection option
can determine one or more seperated subnet prefixes.

    On the non-first hop relay, according to Section 20.1.2. of rfc3315, the
link-address is either 0 (if If the source address from the IP datagram
header of the received message is a global or site-local address) or a
global or site-local address assigned to the interface on which the message
was received.
   
                       relay-forward-1                 relay-forward-2
   client----relay A--------------------NAS/relay
B-----------------------server
 
   NAS,act as relay B, can get the information about the link(s) where the
client is,but the link-address of relay-forward-2 can not be used as a hint
to server
   Relay A just forwards the client-originated message to NAS,it can not
determine where the client is, so the link-address of relay-forward-1 can
not either.
 
   In this case, we can use link-selection option in relay-forward-2 as a
hint to server.
 
B.R.
 
Amy Zhao

  _____  

From: Bernie Volz (volz) [mailto:[email-masked]] 
Sent: Thursday, September 14, 2006 8:59 PM
To: Amy; Kostur, Andre
Cc: [email-masked]
Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS) Opt
ion

The link-address field in the relay-forw message is addressing information
for the server to use in determine where the client is (for address
assignment/prefix-delegation purposes). There is ***NO*** requirement that
this address be an address that the relay-agent has configured.
 
The address of relay agent is in either the peer-address field (if this
isn't the first hop relay) or in the SOURCE address of the relay-forw
packet. Thus, unlike in DHCPv4 where the giaddr field is overloaded to mean
two things, that is NOT the case for DHCPv6.

- Bernie

  _____  

From: Amy [mailto:[email-masked]] 
Sent: Wednesday, September 13, 2006 3:56 AM
To: 'Kostur, Andre'
Cc: [email-masked]
Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS) Opt
ion

Hello,Kostur
    Thank you!
    
    Yes, it is a counterpart of DHCPv4 link-selection sub-option, so we used
a similiar option name. And we missed it in the draft, sorry.
   
    I obtain the requirement from NetLMM Base protocol, the draft is still
in progress.
                     +--------------------------------+
                  |           LMM Domain           |
                  |                                |
                  |    +----+           +----+     |
                  |    |LMA |           | LMA|     |
                  |    +----+           +----+     |
                  |       \               /        |
                  |    **********************      |
                  |   *                      *     |
                  |  *      IP network        *    |
                  |   *                      *     |
                  |    **********************      |
                  |      /        |         \      |
                  |  +----+    +----+     +----+   |
                  +--|MAG1|----|MAG2|-----|MAG3|---+
                     +----+    +----+     +----+
                        |                    |
                        |                    |
                      +---+ Movement        +--+
                      |MN | ---->           |CN|
                      +---+                 +--+
 
  When a mobile mode connects to the NetLMM infrastructure, it first needs
to configure an address,i.e.NetLMM Address. This address is the invariant IP
address on the MN inside the NetLMM domain. And the IPv6 link prefix of the
NetLMM address comes from LMA, not MAG. 

  _____  

From: Kostur, Andre [mailto:[email-masked]] 
Sent: Wednesday, September 13, 2006 12:23 PM
To: Amy; [email-masked]
Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS) Opt
ion

> We posted a new I-D as follows.  We would appreciate your comments. 
> 
>       Title           : DHCPv6 Relay Agent Link Selection(RALS) Option 
>       Author(s)       : Y. Zhao 
>       Filename        : 

I don't understand the requirement for this draft.  From what I understand,
this is to allow the Relay Agent to select the link/prefix from which to
make an allocation.  This is basically a v6 version of the Link Selection
Suboption for dhcpv4.  However, from my reading of RFC 3315, this
functionality is already supported in the link-address field of the
Relay-forward message:

      link-address   A global or site-local address that will be used by 
                     the server to identify the link on which the client 
                     is located. 

What behaviours does this draft cover that the link-address field doesn't
address?