Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS) Opt ion

From: "Kostur, Andre" <[email-masked]>
Date: Tue, 12 Sep 2006 21:22:53 -0700

> -----Original Message-----
> From: Amy [mailto:[email-masked]] 
> 
> We posted a new I-D as follows.  We would appreciate your comments.
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: DHCPv6 Relay Agent Link Selection(RALS) Option
> 	Author(s)	: Y. Zhao
> 	Filename	: 
> draft-zhao-dhc-dhcpv6-relay-link-selection-00.txt
> 	Pages		: 16
> 	Date		: 2006-9-12

I don't understand the requirement for this draft.  From what I understand,
this is to allow the Relay Agent to select the link/prefix from which to
make an allocation.  This is basically a v6 version of the Link Selection
Suboption for dhcpv4.  However, from my reading of RFC 3315, this
functionality is already supported in the link-address field of the
Relay-forward message:

      link-address   A global or site-local address that will be used by
                     the server to identify the link on which the client
                     is located.

What behaviours does this draft cover that the link-address field doesn't
address?
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Amy <[email-masked]>
Date: Wed, 13 Sep 2006 15:55:51 +0800

Hello,Kostur
    Thank you!
    
    Yes, it is a counterpart of DHCPv4 link-selection sub-option, so we used
a similiar option name. And we missed it in the draft, sorry.
   
    I obtain the requirement from NetLMM Base protocol, the draft is still
in progress.
                     +--------------------------------+
                  |           LMM Domain           |
                  |                                |
                  |    +----+           +----+     |
                  |    |LMA |           | LMA|     |
                  |    +----+           +----+     |
                  |       \               /        |
                  |    **********************      |
                  |   *                      *     |
                  |  *      IP network        *    |
                  |   *                      *     |
                  |    **********************      |
                  |      /        |         \      |
                  |  +----+    +----+     +----+   |
                  +--|MAG1|----|MAG2|-----|MAG3|---+
                     +----+    +----+     +----+
                        |                    |
                        |                    |
                      +---+ Movement        +--+
                      |MN | ---->           |CN|
                      +---+                 +--+
 
  When a mobile mode connects to the NetLMM infrastructure, it first needs
to configure an address,i.e.NetLMM Address. This address is the invariant IP
address on the MN inside the NetLMM domain. And the IPv6 link prefix of the
NetLMM address comes from LMA, not MAG. 
 
   From my understand, link-address field holds the address of the relay
agent. And so, we think that only using link-address can not satisfy the
above requirement.

  _____  

From: Kostur, Andre [mailto:[email-masked]] 
Sent: Wednesday, September 13, 2006 12:23 PM
To: Amy; [email-masked]
Subject: RE: [dhcwg] [New I-D] DHCPv6 Relay Agent Link Selection(RALS) Opt
ion