Subject: RE: [dhcwg] Proposal for experimental DHCP option

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sat, 28 Oct 2006 18:15:09 -0400

The 03 draft you published has:

   The code for this option is 95.  The maximum possible length for this
   option is 255 bytes. Note: this option is listed in [4], but has to
   be confirmed by IANA. See IANA Considerations for details.

          Code Len   LDAP URL
         +-----+----+----+----+----+----+--
         | 96  | n  | c1 | c2 | c3 | c4 |  ...
         +-----+----+----+----+----+----+--

Shouldn't the "code" field be 95, not 96, based on the "The code for this option is 95.".

And, http://www.iana.org/assignments/bootp-dhcp-parameters has:

   95      LDAP                     N    Lightweight Directory Access Protocol [RFC3679] 
   96      REMOVED/Unassigned                                                  [RFC3679] 

And, RFC 3679 lists option 95 as"

3.2.1. LDAP Servers

   Code:              95
   Name:              LDAP Servers
   Defined in:        (none)
   Contact:           Dieter Siegmund, [email-masked]
   Reason to recover: Never published in an RFC

And, is your use consistent with the original option? If it is, then it may be OK to proceed with that number. If it isn't, then you would have to request IANA to assign one when and if this ever becomes an RFC.

The original document for the option 95 registration is available thru http://www.iana.org/assignments/bootp-dhcp-extensions/ and is http://www.iana.org/assignments/bootp-dhcp-extensions/bootp-dhcp-option-95. [It is somewhat odd that Dieter Siegmund doesn't match up with this.]

Note also that if MULTIPLE URLs are supposed to be possible, then there has to be some way to detect this. Your document currently states that the URLs are not NULL terminated. So, what mechanism exists for detecting multiple URLs being present? [Note I don't base this comment on the current draft which only allows one; just on some of the email discussion which I think implied that there could be more than one URL.]

I have NO opinion on the usefulness or lack thereof of this option.

- Bernie

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Giuseppe Paternò (Gippa)" <[email-masked]>
Date: Sun, 29 Oct 2006 12:03:27 +0100

Hi Bernie,
I am totally wrong on my draft: it was option 96 ... I proposed to
reuse the same of the LDAP draft, but that's a IANA final decision.
They wouldn't allow me a DHCP option code unless this working group
approves the draft as experimental. My apologies for the miswriting.
Also it is interesting the fact of using null to separate different
URLs, I didn't thought about that. What do the ML think?
Thank you!
Regards,
  Giuseppe