Subject: [dhcwg] I-D ACTION:draft-ietf-dhc-server-override-04.txt

From: [email-masked]
Date: Tue, 24 Oct 2006 15:50:01 -0400

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Dynamic Host Configuration Working Group of the IETF.

	Title		: DHCP Server Identifier Override Suboption
	Author(s)	: R. Johnson, et al.
	Filename	: draft-ietf-dhc-server-override-04.txt
	Pages		: 11
	Date		: 2006-10-24
	
This memo defines a new suboption of the DHCP relay information
   option which allows the DHCP relay to specify a new value for the
   Server Identifier option, which is inserted by the DHCP Server.  This
   allows the DHCP relay to act as the actual DHCP server such that
   RENEW DHCPREQUESTs will come to the relay instead of going to the
   server directly.  This gives the relay the opportunity to include the
   Relay Agent option with appropriate suboptions even on DHCP RENEW
   messages.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-dhc-server-override-04.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-ietf-dhc-server-override-04.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-dhc-server-override-04.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Mukund Kamath" <[email-masked]>
Date: Tue, 31 Oct 2006 17:00:10 +0530

Hello Mr Johnson,
   I had a few questions regarding this draft.

* Why do we need this option? I feel that the relay agent can check all DHCP packets based on the UDP Destination port, and add the relay agent information. In such a case, this option would be redundant.

* From the draft :
  "In a situation where the DHCP Relay is configured to forward packets
   to more than one server, the DHCP Relay should forward all DHCP
   packets all servers.  This applies to DHCP RENEW packets as well."
      DHCP renew packets are unicast. Why do we need to send this packet to all the servers. The servers that have not leased the  ip-address will not have any information regarding this client and will ignore the packet anyway. So why the over head of sending the packet to all the DHCP servers?

* The introduction ( paragraph 3 ) mentions that it would be easier for the relay agent to keep updated abt the  lease information etc. But on page 5, it is mentioned that the "intent is that relay agent need not have to maintain any lease information". I guess this conflict should be resolved. I personally feel that the relay agent should maintain the lease information, so that the information can be used to detect spoofing and prevent it as well.

* How is the RELEASE handled here? Is this unicast to the server or would it come to the RA ? If RA goes down, RELEASE will never reach the DHCP server and this can make the DHCP server hold the IP address until it timesout. If it is unicast to the server, the packet might get routed over another path.

Regards,
Mukund

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wed 10/25/2006 1:20 AM
To: [email-masked]
Cc: [email-masked]
Subject: [dhcwg] I-D ACTION:draft-ietf-dhc-server-override-04.txt

Send a message to:
	[email-masked].
In the body type:

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***