Subject: Re: [dhcwg] Draft submission

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 26 Oct 2006 13:29:10 -0700 (PDT)

Hi Mukund,
  Thanks for comments. Replies inline. Sorry for the delay.

--behcet
----- Original Message ----
From: Mukund Kamath <[email-masked]>
To: [email-masked]; [email-masked]
Sent: Thursday, October 19, 2006 3:12:31 AM
Subject: RE: [dhcwg] Draft submission

Hi Behcet,
   After having read the draft, the following points were not clear to me. 

* Why do we need a proxy DHCP server?? What is the real advantage in getting the IP-address alone from another server? I also assume that the other parameters that need to be configured will be provided by the proxy server.

==> Yes other parameters can also be provided by the proxy server and the Proxy gets them from another server. 
*  We already have several DHCP servers, ( including the DHCP server from ISC) , which support LDAP as suggested by the draft. So can we call a DHCP server using LDAP (to store the parameters ) as a proxy DHCP server?

==>Yes. I believe so.
* The second option suggested to get an IP-address is by Querying an AAA server, the standard for which is not available as of now. ( Other than the draft being circulated now. If that is the case, I guess a reference should be added to the draft).

==>Let me know the reference, sure we'll add it.
* Is the lease info maintained the the DHCP proxy server or the LDAP server?? If the lease info is maintained on the LDAP server, how will  the DHCP server know when a lease has expired and the entry must be deleted??

==> Yes the lease info is maintained by the DHCP Proxy.
Regards,
Mukund 

-----Original Message-----
From: Behcet Sarikaya [mailto:[email-masked]]
Sent: Tue 10/17/2006 12:14 PM
To: [email-masked]
Subject: [dhcwg] Draft submission

Dear DHC Members,
  We submitted a new draft on

DHCP v4/v6 Proxy
which is available at:

http://www.ietf.org/internet-drafts/draft-sarikaya-dhc-proxyagent-00.txt

Regards,

Behcet

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg
**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 26 Oct 2006 13:39:09 -0700 (PDT)

Hi Stig,
  Comments (very much belated) inline.

Regards,

--behcet

----- Original Message ----
From: Stig Venaas <[email-masked]>
To: Mukund Kamath <[email-masked]>
Cc: [email-masked]; [email-masked]
Sent: Thursday, October 19, 2006 3:48:10 AM
Subject: Re: [dhcwg] Draft submission

> * Is the lease info maintained the the DHCP proxy server or the LDAP server?? If the lease info is maintained on the LDAP server, how will  the DHCP server know when a lease has expired and the ent…

First of all, I don't see any reason to differentiate between a DHCP 
server using files and a server using LDAP for data storage (leases,
configs etc).

The question I think should be considered, is to what degree does 
proxying need to be taken care of in the protocol.

==>From a pure DHCP protocol point of view we don't see a need to introduce any new messages, but we would like to discuss what changes if any the mobility aspects bring. We would like to see how the discussions progress and what feedback we get from the WG.

It's perfectly possible to have a proxy that looks like any normal DHCP 
server to the client, does the client need to know the difference?

==>No. 
Is something new needed for communication between proxy and server?

==> No, the Proxy is itself a server, we don't envison communication with another DHCP server

I haven't thought about the answers myself yet though...

Stig