Subject: RE: [dhcwg] [Question] When should we use Interface-ID option

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sun, 15 Oct 2006 10:44:29 -0400

Hideshi:

If a relay agent (which is a router) terminates a bunch of circuits, it
may well be that each of those circuits does not have their own unique
prefix (and hence a link-addess field that can be used). For example, a
relay may have one global address for all of these circuits.

In such a case, the relay must know on which circuit to relay any
replies from a server, and hence the interface-id can be used.

- Bernie

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Friday, October 06, 2006 3:43 AM
To: [email-masked]
Subject: [dhcwg] [Question] When should we use Interface-ID option

Hi all,

I have a question regarding Interface-ID option in DHCPv6.

RFC3315 defines Interface-ID option, 
but I cannot understand in what situation this option should be used. 

RFC3315 20.1.1 says,
----------
(snip)
   If the relay agent cannot use the address in the link-address field
   to identify the interface through which the response to the client
   will be relayed, the relay agent MUST include an Interface-id option
   (see section 22.18)
(snip)
----------

I cannot imagine above sentence situation.
I mean that I can't think up the situation("Relay agent cannot use the
address 
in the link-address field to identify the interface")

Someone, please teach me the situation that Relay agent should use
Interface-ID option in detail.

Moreover, I can't understand actual meaning of following statement.
#I feel the RFC is unclear regarding Interface-id option usage.
--------------
20.1.1. Relaying a Message from a Client
   (snip)	
 
                                                                     The
   relay agent fills in the link-address field as described in the
   previous paragraph regardless of whether the relay agent includes an
   Interface-id option in the Relay-forward message.
---------------
In this statement, when a Relay agent includes an Interface-id option,
what should the Relay agent fill in the link-address field?

What do you think?

Best Regards,

*************************************
Hideshi Enokihara
IPv6 Business
Network & Software Development Dept.
Yokogawa Electric Corporation

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: <[email-masked]>
Date: Tue, 17 Oct 2006 20:24:24 +0900

Dear Bernie Volz,

Thank you very much for your reply.

But, I couldn't understand the words "a bunch of circuits". 
Sorry for my deficient knowledge. 
Is "a bunch of circuits"  like below situation?

------------------
      DHCPv6 Server
           |
           |
  ---------+---------+--------
                     | 
                     | Relay has one Global Address
                +----+--------------+
                |Relay Agent(Router)|
                +----+----+----+----+
                     |    |    |
                     CL   CL   CL
-------------------
Are these CLs off-link each other?
Or on-link?

One more question.
Does the situation of "a bunch of circuits" that you mentioned in the
previous email often appear in  Address Assignment?
How about in Other configuration and Stateless DHCPv6?

What do you think regarding Interface-ID option?
Is Interface-ID option often used by current state (In other words, does
this option have important role in current DHCPv6 circumstance? )?
Moreover, when we think about future DHCPv6 usage, will this option play
a big role?

I'm sorry to bother you.

Best regards,
> From: Bernie Volz (volz) [mailto:[email-masked]] 
> Sent: Sunday, October 15, 2006 11:44 PM
> To: Enokihara, Hideshi ([email-masked]); 
> [email-masked]
> Subject: RE: [dhcwg] [Question] When should we use Interface-ID option
> 
> Hideshi:
> 
> If a relay agent (which is a router) terminates a bunch of 
> circuits, it may well be that each of those circuits does not 
> have their own unique prefix (and hence a link-addess field 
> that can be used). For example, a relay may have one global 
> address for all of these circuits.
> 
> In such a case, the relay must know on which circuit to relay 
> any replies from a server, and hence the interface-id can be used.
> 
> - Bernie
> 
> I mean that I can't think up the situation("Relay agent 
> cannot use the address in the link-address field to identify 
> the interface")
> 
> Someone, please teach me the situation that Relay agent 
> should use Interface-ID option in detail.
> 
> In this statement, when a Relay agent includes an 
> Interface-id option, what should the Relay agent fill in the 
> link-address field?
> 
> What do you think?
> 
> Best Regards,
>