Subject: [dhcwg] A question about processing a RENEW message from a client in DHCPv6.

From: 차현욱 <[email-masked]>
Date: Mon, 30 Apr 2007 00:45:41 +0000 (GMT)

Dear, all.

I am now developing DHCPv6 client and server in our product.
I have a question reading source code of a open source package "Wide DHCPv6".
In this software, it does update update_time of binding assigned to client without checking if all assinged stateful addresses for same IA are included in RENEW message from client. 
If server assigned two addresses to IA requested by client and client send RENEW message for only one address, what is correct behavior of server?
Right before, I checked DHCPv6 conformance testsuit document by the TAHI. But I do not find exact answer. 

In my opinion, several choices are possible. 
- Server rejects RENEW message.
- Server releases lease for omitted address in RENEW message and refreshes update_time of binding including only the address in RENEW message from client. Server may include IA_NA address option for the released address with lifetimes set to zero.
- Server keeps lease for omitted address in RENEW message during its valid life time and refreshes update_time of binding including only the address in RENEW message from client.

Any advicees and comments are welcomed.

Thank you in advance. 

Joseph HyunWook Cha

"For you, O God, tested us; you refined us like silver."

Software Engineer 
Development Part 1. I/Infra  
Network System Division 
Tel 031-279-3804  Mobile 010-3024-3804

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sun, 29 Apr 2007 20:58:31 -0400

How about the server includes the address as if it was in the Renew?

If a client sends just a Renew with anIA option but without any IAADDR options, why wouldn't you just renew all addresses for the binding (IA_* and IAID) and include them in the Reply? (Of course, addresses that can't be renewed would be sent with whatever remaining lifetimes they have.)

- Bernie 

-----Original Message-----
From: 차현욱 [mailto:[email-masked]] 
Sent: Sunday, April 29, 2007 8:46 PM
To: [email-masked]
Subject: [dhcwg] A question about processing a RENEW message from a clientin DHCPv6.

Dear, all.

Thank you in advance. 

Joseph HyunWook Cha

Software Engineer

---

From: "Aggarwal Vivek-Q4997C" <[email-masked]>
Date: Mon, 30 Apr 2007 12:13:13 +0800

Hello All

I have some questions regarding the dimensioning of DHCP server

Can anyone please respond my below question?

1.       What are the dimensioning criteria for DHCP Server?

2.       How many subscribers the Sun 8000 Modular Blade Sever Chassis
with about 150 Gb of Hardisk can handle?

3.       How can we configure DHCP Servers to work in Load Balancing
Scenario?

Looking forward for a early reply

Rgds

Vivek Aggarwal

Motorola India

Network Engineer

Bangalore,India

M- +919945505704