Subject: [dhcwg] dhcp fixed lease problem

From: Bert Verhaeghe <[email-masked]>
Date: Thu, 12 Apr 2007 11:38:09 +0200

Hi all,

is it possible to define a fixed lease for the same MAC in multiple
subnets?  I included a sample configuration file and a scenario below,
but when testing (dhcpd3 -t) I get the following error :

> bert@laptop11:~$ sudo /usr/sbin/dhcpd3 -t Internet Systems
> Consortium DHCP Server V3.0.4 Copyright 2004-2006 Internet Systems
> Consortium. All rights reserved. For info, please visit
> http://www.isc.org/sw/dhcp/ /etc/dhcp3/dhcpd.conf line 148: host
> laptop01: already exists } ^ /etc/dhcp3/dhcpd.conf line 158: host
> laptop02: already exists } ^ Configuration file errors encountered
> -- exiting

Scenario : When the person owning laptop  is in the NY network, the IP
10.10.1.102 should be assigned, but when he's in the LA network he
should get the 10.10.2.101 IP.  Can this be accomplished using the ISC
DHCP v3 server?

Thanks in advance,

Bert Verhaeghe

Sample configuration file :

ddns-update-style none;
option domain-name "example.org";
option domain-name-servers ns1.example.org, ns2.example.org;
default-lease-time 600;
max-lease-time 7200;
authoritative;

shared-network example {

  # example NY network
  subnet 10.10.1.0 netmask 255.255.255.0 {
    option routers ny.example.org;

    host fixedHost01 {
      hardware ethernet 00:00:00:00:00:01;
      fixed-address 10.10.1.101;
    }

    host laptop01 {
      hardware ethernet 00:00:00:00:00:02;
      fixed-address 10.10.1.102;
    }

    host laptop02 {
      hardware ethernet 00:00:00:00:00:03;
      fixed-address 10.10.1.103;
    }
  }

  # example LA network
  subnet 10.10.2.0 netmask 255.255.255.0 {
    option routers la.example.org;

    host laptop01 {
      hardware ethernet 00:00:00:00:00:02;
      fixed-address 10.10.2.101;
    }
  }
}

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Andre Kostur" <[email-masked]>
Date: Thu, 12 Apr 2007 06:29:39 -0700

> -----Original Message-----
> From: Bert Verhaeghe [mailto:[email-masked]] 
> Sent: Thursday, April 12, 2007 2:38 AM
> To: [email-masked]
> Subject: [dhcwg] dhcp fixed lease problem
>
> is it possible to define a fixed lease for the same MAC in 
> multiple subnets?  I included a sample configuration file and 
> a scenario below, but when testing (dhcpd3 -t) I get the 
> following error :

Bert, you're asking about how to configure a specific implementation of
DHCP.  The dhcpwg mailing list is for discussing how the DHCP protocol
(both v4 and v6) itself works.  Not how to configure a specific
implementation.  For that, you need to contact your vendor.

>From a protocol perspective, there's nothing prohibiting a particular
implementation from allowing this behaviour.  I know that our
(Incognito's) DHCP server will allow you to do this.  I'd be surprised
if the other vendors didn't allow it.

---

From: "David W. Hankins" <[email-masked]>
Date: Thu, 12 Apr 2007 14:38:39 -0700

> but when testing (dhcpd3 -t) I get the following error :

Bert, this looks like ISC DHCP 3.x config syntax and questions.
That's not an appropriate topic for the IETF DHC WG mailing list.

This question is appropriate for [email-masked], you can
subscribe here:

	http://www.isc.org/sw/dhcp/dhcp-lists.php

But so long as I'm transmitting, the answer to your question is in
'man dhcpd.conf',

   The fixed‐address declaration

      fixed‐address address [, address ... ];

      The fixed‐address declaration is used to assign one or more fixed IP
      addresses to a client.  It should only appear in a host declaration.
      If more than one address is supplied, then when the client boots, it
      will  be  assigned  the  address  that corresponds to the network on
      which it is booting.  If none of the addresses in the  fixed‐address
      statement  are  valid  for  the  network to which the client is con‐
      nected, that client will not match the host  declaration  containing
      that  fixed‐address  declaration.  Each address in the fixed‐address
      declaration should be either an IP address or  a  domain  name  that
      resolves to one or more IP addresses.

If you're still confused, ask on dhcp-users to help us improve that
documentation.

-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		you'll just have to do it again."
Internet Systems Consortium, Inc.	-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg