Subject: RE: [dhcwg] Elapsed Time Option in RFC 3315

From: "Leino, Tammy" <[email-masked]>
Date: Tue, 4 Sep 2007 08:07:24 -0500

Thanks Eric.  My question is actually whether this option is required in all messages.  The RFC seems a bit ambiguous.  It says:

>    A client MUST include an Elapsed Time option in messages to indicate
>    how long the client has been trying to complete a DHCP message
>    exchange.

Does this mean a client MUST include the option in all DHCP messages or just MUST include it if it wants to determine how long is has been trying to complete a message exchange?

I'm not looking for a meaning of the message, just whether it is required in all messages sent by the client.

Best Regards,
Tammy

-----Original Message-----
From: Eric Kollmann [mailto:[email-masked]]
Sent: Saturday, September 01, 2007 9:33 PM
To: Leino, Tammy
Cc: [email-masked]
Subject: Re: [dhcwg] Elapsed Time Option in RFC 3315

This is one of the "features" I've used in my DHCP fingerprinting
project and paper.  It is much easier to use other things to do an
accurate fingerprint, but this is one of those things that I found
interesting.  Different OS's have done lots of different things with
it over time.  Windows used a factor of 256 for a lot of its earlier
OS's.  Lots of Linux builds have hard coded 10 into it.  Some have
stuck to the general RFC and incremented it.  Basically where the
first DHCP request is 0, if it isn't answered sending a packet 4, 8,
16, and 32 seconds later +/- 1 and setup that correctly.  My
understanding was it was used to let the DHCP server know that this
client has tried "repeatedly" to get an address and that it may want
to give it a higher priority than someone just now requesting one with
a setting of 0 in their packet.

This was back in RFC 1532, may have been updated in a later RFCs:
3.2 Definition of the 'secs' field
The 'secs' field of a BOOTREQUEST message SHOULD represent the
elapsed time, in seconds, since the client sent its first BOOTREQUEST
message. Note that this implies that the 'secs' field of the first
BOOTREQUEST message SHOULD be set to zero.
Clients SHOULD NOT set the 'secs' field to a value which is constant
for all BOOTREQUEST messages.
DISCUSSION:
The original definition of the 'secs' field was vague. It was
not clear whether it represented the time since the first
BOOTREQUEST message was sent or some other time period such as
the time since the client machine was powered-up. This has
limited its usefulness as a policy control mechanism for BOOTP
servers and relay agents. Furthermore, certain client
implementations have been known to simply set this field to a
constant value or use incorrect byte-ordering. Incorrect
byte-ordering usually makes it appear as if a client has been
waiting much longer than it really has, so a relay agent will
relay the BOOTREQUEST sooner than desired (usually
immediately). These implementation errors have further
undermined the usefulness of the 'secs' field. These incorrect
implementations SHOULD be corrected.
[end RFC info]

----

I wrote this paper back in Feburary 2007 for something else that
didn't end up being needed, so I've never gone back and verified it is
100% accurate and have never cleaned up the clear copy/paste of RFCs
and added more info it places I would like to expand on.

This paper is my take on how most vendors do not stick to the RFCs in
their DHCP stack.  There could be some areas where I'm completely
wrong, but in case you want more info on any of it:

http://myweb.cableone.net/xnih/download/Chatter-DHCP.pdf

Eric
On 8/31/07, Leino, Tammy <[email-masked]> wrote:
>
>
> Hello All,
>
> Could someone kindly clarify the requirement of the Elapsed Time option for
> me.  Is it required in all packets sent by the client, or is it just
> required IF the client wants to indicate how long it has been trying to
> complete a DHCP message exchange?
>
>    A client MUST include an Elapsed Time option in messages to indicate
>    how long the client has been trying to complete a DHCP message
>    exchange.
>
> This statement in the RFC seems ambiguous to me, and any clarification you
> can offer would be greatly appreciated.
>
> Best Regards,
> Tammy Leino
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
>
>

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 4 Sep 2007 10:40:01 -0700

On Sep 4, 2007, at 6:07 AM, Leino, Tammy wrote:
> I'm not looking for a meaning of the message, just whether it is  
> required in all messages sent by the client.

In general, when a protocol spec says MUST, and doesn't qualify it,  
it's required.   It's certainly required in this case.   The purpose  
of the option is to assist the server and relay agents - the client  
doesn't need it.

---

From: "David W. Hankins" <[email-masked]>
Date: Tue, 4 Sep 2007 10:40:34 -0700

On Tue, Sep 04, 2007 at 08:07:24AM -0500, Leino, Tammy wrote:
> Does this mean a client MUST include the option in all DHCP messages or just
> MUST include it if it wants to determine how long is has been trying to
> complete a message exchange?

The RFC is very ambiguous here, since there is no mention of this
option anywhere else in 3315.

If the client MUST include it, then I would expect to see a statement
to that effect in the various 'creation and transmission' sections.  I
would definitely say that if it doesn't appear in the relevant
'creation and transmission' section, then it is definitely "not a
MUST" (not "MUST NOT"...).

If it were absolutely mandatory for every message exchange, I think
we would have supplied a header field for it.

So I think what this option really should say is that if the client
wants to benefit from potentially present redundant DHCPv6 servers,
then it MUST include the elapsed time option to express how long it
has been waiting.

But of course, who wouldn't want to benefit from redundant server
architectures?  Who wants their users alone to stand without service
when others are being processed and getting net?

So this is another example of my pet peeve of options granted to
implementors that really aren't good options.

All that said, ISC DHCP 4's client always includes the elapsed time
option in every message, but since our timer system is currently still
granular to seconds you will always see 'multiples of 100'.

I can't remember what other clients at the DHCP Bake-Off did.

> Windows used a factor of 256 for a lot of its earlier
> OS's.

Windows is not alone in failing to put the 'secs' DHCPv4 field into
network byte order.  We see this quite commonly.

-- 
Ash bugud-gul durbatuluk agh burzum-ishi krimpatul.
Why settle for the lesser evil?	 https://secure.isc.org/store/t-shirt/
-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		     you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 4 Sep 2007 10:52:49 -0700

> we would have supplied a header field for it.

No, we deliberately didn't supply header fields for anything that we  
could do as an option.   We made the message type a header field  
because you need to parse it to see if you need to look at the  
message at all, but we really wanted to get away from the solid  
header structure of v4, because so many fields in that structure are  
only relevant for a limited number of messages.   As is the case here  
- the elapsed time option is only relevant in packets sent by the  
client.

It's a very bad precedent to read a MUST as optional.   You may be  
right that it would have been better to mention the Elapsed Time  
option in other places, but the fact that it's mentioned where it is,  
with a MUST, is all you need to know what to do.   You MUST include  
it.   If your client doesn't include it, the server is within its  
rights to drop the packet on the floor.

---

From: "David W. Hankins" <[email-masked]>
Date: Tue, 4 Sep 2007 14:21:36 -0700

> could do as an option.   We made the message type a header field  

And yet the relay messages clearly have header fields that could have
been options, and may even have been simpler if they were (an absent
value being clearer than an all-zero value).

> rights to drop the packet on the floor.

A server that elects to drop an ELAPSED_TIME optionless client packet
on the floor is doing so on its own volition, and is not engaging in a
behaviour that is described in any RFC of which I am aware.  The
results, therefore, are of little interest to me even and especially
if they are non-interoperable with clients developed to interoperate
with servers developed to 3315's guidance (which does not specify
rejection of such packets), or even clients whose developers did not
catch a poorly worded MUST buried in the bowels of the document.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 4 Sep 2007 14:56:18 -0700

On Sep 4, 2007, at 2:21 PM, David W. Hankins wrote:
> The

This is why we do interops, revise documents, and have discussions on  
the WG mailing list.   This is why "standard" is not the first stage  
in acceptance of an RFC.

---

From: "David W. Hankins" <[email-masked]>
Date: Tue, 4 Sep 2007 16:22:45 -0700

> the WG mailing list.   This is why "standard" is not the first stage  

I'm not sure how this is topical to DHC, unless what you just said is
that you are volunteering to write a draft to update 3315 on this
topic.

---

From: "Eric Kollmann" <[email-masked]>
Date: Sat, 1 Sep 2007 19:32:33 -0600

----

Eric

\.%4\.%5\.%6\.%7";
	mso-level-tab-stop:271.55pt;
	mso-level-number-position:left;
	margin-left:191.35pt;
	text-indent:-63.8pt;}
@list l9:level8
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8";
	mso-level-tab-stop:310.8pt;
	mso-level-number-position:left;
	margin-left:219.7pt;
	text-indent:-70.9pt;}
@list l9:level9
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8\.%9";
	mso-level-tab-stop:350.1pt;
	mso-level-number-position:left;
	margin-left:255.1pt;
	text-indent:-85.0pt;}
@list l10
	{mso-list-id:1666475049;
	mso-list-template-ids:-28945502;}
@list l10:level1
	{mso-level-style-link:"Heading 1";
	mso-level-text:%1;
	mso-level-tab-stop:.3in;
	mso-level-number-position:left;
	margin-left:.3in;
	text-indent:-.3in;}
@list l10:level2
	{mso-level-style-link:"Heading 2";
	mso-level-text:"%1\.%2";
	mso-level-tab-stop:.4in;
	mso-level-number-position:left;
	margin-left:.4in;
	text-indent:-.4in;}
@list l10:level3
	{mso-level-style-link:"Heading 3";
	mso-level-text:"%1\.%2\.%3";
	mso-level-tab-stop:.5in;
	mso-level-number-position:left;
	margin-left:.5in;
	text-indent:-.5in;}
@list l10:level4
	{mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l10:level5
	{mso-level-text:%5\FF09;
	mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l10:level6
	{mso-level-number-format:alpha-lower;
	mso-level-text:%6\FF09;
	mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l10:level7
	{mso-level-number-format:roman-lower;
	mso-level-text:%7;
	mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l10:level8
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8";
	mso-level-tab-stop:1.0in;
	mso-level-number-position:left;
	margin-left:1.0in;
	text-indent:-1.0in;}
@list l10:level9
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8\.%9";
	mso-level-tab-stop:1.1in;
	mso-level-number-position:left;
	margin-left:1.1in;
	text-indent:-1.1in;}
@list l11
	{mso-list-id:1916042858;
	mso-list-template-ids:-648263936;}
@list l11:level1
	{mso-level-number-format:alpha-upper;
	mso-level-text:\9644\5F55%1;
	mso-level-tab-stop:.3in;
	mso-level-number-position:left;
	margin-left:.3in;
	text-indent:-.3in;}
@list l11:level2
	{mso-level-text:"%1\.%2";
	mso-level-tab-stop:.4in;
	mso-level-number-position:left;
	margin-left:.4in;
	text-indent:-.4in;}
@list l11:level3
	{mso-level-text:"%1\.%2\.%3";
	mso-level-tab-stop:.5in;
	mso-level-number-position:left;
	margin-left:.5in;
	text-indent:-.5in;}
@list l11:level4
	{mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l11:level5
	{mso-level-text:%5\FF09;
	mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l11:level6
	{mso-level-number-format:alpha-lower;
	mso-level-text:%6\FF09;
	mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l11:level7
	{mso-level-number-format:roman-lower;
	mso-level-text:%7;
	mso-level-tab-stop:28.35pt;
	mso-level-number-position:left;
	margin-left:.65in;
	text-indent:-34.0pt;}
@list l11:level8
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8";
	mso-level-tab-stop:1.0in;
	mso-level-number-position:left;
	margin-left:1.0in;
	text-indent:-1.0in;}
@list l11:level9
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8\.%9";
	mso-level-tab-stop:1.1in;
	mso-level-number-position:left;
	margin-left:1.1in;
	text-indent:-1.1in;}
@list l12
	{mso-list-id:2114861838;
	mso-list-template-ids:-433129230;}
@list l12:level1
	{mso-level-number-format:none;
	mso-level-text:"\9644\5F55A ";
	mso-level-tab-stop:21.25pt;
	mso-level-number-position:left;
	margin-left:21.25pt;
	text-indent:-21.25pt;}
@list l12:level2
	{mso-level-text:"A\.%2";
	mso-level-tab-stop:49.6pt;
	mso-level-number-position:left;
	margin-left:49.6pt;
	text-indent:-28.35pt;}
@list l12:level3
	{mso-level-text:"%1A\.%2\.%3";
	mso-level-tab-stop:70.9pt;
	mso-level-number-position:left;
	margin-left:70.9pt;
	text-indent:-28.35pt;}
@list l12:level4
	{mso-level-text:"%1\.%2\.%3\.%4";
	mso-level-tab-stop:99.2pt;
	mso-level-number-position:left;
	margin-left:99.2pt;
	text-indent:-35.4pt;}
@list l12:level5
	{mso-level-text:"%1\.%2\.%3\.%4\.%5";
	mso-level-tab-stop:127.55pt;
	mso-level-number-position:left;
	margin-left:127.55pt;
	text-indent:-42.5pt;}
@list l12:level6
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6";
	mso-level-tab-stop:163.0pt;
	mso-level-number-position:left;
	margin-left:163.0pt;
	text-indent:-56.7pt;}
@list l12:level7
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7";
	mso-level-tab-stop:191.35pt;
	mso-level-number-position:left;
	margin-left:191.35pt;
	text-indent:-63.8pt;}
@list l12:level8
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8";
	mso-level-tab-stop:219.7pt;
	mso-level-number-position:left;
	margin-left:219.7pt;
	text-indent:-70.9pt;}
@list l12:level9
	{mso-level-text:"%1\.%2\.%3\.%4\.%5\.%6\.%7\.%8\.%9";
	mso-level-tab-stop:255.1pt;
	mso-level-number-position:left;
	margin-left:255.1pt;
	text-indent:-85.0pt;}
ol
	{margin-bottom:0in;}
ul
	{margin-bottom:0in;}
-->
</style>

</head>

<body lang=EN-US link=blue vlink=purple style='text-justify-trim:punctuation'>

<div class=Section1 style='layout-grid:15.6pt'>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>Dear All,<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>I have one doubt in
the Tahi conformance DHCPv6 Server Test suit<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>The below mentioned
test case indicate weather Message level status code or IA level status code<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>Page no: 169;<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>Test case: <b><span
style='font-weight:bold'>5.69 Respond for when not appropriate for link(return
w/status code= NotOnlink) <o:p></o:p></span></b></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>;<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>;<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>Judgment is as
follows<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>&#8230;&#8230;&#8230;&#8230;&#8230;..<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>The Reply must have
IA_NA option with status code option NotOnLink. <o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>But Verification
points as <o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>&lt;&gt;msg-type<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; REPLY
(7)<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>.<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>.<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>.<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>.<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>&lt;&gt;IANA option<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>&lt;&gt;Status code
option<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Value
= NotOnLink<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'>Let me know weather
status code present is IA level or Message Level.<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:21.0pt'><font size=2 face=Arial><span
style='font-size:10.0pt;line-height:150%;font-family:Arial'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><font size=4
color=blue face=Arial><span style='font-size:14.0pt;font-family:Arial;
color:blue'>Thanks and Regards,<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt;line-height:
12.0pt'><font size=1 color=black face=Arial><span style='font-size:8.0pt;
font-family:Arial;color:black'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><font size=4
color=blue face=Arial><span style='font-size:14.0pt;font-family:Arial;
color:blue'>Mari Muthu D<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><font size=4
color="#ffcc00" face=Arial><span style='font-size:14.0pt;font-family:Arial;
color:#FFCC00'>Senior Software Engineer,<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><font size=4
color="#ffcc00" face=Arial><span style='font-size:14.0pt;font-family:Arial;
color:#FFCC00'>Huawei Technologies Co., Ltd.<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><font size=4
color="#ffcc00" face=Arial><span style='font-size:14.0pt;font-family:Arial;
color:#FFCC00'>#1489, Level 3, Leela Galleria,<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><st1:place
w:st="on"><st1:PlaceName w:st="on"><font size=4 color="#ffcc00" face=Arial><span
  style='font-size:14.0pt;font-family:Arial;color:#FFCC00'>Leela</span></font></st1:PlaceName><font
 size=4 color="#ffcc00" face=Arial><span style='font-size:14.0pt;font-family:
 Arial;color:#FFCC00'> <st1:PlaceType w:st="on">Palace</st1:PlaceType></span></font></st1:place><font
size=4 color="#ffcc00" face=Arial><span style='font-size:14.0pt;font-family:
Arial;color:#FFCC00'>, <st1:Street w:st="on"><st1:address
 style="BACKGROUND-POSITION: left bottom; BACKGROUND-IMAGE: url(res://ietag.dll/#34/#1001); BACKGROUND-REPEAT: repeat-x"
 tabIndex="0" w:st="on">#23, Airport Road</st1:address></st1:Street>,<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><st1:City
w:st="on"><st1:place w:st="on"><font size=4 color="#ffcc00" face=Arial><span
  style='font-size:14.0pt;font-family:Arial;color:#FFCC00'>Bangalore</span></font></st1:place></st1:City><font
size=4 color="#ffcc00" face=Arial><span style='font-size:14.0pt;font-family:
Arial;color:#FFCC00'> - 8</span></font><font size=1 color="#ffcc00" face=Arial><span
style='font-size:8.0pt;font-family:Arial;color:#FFCC00'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
<o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt;line-height:
12.0pt'><font size=1 color=black face=Arial><span style='font-size:8.0pt;
font-family:Arial;color:black'>&nbsp; <o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt'><font size=5
color="#0041c2" face="Monotype Corsiva"><span style='font-size:20.0pt;
font-family:"Monotype Corsiva";color:#0041C2'>Keep true, never be ashamed of
doing right; Decide on what you think is right and stick to it.</span></font><font
size=1 color=black face=Arial><span style='font-size:8.0pt;font-family:Arial;
color:black'><o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:48.0pt;text-indent:-27.0pt;line-height:
12.0pt'><font size=1 color=black face=Arial><span style='font-size:8.0pt;
font-family:Arial;color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
*************************************************************************************************************************************************************************************************************************************&nbsp;
&nbsp;This e-mail and attachments contain confidential information from HUAWEI,
which is intended only for the person or entity whose address is listed above.
Any use of the information contained herein in any way (including, but not
limited to, total or partial disclosure, reproduction, or dissemination) by
persons other than the intended recipient's) is prohibited. If you receive this
e-mail in error, please notify the sender by phone or email immediately and
delete it!<br>
*************************************************************************************************************************************************************************************************************************************</span></font><font
size=1 color=black face=Arial><span style='font-size:8.0pt;font-family:Arial;
color:black'><o:p></o:p></span></font></p>

<p class=MsoNormal style='margin-left:0in'><font size=2 face="Times New Roman"><span
style='font-size:10.5pt;line-height:150%'><o:p>&nbsp;</o:p></span></font></p>

</div>

</body>

</html>

--Boundary_(ID_9zPrlB9Gn/P+3KHved68EQ)--

--===============0263261330==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============0263261330==--

---

From: "Eric Kollmann" <[email-masked]>
Date: Sat, 1 Sep 2007 19:32:33 -0600

----

Eric