Subject: [dhcwg] Need more clarity on DHCPv6.

From: RamaSubramanian KrishnaMurthi <[email-masked]>
Date: Tue, 11 Sep 2007 05:07:07 -0700 (PDT)

Hi all,
I just want to know what is the difference between two for the following two paragraph.

Copy+Paste from RFC 3315: "18.2.3. Receipt of Renew Messages" : Page 51

Para 1:   If the server cannot find a client entry for the IA the server
               returns the IA containing no addresses with a Status Code option set
               to NoBinding in the Reply message.

Para 2:    If the server finds that any of the addresses are not appropriate for
               the link to which the client is attached, the server returns the
               address to the client with lifetimes of 0.

What should be the status code for para 2?

Yours ever
-RamaSubbu SK

____________________________________________________________________________________Ready for the edge of your seat? 
Check out tonight's top picks on Yahoo! TV. 
http://tv.yahoo.com/

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Tue, 11 Sep 2007 08:22:32 -0700

> What should be the status code for para 2?

Either omitted or Success.

The result of which would be that the client would downgrade the
lifetimes on the address(es) to zero, immediately expiring them.

If the server also included extra addresses in the Renew, the client
would continue on the new addresses.

If the server did not include any non-zero lifetime addresses, the
client could return to Solicit or Request (there's no telling which).

-- 
Ash bugud-gul durbatuluk agh burzum-ishi krimpatul.
-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		     you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg