Subject: Re: [dhcwg] Last Call: draft-ietf-mip6-hiopt (DHCP Options for Home Information Discovery in MIPv6) to Proposed Standard

From: Jari Arkko <[email-masked]>
Date: Tue, 26 Feb 2008 16:12:25 +0200

FYI -- this draft is being Last Called for the second time, due to
having changed substantially as a result of earlier reviews.

> The IESG has received a request from the Mobility for IPv6 WG (mip6) to 
> consider the following document:
>
> - 'DHCP Options for Home Information Discovery in MIPv6 '
>    <draft-ietf-mip6-hiopt-11.txt> as a Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2008-03-11. Exceptionally, 
> comments may be sent to [email-masked] instead. In either case, please 
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-mip6-hiopt-11.txt
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=15105&rfc_flag=0
>   

_______________________________________________
dhcwg mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/dhcwg

---

From: Bud Millwood <[email-masked]>
Date: Wed, 27 Feb 2008 10:35:40 +0100

> >    <draft-ietf-mip6-hiopt-11.txt> as a Proposed Standard

Section 3.1.1, the encoding for suboption 2 is the "standard" encoding for a 
prefix with one exception that I can see:

  "Home Network Prefix Sub-options"

This option is almost exactly like option 26 with one major exception: The 
"options" part of this suboption are subencoded options, not top-level DHCPv6 
options like with option 26.

Is that really right? The text for suboption 2 says: "Options associated with 
the IPv6 Home Network Prefix. Currently there is no sub-option available."

That implies that this area is open for further definition of options, whereas 
in the case of option 26, my understanding was that any options found in that 
option would *not* be specific to that option.

- Bud

Bud Millwood
Weird Solutions, Inc.
http://www.weird-solutions.com
tel: +46 8 758 3700
fax: +46 8 758 3687
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg