Subject: [dhcwg] for comments: Usage of Host Generating Interface Identifier in DHCPv6

From: "Frank Xia" <[email-masked]>
Date: Fri, 15 Feb 2008 23:40:53 -0600

Hi all

We just submitted the following draft:
http://www.ietf.org/internet-drafts/draft-xia-dhc-host-gen-id-00.txt

Abstract:
This document describes a procedure for configuring a host's IPv6
address which prefix is allocated from a DHCPv6 server while it's
interface identifier is independently generated by the host.  The
method is applicable to Cryptographically Generated Addresses (CGA).

Comments are welcome!                                                                                  

BR
Frank

_______________________________________________
dhcwg mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/dhcwg

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Sat, 16 Feb 2008 13:40:23 +0100

> method is applicable to Cryptographically Generated Addresses (CGA).

I gave this a quick read, it's possible that I missed a detail here or  
there.

Will DHCPv6 servers be given out the same prefix to multiple hosts?  
Obviously one prefix per host is problematic.

Also, why not simply have the hosts learn the prefix from routers?  
They need to see prefixes in router advertisements anyway to know that  
the prefix in question is on-link. Then, it's possible to ask the  
DHCPv6 server for a specific address in that prefix using the IA  
option, like I suggested in http://www.ietf.org/internet-drafts/draft-van-beijnum-cga-dhcp-interaction-00.txt

Iljitsch

---

From: Francis Dupont <[email-masked]>
Date: Sun, 17 Feb 2008 10:52:52 +0100

This draft is based in a commun misunderstanding about DHCPv6: this
protocol never provides the prefix(es) used on a link. The only
standardized way to get prefix informations, in particular the length
of the prefix(es), is to listen to Router Advertisements.
 This can be considered as an annoying limitation of DHCPv6 and is
known to be the source of real world difficulties, but this is a fact!
 So before the IA_PA idea makes sense we need first a drastic change
in the design of DHCPv6 itself...

Thanks

[email-masked]
_______________________________________________
dhcwg mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/dhcwg

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 18 Feb 2008 09:23:14 +0800

Hi, as Ilji already said, the best way hosts learn the prefix is from routers by RA.
Also, I think you misunderstand the DHCP work item within CSI WG. We are not going
to define the DHCP options at this moment, we are "analysing different approaches to
allow SeND and CGAs to be used in conjunction with DHCP, and making recommendations
on which are the best suited." The actual DHCP options can only be sure after we
done the analysis. Please see the following draft for the analysis regarding to
generating CGA involving both RA and DHCP. It is first submitted July 2007, and now
in 01 version.

http://www.ietf.org/internet-drafts/draft-jiang-sendcgaext-cga-config-01.txt

Best regards,

Dr. Sheng JIANG

IP Research Department, Networking Research Department, Network Product Line, Huawei
Technologies Co. Ltd.

*-----Original Message-----
*From: [email-masked] 
*[mailto:[email-masked]] On Behalf Of Iljitsch van Beijnum
*Sent: Saturday, February 16, 2008 8:40 PM
*To: Frank Xia
*Cc: [email-masked]; [email-masked]
*Subject: Re: [CGA-EXT] for comments: Usage of Host Generating 
*InterfaceIdentifier in DHCPv6
*
*On 16 feb 2008, at 6:40, Frank Xia wrote:
*
*> http://www.ietf.org/internet-drafts/draft-xia-dhc-host-gen-id-00.txt
*
*> Abstract:
*> This document describes a procedure for configuring a host's IPv6 
*> address which prefix is allocated from a DHCPv6 server while it's 
*> interface identifier is independently generated by the host.  The 
*> method is applicable to Cryptographically Generated Addresses (CGA).
*
*I gave this a quick read, it's possible that I missed a detail 
*here or there.
*
*Will DHCPv6 servers be given out the same prefix to multiple hosts?  
*Obviously one prefix per host is problematic.
*
*Also, why not simply have the hosts learn the prefix from routers?  
*They need to see prefixes in router advertisements anyway to 
*know that the prefix in question is on-link. Then, it's 
*possible to ask the
*DHCPv6 server for a specific address in that prefix using the 
*IA option, like I suggested in 
*http://www.ietf.org/internet-drafts/draft-van-beijnum-cga-dhcp-
*interaction-00.txt
*
*Iljitsch
*_______________________________________________
*CGA-EXT mailing list
[email-masked]
*http://www.ietf.org/mailman/listinfo/cga-ext
*

---

From: "Frank Xia" <[email-masked]>
Date: Sun, 17 Feb 2008 23:24:32 -0600

Hi Iljitsch

The proposal is a general DHCP procedure not specific to CGA.

To be honest,  the work is originated from our point-to-point  prefix allocation research
such as, 
http://tools.ietf.org/id/draft-xia-mipshop-fmip-ptp-01.txt
http://tools.ietf.org/wg/16ng/draft-sarikaya-16ng-prefix-delegation-02.txt,
http://tools.ietf.org/wg/dime/draft-sarikaya-dime-prefix-delegation-ps-00.txt

Please see my other inline comments...

BR
Frank

----- Original Message ----- 
From: "Iljitsch van Beijnum" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Saturday, February 16, 2008 6:40 AM
Subject: Re: [CGA-EXT] for comments: Usage of Host Generating Interface Identifier in DHCPv6

> I gave this a quick read, it's possible that I missed a detail here or  
Frank=>thank for your quick review.

> Obviously one prefix per host is problematic.
Frank=>This draft only deals with one prefix per host case.
In this scenario, each host has unique prefix.
Probably, you can check out the following documents about point-to-point link model:
http://tools.ietf.org/rfc/rfc4968.txt
http://tools.ietf.org/rfc/rfc5121.txt
http://www.ietf.org/rfc/rfc3314.txt

> Also, why not simply have the hosts learn the prefix from routers?  
Frank=>Stateless address configuration requires prefix advertised from
routers.  But, in stateful address configuration, prefixes should be from a
DHCP server.  It makes sense that prefixes are managed by a central DHCP
server in some situation.

---

From: "Frank Xia" <[email-masked]>
Date: Sun, 17 Feb 2008 23:32:29 -0600

Hi Francis

Thank you for your comments.

" So before the IA_PA idea makes sense we need first a drastic change
 in the design of DHCPv6 itself..."

You are right.
Our draft DO extend the design of DHCPv6 itself.
So our draft was submited to DHCP WG.

It probabaly makes sense if we try to solve the problems described
in the draft.

BR
Frank