Subject: Re: [dhcwg] about mip6-hiopt I-D

From: Heejin Jang <[email-masked]>
Date: Thu, 03 Apr 2008 05:00:18 +0000 (GMT)

Hi, Francis.

If I understand what you're saying right, your points are 
1) You don't like a 'zig-zag' delivery path.
2) So, you prefer to optimize the path by allowing the relay to respond to the MN directly.
(Agent concept)

My opinion is that I'm not against the efficiency of optimization itself. 
However, that approach requires the change of DHCPv6 relay operation, that is, 
change of RFC3315.  I cannot use such optimization which is not documented 
anywhere. It should be standardized in DHCP documents first. 

Our discussion seems to be in the loop. 
I think that we need the help of AD or DHC wg chairs.

- Best regards, 
Heeiin.

------- Original Message -------
Sender : Francis Dupont<[email-masked]>
Date   : 2008-04-03 06:53 (GMT+09:00)
Title  : Re: [dhcwg] about mip6-hiopt I-D

 In your previous mail you wrote:

   As I understand, you are questioning the need for DHCP relay sending the
   AAA-delivered info to the DHCP server.
   
=> yes, the path followed by the infos is silly IMHO.

   This is for the case where NAS is co-located with the DHCP relay, and there
   is a separate DHCP server somewhere else in the same "local" network.  The
   AAA-delivered info needs to be provided to the DHCP server, so that the DHCP
   server delivers it to the DHCP client. Yes the info needs to zig-zag, but
   that&#39;s necessary unless the node acting as DHCP relay assumes the role of a
   DHCP server.
   
=> I believe you share a misconception with I-D&#39;s author: there is no
such "the server" thing. The DHCP service can be provided by multiple
servers in parallel (because requests are multicasted at different
layers). So it is possible and even natural to reply, perhaps partially,
locally. You give a way to implement it (this is the most efficient)
but there are others, for instance co-locate a server or simply have
the relay forwards to a local server too.
So I still do not like the zig-zag...

Thanks

[email-masked]
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Francis Dupont <[email-masked]>
Date: Mon, 07 Apr 2008 15:54:20 +0200

2) So, you prefer to optimize the path by allowing the relay to
   respond to the MN directly. (Agent concept)
   
=> I'd like to get the reply performed locally. The agent concept is just
a way to implement it.

=> you don't read what I write...