Subject: [dhcwg] comments on draft-popoviciu-dhc-certificate-opt-01

From: Frank Xia <[email-masked]>
Date: Tue, 15 Apr 2008 12:07:18 -0500

Hi Folks

I had a quick look at the draft
http://tools.ietf.org/id/draft-popoviciu-dhc-certificate-opt-01.txt.

Here are some questions.

where does the delegating router get the certificate?
using manual configuration or using dymanic mechanism to get
the certificate from other entities?

is it possible for the requesting router to retrieve the certificate
from a DHCP server rather than the delegating server?

BR
Frank
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Eric Levy-Abegnoli <[email-masked]>
Date: Wed, 23 Apr 2008 00:50:06 +0200

> the certificate from other entities?
either way. This is outside the scope of this specification, and there
exist a number of mechanisms to achieve that (SCEP, CMP,...)
> from a DHCP server rather than the delegating server?
the delegating server and the DHCP server can be collapsed. It is just a
special case of the more general case that we tried to cover
Eric
> BR
> Frank
> ------------------------------------------------------------------------
>

---

From: Frank Xia <[email-masked]>
Date: Wed, 23 Apr 2008 09:29:02 -0500

Hi Eric

Please see my inline response...

BR
Frank
  ----- Original Message ----- 
  From: Eric Levy-Abegnoli 
  To: Frank Xia 
  Cc: [email-masked] 
  Sent: Tuesday, April 22, 2008 5:50 PM
  Subject: Re: [dhcwg] comments on draft-popoviciu-dhc-certificate-opt-01

  either way. This is outside the scope of this specification, and there
  exist a number of mechanisms to achieve that (SCEP, CMP,...)
  Frank=>I encourage you make it more detailed. I think it is better for
  people to understand the use case or background. You define a protocol,
  and the others probably dont know how to use it.

  the delegating server and the DHCP server can be collapsed. It is just a
  special case of the more general case that we tried to cover
  Frank=>I can't get your point.  I would like to reword my question.
  It is possible for the following scenario?
  A dedicated DHCP server stores a router's  certificate,
  then the router get the certificate from the DHCP server.

  Eric