Subject: Re: [dhcwg] Mobility support in DHCPv6

From: HYUN WOOK CHA <[email-masked]>
Date: Thu, 15 May 2008 08:57:24 +0000 (GMT)

Hello, Francis.

Would you tell me what if the informations contained in PIO regarding HNP can not be given? 
In this case, a host views all destinations as off-link and forward all packets to current default gateway(s). Are there any problems?

As you know, DHCPv6 PD functionality requires that routes for delegated prefixes should be injected by Relay Agent for the case where DHCPv6 server is not on-link with a RR. Inspired from this, I think one solution is for Relay Agent on LMA to maintain route informations for addresses/prefixes leased to a mobile host. 

It seems to me that exchanging PBU/PBA and advertising HNP are not essential for a host to keep communicating using addresses configured via DHCPv6. 

Joseph

------- Original Message -------
Sender : Francis Dupont<[email-masked]> 
Date   : 2008-05-15 16:32 (GMT+09:00)
Title  : Re: [dhcwg] Mobility support in DHCPv6

DHCPv6 doesn't provide all the informations needed for a host
configuration, for instance it doesn't provide the prefix length
or whether the prefix is on-line or not (cf the recent 6man I-D
about subnets vs. prefixes).
So if you believe this should be changed, netlmm or dhc WGs are not
the right place. In general, I strongly object any proposal to "adapt"
IPv6 core protocols to mobility done by a mobility WG outside its charter.

Thanks

[email-masked]

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Francis Dupont <[email-masked]>
Date: Sat, 17 May 2008 14:51:39 +0200

In your previous mail you wrote:

   Would you tell me what if the informations contained in PIO
   regarding HNP can not be given?
   In this case, a host views all destinations as off-link and forward
   all packets to current default gateway(s). Are there any problems?

=> just a little problem: how the host knows the default gateway(s)?
The whole point is DHCPv6 does not replace Router Advertisements.
   
   As you know, DHCPv6 PD functionality requires...

=> it doesn't require this kind of things. BTW:
 - there are other ways (even I like the Relay spoofing one)
 - there is no official document about this.

Thanks