Subject: [dhcwg] DHCPv6 LEASEQUERY

From: [email-masked]
Date: Mon, 05 May 2008 09:04:51 +0200

Hello 

my name is rafael. I'm contacting you, to ask you if there is any 
option in DHCPv6 that enables a DHCPv6 client to retrieve the address of a client to which a certain prefix was delegated to? DHCPv6 allows a client to get one or 
more prefix(es) by the DHCPv6 server. I assume that a DHCPv6 server is keeping a binding list or a binding table, i don't know exactly. In this list the server keeps track over the delageted prefixes an may be also information 
about the IPv6 address of the client(that client could be a router, 
that forwards the received prefixes to hosts whithin a router 
advertisement message) to which the prefix(es) were delegated to. So, is 
there a possibility or a DHCPv6 option to ask for the client's address 
regarding a specific prefix? I have read something about the 'Lease 
query' option, but I'm not sure if this options is capable in 
retrieving the address of the entity to which the specific prefix were delegated by the DHCPv6 server. 

Thanks a lot in advance,

Rafael

P.S.: In RFC5007 (LEASEQUERY) there is the 'Client Link Option' defined, which provides a LEASEQUERY requestor with link-addresses, to which a client keeps one or more bindings. It is ONLY used in reply to a LEASEQUERY when no link-address was specified and the client is found to be on MORE than one link. That is my problem!! The 'Client Link Option' should also be returned in a LEASEQUERY-REPLY even then, when the client has ONE binding with a link. Is there a possibility to get the link-address or it is necessary to define a new option for my purposes?
-- 
249 Spiele für nur 1 Preis. Die GMX Spieleflatrate schon ab 9,90 Euro.
Neu: Asterix bei den Olympischen Spielen: http://flat.games.gmx.de
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 14 May 2008 22:58:54 -0400

RFC 5007 sure does have this support.

3.3.  Query Types

   Leasequery provides for the following queries:

   Query by IPv6 address -  This query allows a requestor to request
      from a server the bindings for a client that either is bound to
      the address or has been delegated the prefix that contains the
                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
      address.
      ^^^^^^^

So, you CAN NOT query for a particular prefix, but you CAN QUERY for an address and get the delegated prefix that contains the address.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 05, 2008 3:05 AM
To: [email-masked]
Subject: [dhcwg] DHCPv6 LEASEQUERY

Hello 

Thanks a lot in advance,

Rafael

---

From: [email-masked]
Date: Thu, 15 May 2008 08:29:46 +0200

Hi Bernie,

thanks for your response! Please see below.

> So, you CAN NOT query for a particular prefix, but you CAN QUERY for an
> address and get the delegated prefix that contains the address.

I won't query for a particular prefix address. I want to query the address of a DHCP client to which a certain address or prefix was delegated to. And to do so, I have to use the delegated address or prefix as an indicator for the DHCPv6 server, to query the address of the client (requesting router).

Please see below to understand my problem/need.

I have read RFC 3633 ('IPv6 Prefix Options for DHCPv6) and there are now one or more questions regarding the prefix delegation option, particularly the behavior of the Delegating Router (DHCPv6 Server).

RFC 3633 allows a Requesting Router to request one or more IPv6 prefixes from the Delegating Router. To do so the Requesting Router has to send a Solicit message, containing a IA_PD option and a IA_PD Prefix option, to the Delegating Router. Subsequently the Delegating Router, if supported, has to assign one or more prefixes --depending on the solicit message-- and to send a response to the Requesting Router (prefix acquiring is simplified). See below for a detailed prefix acquisition behavior. 

Requesting Router (DHCPv6 Client)      Delegating Router (DHCPv6 Server)  
         |                                              |        
         |-Solicit------------------------------------->|
         |<--Advertise (Prefix)-------------------------|
         |-Request (Prefix)---------------------------->| 
         |<--Reply (Prefix)-----------------------------|
         |                                              |

After receiving one or more prefixes, the Requesting Router can use that prefixes to build-up one or more subnets. See figure 1 on page 3 of RFC3633).

My first question:

Does the delegating router keep track over the address to which he has send the prefixes? I think, he has to store the interface address which the requesting router has used to send a solicit message toward the DHCPv6 server. 

Second question (and the most important one ;) ): 

Is there really no LEASE_QUERY, to ask after the address of the interface, to which a certain prefix was delegated to? Maybe there is another possibility to ask the DHCPv6 server after the requesting router's IP address to which he has delegated a certain prefix.

Ok, if you say, I have to create a LEASE_QUERY which uses 'Query by IPv6 address', than which option have I to use in the 'Option Request' option to indicate the DHCPv6 server to supply me with the client's address? There is no such option. There are only the OPTION_CLIENTID, OPTION_IAADR, OPTION_IAPREFIX and the OPTION_CLT_TIME within a LEASEQUERY-REPLY's 'OPTION_CLIENT_DATA' option.

If there is really not such Request message, then it will be necessary for me to draw up a draft.

Thanks for your time!

> option in DHCPv6 that enables a DHCPv6 client to retrieve the address of a
> client to which a certain prefix was delegated to? DHCPv6 allows a client
> to get one or 
> more prefix(es) by the DHCPv6 server. I assume that a DHCPv6 server is
> keeping a binding list or a binding table, i don't know exactly. In this list
> the server keeps track over the delageted prefixes an may be also
> information 
> P.S.: In RFC5007 (LEASEQUERY) there is the 'Client Link Option' defined,
> which provides a LEASEQUERY requestor with link-addresses, to which a client
> keeps one or more bindings. It is ONLY used in reply to a LEASEQUERY when
> no link-address was specified and the client is found to be on MORE than
> one link. That is my problem!! The 'Client Link Option' should also be
> returned in a LEASEQUERY-REPLY even then, when the client has ONE binding with a
> link. Is there a possibility to get the link-address or it is necessary to
> define a new option for my purposes?
> -- 

-- 
Ist Ihr Browser Vista-kompatibel? Jetzt die neuesten 
Browser-Versionen downloaden: http://www.gmx.net/de/go/browser
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ole Troan <[email-masked]>
Date: Thu, 15 May 2008 10:48:59 +0200

> I won't query for a particular prefix address. I want to query the  
> address of a DHCP client to which a certain address or prefix was  
> delegated to. And to do so, I have to use the delegated address or  
> prefix as an indicator for the DHCPv6 server, to query the address  
> of the client (requesting router).
>
> I have read RFC 3633 ('IPv6 Prefix Options for DHCPv6) and there are  
> now one or more questions regarding the prefix delegation option,  
> particularly the behavior of the Delegating Router (DHCPv6 Server).
>
> RFC 3633 allows a Requesting Router to request one or more IPv6  
> prefixes from the Delegating Router. To do so the Requesting Router  
> has to send a Solicit message, containing a IA_PD option and a IA_PD  
> Prefix option, to the Delegating Router. Subsequently the Delegating  
> Router, if supported, has to assign one or more prefixes --depending  
> on the solicit message-- and to send a response to the Requesting  
> Router (prefix acquiring is simplified). See below for a detailed  
> prefix acquisition behavior.
>
>
> After receiving one or more prefixes, the Requesting Router can use  
> that prefixes to build-up one or more subnets. See figure 1 on page  
> 3 of RFC3633).
>
> My first question:
>
> Does the delegating router keep track over the address to which he  
> has send the prefixes? I think, he has to store the interface  
> address which the requesting router has used to send a solicit  
> message toward the DHCPv6 server.
>

yes. the link-local IPv6 address of the RR.

> Is there really no LEASE_QUERY, to ask after the address of the  
> interface, to which a certain prefix was delegated to? Maybe there  
> is another possibility to ask the DHCPv6 server after the requesting  
> router's IP address to which he has delegated a certain prefix.
>

a prefix is not delegated to an interface. it is delegated to the RR  
which can split the prefix and use it on downstream interfaces. if you  
want to know the global IPv6 address on the upstream interface, then  
that is of no concern to the prefix delegation mechanism. you can for  
example assign this address using normal DHCP address configuration.

> Ok, if you say, I have to create a LEASE_QUERY which uses 'Query by  
> IPv6 address', than which option have I to use in the 'Option  
> Request' option to indicate the DHCPv6 server to supply me with the  
> client's address? There is no such option. There are only the  
> OPTION_CLIENTID, OPTION_IAADR, OPTION_IAPREFIX and the  
> OPTION_CLT_TIME within a LEASEQUERY-REPLY's 'OPTION_CLIENT_DATA'  
> option.
>
>

/ot

---

From: [email-masked]
Date: Thu, 15 May 2008 11:55:58 +0200

Hi OT, 

thanks for your answer.

Please see below
-------- Original-Nachricht --------
> Datum: Thu, 15 May 2008 10:48:59 +0200
> Von: Ole Troan <[email-masked]>
> An: [email-masked]
> CC: "Bernie Volz (volz)" <[email-masked]>, [email-masked]
> Betreff: Re: [dhcwg] DHCPv6 LEASEQUERY

> which can split the prefix and use it on downstream interfaces. 

It's right, that an RR can split the prefix and use it on the downstream interfaces.
  
>if you want to know the global IPv6 address on the upstream interface, >then that is of no concern to the prefix delegation mechanism.

Okay!

> you can for example assign this address using normal DHCP address 
> configuration.

I won't assign this address. I want to know this upstream address. How can a DHCPv6 server provide me with that upstream interface address? It seems, that the LEASE_QUERY option doesn't help me. It must be a possibility to request from the DHCPv6 server the address of the RR, to which he has delegated a certain address or prefix.

Do you have some recommendation? Maybe I have oversighted such an DHCPv6 option as I'm very new in DHCPv6.

> > necessary for me to draw up a draft.

Thanks a lot in advance.

Rafael 

-- 
GMX startet ShortView.de. Hier findest Du Leute mit Deinen Interessen!
Jetzt dabei sein: http://www.shortview.de/?mc=sv_ext_mf@gmx
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Francis Dupont <[email-masked]>
Date: Thu, 15 May 2008 10:10:58 +0200

In your previous mail you wrote:

   Does the delegating router keep track over the address to which he
  has send the prefixes? I think, he has to store the interface address
  which the requesting router has used to send a solicit message toward
  the DHCPv6 server.
   
=> no, it should keep only the DUID. BTW the server should know the
client address (or the address and a relay chain) only to send
reconfigure messages.

   Is there really no LEASE_QUERY, to ask after the address of the
  interface, to which a certain prefix was delegated to? Maybe there is
  another possibility to ask the DHCPv6 server after the requesting
  router's IP address to which he has delegated a certain prefix.
   
=> a LEASE_QUERY returns the DUID and optionally the relay chain.
Don't expect it to provide infos the server doesn't keep in the
common case...

   Ok, if you say, I have to create a LEASE_QUERY which uses 'Query by
  IPv6 address', than which option have I to use in the 'Option Request'
  option to indicate the DHCPv6 server to supply me with the client's
  address? There is no such option. There are only the OPTION_CLIENTID,
  OPTION_IAADR, OPTION_IAPREFIX and the OPTION_CLT_TIME within a
  LEASEQUERY-REPLY's 'OPTION_CLIENT_DATA' option.
   
=> it seems not only you know the answer but even the reasons.
   
   If there is really not such Request message, then it will be
  necessary for me to draw up a draft.
   
=> IMHO a draft won't solve your problem: you should look for
a solution using a routing protocol as if you don't know where
to send packet to an address in a delegated prefix you are in
trouble, and this is not the job of DHCP.

Regards

[email-masked]
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg