Subject: Re: [dhcwg] Accepting the following drafts as WG work items

From: Bharat Joshi <[email-masked]>
Date: Sun, 19 Oct 2008 23:12:05 +0530

Hi John/Ralph,

     Should we submit a working group specific draft for draft-kurapati-dhc-leasequery-by-remote-id-01?

Thanks,
Bharat
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of John Jason Brzozowski [[email-masked]]
Sent: Thursday, September 18, 2008 10:45 AM
To: dhc WG
Cc: dhc Chairs
Subject: [dhcwg] Accepting the following drafts as WG work items

At the last dhc WG meeting, the consensus of attendees at the meeting
was to accept the following drafts as WG work items:

draft-miles-dhc-dhcpv6-ldra-00
draft-kurapati-dhc-leasequery-by-remote-id-01

If you feel that one or both of these drafts should not be accepted as
WG work items, please respond to the WG mailing list by Mon, 09-26-2008.

-Ralph Droms, John Brzozowski
   dhc WG chairs

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 19 Oct 2008 15:16:56 -0400

Usually once an I-D is accepted as a work item, that should be done.

When you do, please make sure to clean up the following text in 6.4. 

   In the case where more than one IP address has been accessed by the
   client specified by the Remote ID, then the DHCP server MUST return
   the IP address returned to the client in the most recent transaction
   with the client unless the DHCP server has been configured by the
   server administrator to use some other preference mechanism.

The assumption that there is a single client (for a specific remote id)
is wrong. There could be multiple clients that share the same remote id
(this is the case in DOCSIS, for example where the CM and the CPE will
have the same remote id and if multiple CPEs are allowed, they would
also all have the same remote-id -- these are all clearly not the same
client).

There may be other places where the text needs to be changed.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Bharat Joshi
Sent: Sunday, October 19, 2008 1:42 PM
To: John Jason Brzozowski; dhc WG
Cc: dhc Chairs
Subject: Re: [dhcwg] Accepting the following drafts as WG work items

Hi John/Ralph,

     Should we submit a working group specific draft for
draft-kurapati-dhc-leasequery-by-remote-id-01?

Thanks,
Bharat
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of John
Jason Brzozowski [[email-masked]]
Sent: Thursday, September 18, 2008 10:45 AM
To: dhc WG
Cc: dhc Chairs
Subject: [dhcwg] Accepting the following drafts as WG work items

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended
solely 
for the use of the addressee(s). If you are not the intended recipient,
please 
notify the sender by e-mail and delete the original message. Further,
you are not 
to copy, disclose, or distribute this e-mail or its contents to any
other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys
has taken 
every reasonable precaution to minimize this risk, but is not liable for
any damage 
you may sustain as a result of any virus in this e-mail. You should
carry out your 
own virus checks before opening the e-mail or attachment. Infosys
reserves the 
right to monitor and review the content of all messages sent to or from
this e-mail 
address. Messages sent to or from this e-mail address may be stored on
the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Bharat Joshi <[email-masked]>
Date: Mon, 20 Oct 2008 10:17:13 +0530

Hi Bernie,

> Usually once an I-D is accepted as a work item, that should be done.

So this means, I can generate a ietf draft and submit. Thanks!

> also all have the same remote-id -- these are all clearly not the same

We do not have an assumption that there is a single client attached to a remote-id. What this paragraph means to convey is that DHCP server should return the most recently accessed IP address by a client using that remote-id. I will try to re-phrase this paragraph.

> There may be other places where the text needs to be changed.

I will see if there are any other place where such an assumption is visible, I will re-phrase that part of the text as well.

Regards,
Bharat