Subject: [dhcwg] Fwd: I-D ACTION:draft-boucadair-dhc-port-range-00.txt

From: Ralph Droms <[email-masked]>
Date: Mon, 27 Oct 2008 15:21:44 -0400

See below for an announcement of a new draft of interest to the dhc  
WG.  Review and comments welcome...

- Ralph

Begin forwarded message:

> From: [email-masked]
> Date: October 27, 2008 3:00:01 PM EDT
> To: [email-masked]
> Subject: I-D ACTION:draft-boucadair-dhc-port-range-00.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: DHCP Options for Conveying Port Mask and Port Range Router  
> IP Address
>
> 	Author(s)	: M. Boucadair, J. Grimault, P. Levis
> 	Filename	: draft-boucadair-dhc-port-range-00.txt
> 	Pages		: 15
> 	Date		: 2008-10-27
> 	
> This draft defines two new DHCP (Dynamic Host Configuration Protocol,
>   [RFC2131]) Options to be used in the context of Provider-Provisioned
>   CPE solution (a.k.a.  Port Range solution or Fractional Address).
>   The first option is used to convey a Port Mask and the second one  
> may
>   be used to convey a list of Port Range Router IP addresses.
>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-boucadair-dhc-port-range-00.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: <[email-masked]>
Date: Mon, 27 Oct 2008 21:47:31 +0200

The DHC WG could also look at the very related draft "Port Restricted IP
Address Assignment",
http://www.ietf.org/internet-drafts/draft-bajko-v6ops-port-restricted-ip
addr-assign-01.txt

--
Abstract 
    
   With the foreseen scarcity of public IPv4 addresses and the 
   hesitation and technical difficulties to deploy IPv6, the transition 
   scenarios which assumed that migration to IPv6 happens before the 
   run-out of IPv4 addresses, need to be revisited. 
   This document defines a method to allocate the same IPv4 address to 
   multiple hosts, thus prolonging the availability of public IPv4 
   addresses for as long as it takes for IPv6 to take over the demand 
   for IPv4. The document also describes the deployment scenarios where 
   this method is applicable. 
--

Our approach was to make DHCP messages used to allocate fractional IP
addresses differ clearly from normal address allocations and thus have
'yiaddr' 0.0.0.0 when the proposed new option having IP address with
port range is present.

Best regards,

	Teemu

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of ext Ralph Droms
>Sent: 27 October, 2008 21:22
>To: DHC WG
>Subject: [dhcwg] Fwd: I-D ACTION:draft-boucadair-dhc-port-range-00.txt
>
>See below for an announcement of a new draft of interest to 
>the dhc WG.  Review and comments welcome...
>
>- Ralph
>
>Begin forwarded message:
>