Subject: Re: [dhcwg] [netlmm] Request for review of draft-xia-netlmm-lma-discovery-01.txt

From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 04 May 2009 14:34:23 +0300

Hi,

I agree with Vijay. So far there has been no identified need to have 
DHCP client functionality in the MAG. MAG is basically infrastructure 
equipment and I wonder if DHCP is really the right technology for it.

In addition, I don't know if Vidya has, but I at least I have not asked 
for any official review of this document, which is just an individual draft.

Cheers,

Jonne.
ext Vijay Devarapalli wrote:
> Behcet,
>
> We had numerous discussions on this in the past. The MAG is not a DHCP
> client according to any of the specifications we have so far. I don't think
> it makes sense for the MAG to implement DHCP client functionality just to
> obtain the LMA IP address.
>
> Moreover, the MAG acting as a DHCP client doesn't is not valid in any of the
> SDO architectures that are using PMIPv6.
>
> We shouldn't extend protocols just because we can.
>
> Vijay
>
> On 4/29/09 12:20 PM, "Behcet Sarikaya" wrote:
>
>   
>> Hi Ted,
>>   The reason we wrote this draft is already stated in netlmm charter
>> (http://www.ietf.org/html.charters/netlmm-charter.html) item 6 which states
>> that:
>> 6) Automatic LMA discovery: This will define the ability for MAGs to
>> automatically discover and use an LMA within a PMIPv6 domain. The
>> scope of this effort may include specifying the use of DNS or DHCP
>> based LMA discovery or LMA discovery using policy information
>> retrieved via AAA protocols
>>
>>   At the moment we don't know if netlmm will adopt this draft. There is
>> another draft co-authored by Vijay which is about some other non-DHCP means of
>> LMA discovery, hence Vijay's intervention here .
>>   Based on the above having a quick preliminary review by DHC WG will be quite
>> helpful to netlmm folks.
>>  
>> Regards,
>>  
>> Behcet
>>
>> From: Ted Lemon <[email-masked]>
>> To: Vijay Devarapalli <[email-masked]>
>> Cc: dhc WG <[email-masked]>; "[email-masked]" <[email-masked]>
>> Sent: Wednesday, April 29, 2009 1:00:49 PM
>> Subject: Re: [dhcwg] Request for review of
>> draft-xia-netlmm-lma-discovery-01.txt
>>
>> On Apr 29, 2009, at 12:39 PM, Vijay Devarapalli wrote:
>>     
>>> I am not sure who requested this draft to be reviewed by the DHC WG.
>>> There is no consensus in the NETLMM WG at this point for the PMIPv6 MAG
>>> function to use DHCPv6 to obtain the LMA IP address. So any DHC WG
>>> review would be premature at this point.
>>>       
>> My motivation in asking for review of this document before it's been adopted
>> by the netlmm working group as a work item, is that it appears to make a
>> rather novel use of the DHCPv6 protocol.  Unless the netlmm working group has
>> already decided not to adopt this draft, I think it makes some sense for you
>> to consider feedback from the DHC working group on the draft when you are
>> deliberating on whether or not to adopt the draft as a netlmm working group
>> item.
>>
>> So if in fact there is no likelihood that the netlmm working group will adopt
>> this draft, it would certainly save us some effort to know that.  Otherwise I
>> think actually this is a good time for the DHC working group to give the draft
>> a quick preliminary review.
>>
>> _______________________________________________
>> dhcwg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dhcwg
>>
>>  
>>     
>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm
>

---

From: Frank Xia <[email-masked]>
Date: Mon, 04 May 2009 10:33:45 -0500

Hi Jonne

I don't get the logic you have.

Our protocol design servers  business requirment.
I believe if there is a solid scenario, there is
no reason for us  to refuse it just  say "currently
there is no ready DHCP client".

BTW, we did not ask DHC group to review before
the Ted commented it.

BR
Frank

----- Original Message ----- 
From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
To: "ext Vijay Devarapalli" <[email-masked]>
Cc: "dhc WG" <[email-masked]>; <[email-masked]>; "Ted Lemon" 
<[email-masked]>
Sent: Monday, May 04, 2009 6:34 AM
Subject: Re: [netlmm] [dhcwg] Request for review 
ofdraft-xia-netlmm-lma-discovery-01.txt

> Hi,
>
> I agree with Vijay. So far there has been no identified need to have DHCP 
> client functionality in the MAG. MAG is basically infrastructure equipment 
> and I wonder if DHCP is really the right technology for it.
>