Subject: Re: [dhcwg] [netlmm] Request for review of draft-xia-netlmm-lma-discovery-01.txt

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 6 May 2009 12:35:55 -0700 (PDT)

Sorry for late reply as I received this mail today.

________________________________

From: Ted Lemon <[email-masked]>
To: Vijay Devarapalli <[email-masked]>
Cc: dhc WG <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Wednesday, April 29, 2009 1:00:49 PM
Subject: Re: [netlmm] [dhcwg] Request for review of draft-xia-netlmm-lma-discovery-01.txt

[behcet] Is your concern related to co-locating DHCP Client with DHCP Relay?
If yes, please state why?
 
Or is it related to AAA because as you said earlier DHCP server has to contact AAA?

If yes, I think you got this impression because of Figure 2 which is misleading as it tries to show two methods at the same time. But in the text it is clarifed. The two, AAA part and DHCP are totally unrelated, if you do get LMA address from AAA as in Step 1 you stop there. Otherwise you continue with steps 2 & 3.

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

On Apr 29, 2009, at 12:39 PM, Vijay Devarapalli wrote:
> I am not sure who requested this draft to be reviewed by the DHC WG.
> There is no consensus in the NETLMM WG at this point for the PMIPv6 MAG
> function to use DHCPv6 to obtain the LMA IP address. So any DHC WG
> review would be premature at this point.

My motivation in asking for review of this document before it's been adopted by the netlmm working group as a work item, is that it appears to make a rather novel use of the DHCPv6 protocol.  Unless the netlmm working group has already decided not to adopt this draft, I think it makes some sense for you to consider feedback from the DHC working group on the draft when you are deliberating on whether or not to adopt the draft as a netlmm working group item.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 6 May 2009 16:46:42 -0500

On May 6, 2009, at 2:35 PM, Behcet Sarikaya wrote:
> If yes, I think you got this impression because of Figure 2 which is  
> misleading as it tries to show two methods at the same time. But in  
> the text it is clarifed. The two, AAA part and DHCP are totally  
> unrelated, if you do get LMA address from AAA as in Step 1 you stop  
> there. Otherwise you continue with steps 2 & 3.

In a sense this clarification helps - I had in fact misread how this  
interaction worked.   However, step 3 is still basically magic -  
essentially what it looks like is that you are using the DHCPv6 server  
in the same way that you would be using the AAA server.   While a  
DHCPv6 server could be implemented that functioned in this way, I  
don't see what the advantage would be of this over just using an AAA  
server.

If the problem is that the NAS/MAG doesn't know how to contact the AAA  
server, it would seem to be a better use of DHCPv6 to acquire the  
address of the AAA server and then contact the AAA server to fulfill  
the MN/user's request.   If the problem is something else, can you  
explain further?   This is why I am asking about the motivation behind  
using DHCPv6 - it's still not clear to me what problem you are trying  
to solve here.

Maybe a better question for me to ask is, how does this differ from  
what's already specified in draft-ietf-mip6-hiopt-17.txt?  And what's  
the status of that draft anyway?  It looks like it's going to expire  
soon.   Is that still an active proposal?   Who's shepherding it?    
The last time it was discussed on the DHC working group mailing list  
was April of 2008.

---

From: Frank Xia <[email-masked]>
Date: Wed, 06 May 2009 17:30:11 -0500

Hi Ted

Sorry for my jumping in.

draft-ietf-mip6-hiopt-17.txt defines DHCP options
for a mobile node to fetch available HA information
from a DHCP server. The information stored in DHCP
server is independent from  any AAA facility.

In real deployment scenario,  HAs are normally colocated
with LMAs. That is,  a physical network device acts as both
HA and LMA.  It also means the DHCP server stores LMA
information.

So,  mechanism is needed for a MAG to fectch LMA/HA
information from the DHCP server.

BR
Frank

----- Original Message ----- 
From: "Ted Lemon" <[email-masked]>
To: "Behcet Sarikaya" <[email-masked]>; "Behcet Sarikaya" 
<[email-masked]>
Cc: "dhc WG" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 06, 2009 4:46 PM
Subject: Re: [dhcwg] [netlmm] Request for review 
ofdraft-xia-netlmm-lma-discovery-01.txt

>> misleading as it tries to show two methods at the same time. But in  the 
>> text it is clarifed. The two, AAA part and DHCP are totally  unrelated, 
>> if you do get LMA address from AAA as in Step 1 you stop  there. 
>> Otherwise you continue with steps 2 & 3.
>
> essentially what it looks like is that you are using the DHCPv6 server  in 
> the same way that you would be using the AAA server.   While a  DHCPv6 
> server could be implemented that functioned in this way, I  don't see what 
> the advantage would be of this over just using an AAA  server.
>
> server, it would seem to be a better use of DHCPv6 to acquire the  address 
> of the AAA server and then contact the AAA server to fulfill  the 
> MN/user's request.   If the problem is something else, can you  explain 
> further?   This is why I am asking about the motivation behind  using 
> DHCPv6 - it's still not clear to me what problem you are trying  to solve 
> here.
>
> what's already specified in draft-ietf-mip6-hiopt-17.txt?  And what's  the 
> status of that draft anyway?  It looks like it's going to expire  soon. 
> Is that still an active proposal?   Who's shepherding it?    The last time 
> it was discussed on the DHC working group mailing list  was April of 2008.
>
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 6 May 2009 18:09:22 -0500

> server is independent from  any AAA facility.

Yes, I know what this draft does, and have some questions about its  
requirement that the DHCP server store information on behalf of the  
relay agent in certain cases.   This seems unnecessarily stateful  
given that the relay agent knows the information and could easily send  
it along every time rather than relying on the DHCPv6 server to store  
it.   But that wasn't my question.   :')

---

From: Frank Xia <[email-masked]>
Date: Wed, 06 May 2009 21:27:17 -0500

Hi Ted

Let me get another shot.

Please read these text from
http://tools.ietf.org/id/draft-ietf-mip6-hiopt-17.txt

" There can be several ways that the DHCP
server knows the requested home network
information.  For instance, as described in
[I-D.ietf-mip6-radius] and [I-D.ietf-dime-mip6-integrated],
a NAS can learn the information via
RADIUS or Diameter, respectively, during
network access authentication, and the
DHCP relay co-located with the NAS can
transfer it to the DHCP server by using the
DHCP option specified in Section 3.2 and
Section 3.3.  Or the home information
may have been configured statically in
the DHCP server by the  administrator.  "

BR
Frank

----- Original Message ----- 
From: "Ted Lemon" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: "Behcet Sarikaya" <[email-masked]>; "Behcet Sarikaya" 
<[email-masked]>; "dhc WG" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 06, 2009 6:09 PM
Subject: Re: [dhcwg] [netlmm] Request for review 
ofdraft-xia-netlmm-lma-discovery-01.txt

> requirement that the DHCP server store information on behalf of the  relay 
> agent in certain cases.   This seems unnecessarily stateful  given that 
> the relay agent knows the information and could easily send  it along 
> every time rather than relying on the DHCPv6 server to store  it.   But 
> that wasn't my question.   :')
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 7 May 2009 08:41:53 -0700 (PDT)

Ted, this draft is now in RFC Editor queue.

Regards,

Behcet

________________________________
From: Frank Xia <[email-masked]>
To: Ted Lemon <[email-masked]>
Cc: Behcet Sarikaya <[email-masked]>; Behcet Sarikaya <[email-masked]>; dhc WG <dhcwg@ietf..org>; [email-masked]
Sent: Wednesday, May 6, 2009 9:27:17 PM
Subject: Re: [dhcwg] [netlmm] Request for review ofdraft-xia-netlmm-lma-discovery-01.txt

Hi Ted

Let me get another shot.

BR
Frank

----- Original Message ----- From: "Ted Lemon" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: "Behcet Sarikaya" <[email-masked]>; "Behcet Sarikaya" <[email-masked]>; "dhc WG" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 06, 2009 6:09 PM
Subject: Re: [dhcwg] [netlmm] Request for review ofdraft-xia-netlmm-lma-discovery-01.txt

> Yes, I know what this draft does, and have some questions about its requirement that the DHCP server store information on behalf of the  relay agent in certain cases..  This seems unnecessarily stateful  given that the relay agent knows the information and could easily send  it along every time rather than relying on the DHCPv6 server to store  it.  But that wasn't my question.  :')
>