Subject: [dhcwg] Relay agent with dhcp server on same subnet

From: "Autuori Gianluigi" <[email-masked]>
Date: Thu, 12 Nov 2009 08:42:38 +0100

Hi,
I have a simple network with one dhcp server (isc dhcp), one managged switch and two clients.

			    ___________
			   |          4|------- Client 1 to sw port 4
DHCPD  Server--------| Switch   6|------- Client 2 to sw port 6
(192.168.1.30)       |___________|
			  (192.168.1.101)

I want to asign ip address according to switch ports whitch clients are connected.
So I set Relay Agent on switch to relaying to DHCPD  Server (192.168.1.30) with Option-82.
Then I configure DHCPD  Server like follow:

class "port4" {
    match (binary-to-ascii(16, 8, ":",option agent.circuit-id)); }

subclass "port4" "b8:6:0:0:1:1:1:4";

class "port6" {
    match (binary-to-ascii(16, 8, ":",option agent.circuit-id)); }

subclass "port6" "b8:6:0:0:1:1:1:6";

subnet 192.168.1.0 netmask 255.255.255.0 {    
    pool {
	allow members of "port4";
	range 192.168.1.4 192.168.1.4;
    }
    pool {
	allow members of "port6";
	range 192.168.1.6 192.168.1.6;
    }
}

Now I test this with only one client connected to the right port and I obtain this traffic:

No.     Time        Source                Destination           Protocol Info
      1 0.000000    0.0.0.0               255.255.255.255       DHCP     DHCP Discover - Transaction ID 0xeaa79f3f
      2 0.005068    192.168.1.101         192.168.1.30          DHCP     DHCP Discover - Transaction ID 0xeaa79f3f
      3 0.005072    192.168.1.30          192.168.1.101         DHCP     DHCP Offer    - Transaction ID 0xeaa79f3f
      4 0.010307    192.168.1.101         192.168.1.4           DHCP     DHCP Offer    - Transaction ID 0xeaa79f3f
      5 0.010796    0.0.0.0               255.255.255.255       DHCP     DHCP Request  - Transaction ID 0xeaa79f3f
      6 0.010819    192.168.1.30          255.255.255.255       DHCP     DHCP NAK      - Transaction ID 0xeaa79f3f
      7 0.015958    192.168.1.101         192.168.1.30          DHCP     DHCP Request  - Transaction ID 0xeaa79f3f
      8 0.031054    192.168.1.30          192.168.1.101         DHCP     DHCP ACK      - Transaction ID 0xeaa79f3f
      9 0.035778    192.168.1.101         192.168.1.4           DHCP     DHCP ACK      - Transaction ID 0xeaa79f3f

as can you see there is a NAK (packet n°6) so the transaction fails.
Can I configure DHCP Server to not send this NAK?

Thanks
Gianluigi

--------------------------------------------------------------------------------
Questo messaggio e-mail e ogni documento ad esso eventualmente allegato puo' avere carattere riservato ed essere tutelato da segreto. Esso,comunque, e'
ad esclusivo utilizzo del destinatario in indirizzo. Qualora non foste il destinatario del messaggio vi preghiamo di volerci avvertire immediatamente per e-mail o telefono e di cancellare il presente messaggio e ogni eventuale allegato dal vostro sistema. E' vietata la duplicazione o l'utilizzo per qualunque fine del messaggio e di ogni allegato, nonche' la loro divulgazione, distribuzione o inoltro a terzi senza l'espressa autorizzazione del mittente. In ragione del mezzo di trasmissione utilizzato, il mittente non assume alcuna responsabilita' sulla segretezza/riservatezza delle informazioni contenute nel messaggio e nei relativi allegati. 

This e-mail and any file transmitted with it may contain material that is confidential, privileged and/or attorney work product for the sole use of the intended recipient. If you are not the intended recipient of this e-mail, please do not read it, notify us immediately by e-mail or by telephone and then delete this message and any file attached from your system. You should not copy or use it for any purpose, disclose the contents of the same to any other person or forward it without express permission.
Considering the means of transmission, we do not undertake any liability with respect to the secrecy and confidentiality of the information contained in this e-mail and its attachments.

---

From: [email-masked]
Date: Thu, 12 Nov 2009 11:37:25 -0200

Hi Gianluigi,

I believe that relay agents are supposed to be used with routed  
networks. In your switch configuration, it seems that your server is  
receiving two requests, one from the relay agent and other from the  
client broadcast. The last one is rejected by dhcp. Have you tried the  
options "allow unknown-clients" or "ignore unknown-clients"? Anyway, I  
think that the right discussion list for this issue can be found int  
the ISC homepage.

Regards,
Caciano Machado
Federal University of Rio Grande do Sul

Citando Autuori Gianluigi <[email-masked]>:

>       1 0.000000    0.0.0.0               255.255.255.255       DHCP  
>      DHCP Discover - Transaction ID 0xeaa79f3f
>       2 0.005068    192.168.1.101         192.168.1.30          DHCP  
>      DHCP Discover - Transaction ID 0xeaa79f3f
> Questo messaggio e-mail e ogni documento ad esso eventualmente   
> allegato puo' avere carattere riservato ed essere tutelato da   
> segreto. Esso,comunque, e'
> ad esclusivo utilizzo del destinatario in indirizzo. Qualora non   
> foste il destinatario del messaggio vi preghiamo di volerci   
> avvertire immediatamente per e-mail o telefono e di cancellare il   
> presente messaggio e ogni eventuale allegato dal vostro sistema. E'   
> vietata la duplicazione o l'utilizzo per qualunque fine del   
> messaggio e di ogni allegato, nonche' la loro divulgazione,   
> distribuzione o inoltro a terzi senza l'espressa autorizzazione del   
> mittente. In ragione del mezzo di trasmissione utilizzato, il   
> mittente non assume alcuna responsabilita' sulla   
> segretezza/riservatezza delle informazioni contenute nel messaggio e  
>  nei relativi allegati.
>
> This e-mail and any file transmitted with it may contain material   
> that is confidential, privileged and/or attorney work product for   
> the sole use of the intended recipient. If you are not the intended   
> recipient of this e-mail, please do not read it, notify us   
> immediately by e-mail or by telephone and then delete this message   
> and any file attached from your system. You should not copy or use   
> it for any purpose, disclose the contents of the same to any other   
> person or forward it without express permission.
> Considering the means of transmission, we do not undertake any   
> liability with respect to the secrecy and confidentiality of the   
> information contained in this e-mail and its attachments.
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

---

From: "David W. Hankins" <[email-masked]>
Date: Tue, 17 Nov 2009 14:56:35 -0800

On Thu, Nov 12, 2009 at 11:37:25AM -0200, [email-masked] wrote:
> unknown-clients" or "ignore unknown-clients"? Anyway, I think that the 
> right discussion list for this issue can be found int the ISC homepage.

Specifically, here:

    https://lists.isc.org/mailman/listinfo/dhcp-users

-- 
David W. Hankins	BIND 10 needs more DHCP voices.
Software Engineer		There just aren't enough in our heads.
Internet Systems Consortium, Inc.		http://bind10.isc.org/

---

From: John Jason Brzozowski <[email-masked]>
Date: Tue, 17 Nov 2009 19:27:20 -0500

I agree with David, this thread would be best served on the ISC DHCP mailing
list.

>     https://lists.isc.org/mailman/listinfo/dhcp-users

=========================================
John Jason Brzozowski
Comcast Cable
e) mailto:[email-masked]
o) 609-377-6594
m) 484-962-0060
=========================================