Subject: [dhcwg] Use of OPTION_VENDOR_OPTS

From: Ole Troan <[email-masked]>
Date: Sun, 17 Jan 2010 11:25:24 +0100

hi,

I'm one of the co-authors of the BBF document WT-192 which deals with CPE requirements for IPv6.

during that work a question of the intended usage of OPTION_VENDOR_OPTS came up.

currently we have the following requirement:

"WAN.IPv6.	21	The device MUST provide up to 4 instances of OPTION_VENDOR_OPTS (17) (RFC 3315) with IANA "ADSL Forum" Enterprise Number as the enterprise-number. Each instance will have one of the 4 sub-options from WAN.DHCPC.7 as the vendor-specific opt-code, with the corresponding value in the vendor-specific option-data. If the value of a parameter is empty for the device, then the sub-option MUST be omitted."

alternative interpretation would be that each OPTION_VENDOR_OPTS option should have a separate enterprise-id. then the four ADSL forum sub-options should be encoded as TLVs in a single OPTION_VENDOR_OPTS.

what is the dhcwg's view on this? 4 OPTIONS_VENDOR_OPTS or 1?

Best regards,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Sun, 17 Jan 2010 10:18:57 -0700

> what is the dhcwg's view on this? 4 OPTIONS_VENDOR_OPTS or 1?

I don't see what it adds to use four vendor options instead of one.   Is there some reason why you'd want to do this?  Obviously it wastes a lot of space in the packet, and you haven't said anything that would suggest to me that this solution would be preferable.   Furthermore, from a processing perspective, it goes contrary to how these options normally work.   This means it would require special handling from the DHCP server and DHCP client, which is undesirable in general, but arguably impossible in a vendor-specific option.

---

From: Ole Troan <[email-masked]>
Date: Mon, 18 Jan 2010 20:15:14 +0100

Ted,

> I don't see what it adds to use four vendor options instead of one.   Is there some reason why you'd want to do this?  Obviously it wastes a lot of space in the packet, and you haven't said anythin…

thanks Ted, that is my reading of the RFC3315 description too. one vendor option per enterprise number with a set of TLVs/sub-options in each. I just wanted that confirmed, as there are some disagreement on this in the BBF.

cheers,
Ole

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 18 Jan 2010 20:15:57 -0600

FYI - The main user of this vendor option today is Cablelabs for DOCSIS
3.0. They place MANY vendor options inside a single vendor option - that
was always the intent.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ole Troan
Sent: Monday, January 18, 2010 2:15 PM
To: Ted Lemon
Cc: [email-masked]
Subject: Re: [dhcwg] Use of OPTION_VENDOR_OPTS

Ted,

> I don't see what it adds to use four vendor options instead of one.
Is there some reason why you'd want to do this?  Obviously it wastes a
lot of space in the packet, and you haven't said anything that would
suggest to me that this solution would be preferable.   Furthermore,
from a processing perspective, it goes contrary to how these options
normally work.   This means it would require special handling from the
DHCP server and DHCP client, which is undesirable in general, but
arguably impossible in a vendor-specific option.

thanks Ted, that is my reading of the RFC3315 description too. one
vendor option per enterprise number with a set of TLVs/sub-options in
each. I just wanted that confirmed, as there are some disagreement on
this in the BBF.

cheers,
Ole
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Mon, 18 Jan 2010 23:18:39 -0500

If the current text in RFC 3315 isn't clear that:

* there should be no more than one instance of OPTION_VENDOR_CLASS  
with a specific vendor's Enterprise Number
* there should be no more than one instance of OPTION_VENDOR_OPTS with  
a specific vendor's Enterprise Number
* each instance of OPTION_VENDOR_CLASS and OPTION_VENDOR_OPTS can  
carry multiple sub-options

perhaps we should submit an errata.

- Ralph

---

From: Ole Troan <[email-masked]>
Date: Thu, 21 Jan 2010 09:40:00 +0100

thank you very much for the clarification. I am submitting comments to the BBF document to get that issue fixed today.

with regards to an errata, I found the text clear, but apparently not all do.

Best regards,
Ole

On Jan 19, 2010, at 5:18 , Ralph Droms wrote:

> * there should be no more than one instance of OPTION_VENDOR_CLASS with a specific vendor's Enterprise Number
> * there should be no more than one instance of OPTION_VENDOR_OPTS with a specific vendor's Enterprise Number
> * each instance of OPTION_VENDOR_CLASS and OPTION_VENDOR_OPTS can carry multiple sub-options
>