Subject: Re: [dhcwg] DHCPv6 Server Option in RA

From: Xu Xiaohu <[email-masked]>
Date: Wed, 03 Feb 2010 11:28:31 +0800

Hi all,

Is there any objection to this Stateless DHCPv6 Server Option in RA?

Xiaohu

> -----邮件原件-----
> 发件人: Xu Xiaohu [mailto:[email-masked]]
> 发送时间: 2010年1月29日 9:47
> 收件人: [email-masked]'
> 主题: FWD: DHCPv6 Server Option in RA
> 
> 
> 
> Hi all,
> 
> Since the following discussion is related to DHCPv6, especially stateless
> DHCPv6, I forward it here.
> 
> Any comment is appreciated!
> 
> Best wishes,
> Xiaohu
> 
> > -----邮件原件-----
> > 发件人: Xu Xiaohu [mailto:[email-masked]]
> > 发送时间: 2010年1月28日 12:15
> > 收件人: 'IETF IPv6 Mailing List'
> > 主题: DHCPv6 Server Option in RA
> >
> > Hi all,
> >
> > In a scenario where hosts have obtained IPv6 addresses through some
other
> > mechanism, such as stateless address auto-configuration or manual
> > configuration while other configuration parameters (e.g., recursive DNS
> > servers)are learnt via stateless DHCPv6 [RFC 3736], would it be better
for
> these
> > hosts to obtain the DHCPv6 server addresses via a new RA option in
advance?
> > Thus these hosts could directly send unicast DHCP Information-request
> messages
> > to the stateless DHCP server without the need of DHCP relay agent
between
> the
> > client and server. As a result, delays due to the relaying of messages
by
> relay
> > agents, as well as overhead and duplicate responses by servers due to
the
> > delivery of client messages to multiple servers can be avoided.
> >
> > Meanwhile, I noticed there is a statement about unicast DHCP request in
the
> > DHCPv6 specification [RFC 3315] as follows:
> >    "When the server receives a Request message via unicast from a client
> >    to which the server has not sent a unicast option, the server
> >    discards the Request message and responds with a Reply message
> >    containing a Status Code option with the value UseMulticast, a Server
> >    Identifier option containing the server's DUID, the Client Identifier
> >    option from the client message, and no other options."
> >
> > Unless the unicast option is not available for all clients, I believe it
would
> > conflict with the basic principle of stateless DHCP that DHCP server
needs
> not
> > to maintain per host state.
> >
> > There is another statement about the unicast DHCP request in RFC 3315 as
> > follows:
> >       " ...Use of unicast may avoid delays due to the relaying of
messages
> by
> >       relay agents, as well as avoid overhead and duplicate responses by
> >       servers due to the delivery of client messages to multiple
> >       servers.  Requiring the client to relay all DHCP messages through
> >       a relay agent enables the inclusion of relay agent options in all
> >       messages sent by the client.  The server should enable the use of
> >       unicast only when relay agent options will not be used. "
> >
> > Judging from the above statement, especially the last sentence, it seems
that
> > the relay agent is preferred. Then what's the reason for that
preference?
> To
> > prevent flood attack on the DHCP server? If the answer is yes, then as
for
> > stateless DHCP, it seems that such attacks are not much serious since
the
> > stateless DHCP server doesn't need to maintain any dynamic state for
> individual
> > clients. At least, not worse than flood attacks on DNS servers.
> >
> > Comments?
> >
> > Xiaohu

---

From: "Wes Beebee (wbeebee)" <[email-masked]>
Date: Wed, 3 Feb 2010 08:29:10 -0600

What happens if there is a relay agent on the link and the DHCPv6 Stateless Server Option is provided in the RA as well as O=1?

Does the DHCPv6 Stateless Server Option take precedence over the relay agent?

Wes Beebee
Software Engineer
Product Development
[email-masked]

United States
Cisco.com - http://www.cisco.com
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Xu Xiaohu
Sent: Tuesday, February 02, 2010 10:29 PM
To: [email-masked]
Subject: Re: [dhcwg] DHCPv6 Server Option in RA

Hi all,

Xiaohu

> Since the following discussion is related to DHCPv6, especially 
> stateless DHCPv6, I forward it here.
> 
other
> > configuration while other configuration parameters (e.g., recursive 
> > DNS servers)are learnt via stateless DHCPv6 [RFC 3736], would it be 
> > better
for
advance?
between
by
the
the
would
needs
messages
that
preference?
for
the
> > clients. At least, not worse than flood attacks on DNS servers.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Xu Xiaohu <[email-masked]>
Date: Thu, 04 Feb 2010 11:06:57 +0800

> -----邮件原件-----
> 发件人: Wes Beebee (wbeebee) [mailto:[email-masked]]
> 发送时间: 2010年2月3日 22:29
> 收件人: Xu Xiaohu; [email-masked]
> 主题: RE: [dhcwg] DHCPv6 Server Option in RA
> 
> What happens if there is a relay agent on the link and the DHCPv6
Stateless
> Server Option is provided in the RA as well as O=1?
> 

I think this is the client's internal policy. Am I right?  Or do you believe
we should specify it definitely in a specification?

Xiaohu

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Xu