Subject: Re: [dhcwg] [Softwires] FW: New Version Notification for draft-guo-softwire-6rd-ipv6-config-00

From: Xu Xiaohu <[email-masked]>
Date: Tue, 02 Mar 2010 10:40:41 +0800

> -----邮件原件-----
> 发件人: Xu Xiaohu [mailto:[email-masked]]
> 发送时间: 2010年3月2日 10:14
> 收件人: 'WashamFan'; 'Dayong Guo'
> 抄送: [email-masked]'; 'DHC WG'
> 主题: re: [Softwires] FW: New Version Notification for
> draft-guo-softwire-6rd-ipv6-config-00
> 
> 
> 
> > -----邮件原件-----
> > 发件人: [email-masked] [mailto:[email-masked]]
代
> 表
> > WashamFan
> > 发送时间: 2010年3月2日 9:58
> > 收件人: Dayong Guo
> > 抄送: [email-masked]; 'DHC WG'
> > 主题: Re: [Softwires] FW: New Version Notification for
> > draft-guo-softwire-6rd-ipv6-config-00
> >
> > Hi,
> >
> > Do you assume the SP would provide DHCPv6 server and DNSv6
> > server for the hosts behind 6rd CEs?
> 
> Not accurate. Taken the DHCPv6 option usage as an example, the SP provides
the
> DHCPv6 server to the 6rd CPE which would act as a DHCPv6 relay agent, the
IPv6
> hosts behind the 6rd CPE in turn obtain the configuration information
(e.g.,
> DNS, NTP etc) from the DHCPv6 server.
> 
> > Since the SP network is IPv4-only, IMO, DHCPv6 server and
> > DNSv6 server would be deployed in 6rd CE LAN side. In that
> > case, DHCPv4 options defined in this draft would be not
> > justified.
> 
> If a given DHCPv6 server is deployed in a customer site, its IPv6 address
should
> be a 6rd IPv6 address. In this case, the DHCP relay agent will relay the
> information-request message to the 6rd CPE of that site, rather than to
the
> 6rd border relay.

The "customer" site mentioned above is a 6rd site which is actually deployed
by the SP and is used for holding IPv6 servers (e.g., DHCPv6 servers, NTP
servers and DNS servers etc). 

For the small-sized sites, do you believe they should deploy their own
DHCPv6 servers?

Xiaohu

> > I thought the hosts residing on the 6rd CE LAN side are dual stack
> > hosts. If there is any IPv6-only host, a DNS proxy might be
> > deployed (in the 6rd CE).
> 
> Yes, if DNS is the only configuration information which the hosts need,
the
> DNS proxy mechanism can be used. However, if the hosts need other
configuration
> information besides DNS, they should use the stateless DHCPv6.
> 
> Xiaohu
> 
> > Any comments?
> >
> > washam
> >
> > ----- Original Message -----
> > From: Dayong Guo <[email-masked]>
> > Date: Tuesday, March 2, 2010 9:29 am
> > Subject: [Softwires] FW: New Version Notification for
> > draft-guo-softwire-6rd-ipv6-config-00
> > To: [email-masked]
> > Cc: 'DHC WG' <[email-masked]>
> >
> >
> > >
> > >
> > >
> > >  Dayong Guo
> > >
> > >  Huawei Technologies Co., Ltd.
> > >  Email：[email-masked]
> > >  http://www.huawei.com
> > >
> > >  Hi, all
> > >       A new draft about IPv6 auto-configuration in 6rd scenario was
> > >  submitted. Any comments are welcome.
> > >
> > >  Xiaohu Xu   &   Dayong Guo
> > >
> > >  -----Original Message-----
> > >  From: IETF I-D Submission Tool [mailto:[email-masked]]
> > >  Sent: Monday, March 01, 2010 9:02 PM
> > >  To: [email-masked]
> > >  Cc: [email-masked]
> > >  Subject: New Version Notification for
> > draft-guo-softwire-6rd-ipv6-config-00
> > >
> > >
> > >  A new version of I-D, draft-guo-softwire-6rd-ipv6-config-00.txt has
been
> > >  successfuly submitted by Xiaohu Xu and posted to the IETF repository.
> > >
> > >  Filename:         draft-guo-softwire-6rd-ipv6-config
> > >  Revision:         00
> > >  Title:                 IPv6 Host Configuration in 6rd Deployment
> > >  Creation_date:         2010-03-01
> > >  WG ID:                 Independent Submission
> > >  Number_of_pages: 7
> > >
> > >  Abstract:
> > >  This document proposes two new DHCPv4 options which allow IPv6 hosts
> > > to
> > >  obtain configuration information (e.g., DNS servers). The DHCPv6
Server
> > >  Option in DHCPv4 provides the IPv6 address of DHCPv6 server  to the
> > > 6rd CPE.
> > >  In result the 6rd CPE can relay DHCPv6 requests to
> > >   DHCPv6 servers. As an alternative, the IPv6 DNS Server Option is
> > > used  in
> > >  the scenario where hosts only need the information of IPv6 DNS
servers.
> > >
> > >
> > >
> > >
> > >  The IETF Secretariat.
> > >
> > >
> > >  _______________________________________________
> > >  Softwires mailing list
> > >  [email-masked]
> > >  https://www.ietf.org/mailman/listinfo/softwires
> > >
> > _______________________________________________
> > Softwires mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/softwires

---

From: WashamFan <[email-masked]>
Date: Tue, 02 Mar 2010 11:00:03 +0800

Hi,

>  For the small-sized sites, do you believe they should deploy their own

My concern is, if DHCPv6 is deployed within 6rd CE LANs, extensions
to DHCPv4 defined in the draft would not apply. If DHCPv6 server
deployed in 6rd CE WAN, that is where your draft fits in, I guess.

But how come DHCPv6 server is deployed in 6rd CE WAN which
is IPv4-only SP network?

Thanks,
washam

---

From: Xu Xiaohu <[email-masked]>
Date: Tue, 02 Mar 2010 11:10:25 +0800

> -----邮件原件-----
> 发件人: WashamFan [mailto:[email-masked]]
> 发送时间: 2010年3月2日 11:00
> 收件人: Xu Xiaohu
> 抄送: 'Dayong Guo'; [email-masked]; 'DHC WG'

The IPv6 servers (e.g., DHCPv6 servers) could be deployed in a 6rd ”
customer” site which is actually owned by the SP.

Xiaohu