Subject: Re: [dhcwg] [3gv6] about Prefix delegation in 3GPP EPC networks

From: [email-masked]
Date: Fri, 9 Apr 2010 00:44:12 +0800

Hi, Frank,
 
I listed two possible use cases in S2-100449 I submitted to 3GPP SA2#77. S2-100449 is also attached in this mail.
One of the use cases is like what you said. The other one is machine to machine communication gateway. This gateway has to assign IPv6 addresses to the sensors, knobs, or other devices within its control area. The uplink connection of this gateway can be LTE or 2/3G GPRS.
 
Anyway, even we use a specific APN to support shorter prefix, this APN has to be able to assign prefix with variable length to different UEs,  because the UEs attached to this APN may cover different number of subnets, thus need different length prefix. 
 
Best Regards,

--------------------------------------------------------------------------------

Zhenqiang Li
13911635816
Department of Network Technology
China Mobile Research Institute
2010-04-09

--------------------------------------------------------------------------------

发件人： Frank Brockners (fbrockne)
发送时间： 2010-04-02 00:16:43
收件人： [email-masked]; [email-masked]
抄送： [email-masked]; [email-masked]; [email-masked]; Dhananjay Patki (dhpatki)
主题： RE: RE: [3gv6] about Prefix delegation in 3GPP EPC networks
 
Hi Zhenqiang,

> 
> Using different APN for different prefix length is not practical.
> Usually, We do not set too many APNs in the field network. It is not
> convenient for the UE to change one APN to another if it wants a
> different length prefix. Usually, differnt APN is set for different
> service.  UEs connected to the same APN may want to get different
> length prefixes due to differnt networks behind them.

...FB: Could you detail the deployment scenario a bit more? From what I've heard so far, the expectation is that subscriptions which will use shorter/multiple prefixes will be different from the typical service subscription of a mobile-phone user, e.g. those subscriptions would be broadband-home-router type devices using LTE to connect to the network. Hence the approach of using different APNs. You obviously have a different deployment model in mind. 
 
Appreciate your thoughts.
 
Thanks, Frank
 
> 
> 
> 
> -----------------------------------------------------------------------
> ---------
> 
> Zhenqiang Li
> 13911635816
> Department of Network Technology
> China Mobile Research Institute
> 2010-04-01
> 
> -----------------------------------------------------------------------
> ---------
> 
> 发件人： Frank Brockners (fbrockne)
> 发送时间： 2010-03-30 15:50:07
> 收件人： [email-masked]; [email-masked]
> 抄送： [email-masked]; [email-masked]; [email-masked]; Dhananjay
> Patki (dhpatki)
> 主题： RE: [3gv6] about Prefix delegation in 3GPP EPC networks
> 
> Hi Zhenqiang Li,
> 
> please see some thoughts inline.. (Suresh will probably add more)
> 
>  > -----Original Message-----
>  > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
>  > [email-masked]
>  > Subject: [3gv6] about Prefix delegation in 3GPP EPC networks
>  >
>  > Dear Suresh,
>  >
>  > Nice meeting you at IETF 77.
>  >
>  > First of all, I agree with you that it is good for a UE to use a
>  > shorter prefix to meet the situation, rather than using multiple /64
>  > prefixes.
> 
> ...FB: there's been several discussions at this past IETF on this
> particular topic - and the approach which seems to have wide support is
> that for Release 10, one would support a model where one PDN connection
> would continue to be represented by a *single* prefix. This prefix
> could
> be shorter that /64. This means that we can still hand out multiple
> prefixes to the UE, but it would always be possible to aggregate all of
> them into a single prefix. We'd continue using SLAAC for assigning the
> /64 for the UE (or better PDN-Connection-link) and would hand out the
> remainder of the "shorter prefix" using DHCP PD. This will keep changes
> to the current architecture to a minimum (incl. PCC will need to deal
> with only a single prefix in its rules). More complex alternatives
> would
> be explored in future releases (i.e. Release 11 and onwards).
> 
> I'm working on updating the contributions S2-101176, S2-101177,
> S2-101178 that were submitted "for information" to the last 3GPP SA2
> meeting to reflect these changes (which are only small deltas to the
> current versions, so hope to have them available for discussion in the
> next few days) (You can find the submitted version at
> http://www.3gpp.org/ftp/tsg_sa/WG2_Arch/TSGS2_78_San_Francisco/Docs/)
> 
>  >
>  > Some additional comments about your draft:
>  > 1. Where to store the prefix length that you reserved for each UE?
>  > 2. How to validate the request from UE to avoid address abusing?
> 
> ...FB: The expected approach is that shorter prefixes would be handled
> as a capability of the APN. This way you also won't have any issues
> with
> "abuse" - each UE (for a particular APN supporting shorter prefixes)
> could use DHCPv6 PD to request portions of the prefix.
> 
> 
>  > 3. The proposed method in your draft seems address wasting, because
> you
>  > reserve /x (x   < 64) prefix for each UE. It is better to store the
>  > minimum length that a UE can apply, and assign the proper lengh to UE
>  > based on the available adrress pool, the minimum length the UE can
>  > apply, and the length the UE actually requests.
> 
> ...FB: If we do things on a per APN basis (as mentioned above), one
> would expect that only those UEs who need shorter prefixes would use
> the
> particular APN, so the amount of "wasted" addresses would be relatively
> small. That said, the approach would just be for Release 10 (we just
> have two more meetings to get this off the ground) - more optimal
> approaches could be studied in future releases.
> 
> Regards, Frank
> 
>  > 4. Are there any other alternatives besides DHCPv6-PD? I listed some
>  > potential solutions in a 3GPP document. What is your opinion to them?
>  >
>  > Best Regards,
>  > Zhenqiang Li
>  > 13911635816
>  > Department of Network Technology
>  > China Mobile Research Institute
>  > 2010-03-26
>  > _______________________________________________
>  > 3gv6 mailing list
>  > [email-masked]
>  > https://www.ietf.org/mailman/listinfo/3gv6

---

From: <[email-masked]>
Date: Fri, 9 Apr 2010 14:56:01 +0200

Dear all,

Please find some comments on this document.
In general, I think such variant prefix allocation is required for future services and it would be efficient from an operator's perspective to provide some flexibility in architecture design so that each operator may set up its own addressing policy, in confromance with IETF and 3GPP requirements. 

Best Regards
David  

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] 
> De la part de [email-masked]
> Envoyé : jeudi 8 avril 2010 18:44
> À : Frank Brockners; suresh.krishnan@
> Cc : [email-masked]; [email-masked]; [email-masked]; 
> Dhananjay Patki (dhpatki)
> Objet : Re: [dhcwg] [3gv6] about Prefix delegation in 3GPP 
> EPC networks
> 
> Hi, Frank,
>  
> I listed two possible use cases in S2-100449 I submitted to 
> 3GPP SA2#77. S2-100449 is also attached in this mail.
> One of the use cases is like what you said. The other one is 
> machine to machine communication gateway. This gateway has to 
> assign IPv6 addresses to the sensors, knobs, or other devices 
> within its control area. The uplink connection of this 
> gateway can be LTE or 2/3G GPRS.
>  
> Anyway, even we use a specific APN to support shorter prefix, 
> this APN has to be able to assign prefix with variable length 
> to different UEs,  because the UEs attached to this APN may 
> cover different number of subnets, thus need different length prefix. 
>  
> Best Regards,
>  
> 
> ...FB: Could you detail the deployment scenario a bit more? 
> From what I've heard so far, the expectation is that 
> subscriptions which will use shorter/multiple prefixes will 
> be different from the typical service subscription of a 
> mobile-phone user, e.g. those subscriptions would be 
> broadband-home-router type devices using LTE to connect to 
> the network. Hence the approach of using different APNs. You 
> obviously have a different deployment model in mind. 
>  
> >  > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of  > [email-masked]  > Subject: [3gv6] about 
> > Prefix delegation in 3GPP EPC networks  >  > Dear Suresh,  
> >  > Nice 
> > meeting you at IETF 77.
> >  >
> >  > First of all, I agree with you that it is good for a UE 
> to use a  > 
> > particular topic - and the approach which seems to have 
> wide support 
> > is that for Release 10, one would support a model where one PDN 
> > connection would continue to be represented by a *single* 
> prefix. This 
> > prefix could be shorter that /64. This means that we can still hand 
> > out multiple prefixes to the UE, but it would always be possible to 
> > aggregate all of them into a single prefix. We'd continue 
> using SLAAC 
> > for assigning the
> > remainder of the "shorter prefix" using DHCP PD. This will keep 
> > changes to the current architecture to a minimum (incl. PCC 
> will need 
> > to deal with only a single prefix in its rules). More complex 
> > alternatives would be explored in future releases (i.e. 
> Release 11 and 
> > onwards).
> > 
> > with "abuse" - each UE (for a particular APN supporting shorter 
> > prefixes) could use DHCPv6 PD to request portions of the prefix.
> > 
> > 
> >  > minimum length that a UE can apply, and assign the 
> proper lengh to 
> > UE  > based on the available adrress pool, the minimum 
> length the UE 
> > can  > apply, and the length the UE actually requests.
> > 
> > the particular APN, so the amount of "wasted" addresses would be 
> > relatively small. That said, the approach would just be for 
> Release 10 
> > (we just have two more meetings to get this off the ground) - more 
> > optimal approaches could be studied in future releases.
> > 
> > Regards, Frank
> > 
> >  > 4. Are there any other alternatives besides DHCPv6-PD? I listed 
> > some  > potential solutions in a 3GPP document. What is 
> your opinion to them?
> >  >
> >  > Best Regards,
> >  > Zhenqiang Li
> >  > 13911635816
*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************