Subject: [dhcwg] DHCPv6 relay agent related question

From: "DEIVANAYAGAM, MANICKAVASAGAM (MANICKAVASAGAM)" <[email-masked]>
Date: Fri, 9 Apr 2010 11:25:13 +0530

There are few cases where DHCPv6 relay agent will alter the reply message address details.
The alteration could be removal of addresses present in the reply message.

Given below few scenarios that will result in removal of addresses in reply message.
     - Relay might have administratively configured to remove certain addresses based on client DUID matching
     - Relay will also do the snooping in that case any scaling limit set in snooping could result in removal of addresses
(both scenarios are not standardized one)

Client and server will not be informed about this address removal.
Can relay agent send a new message relay-release to server so that server will be notified?
So that server will maintain the up to date lease information. Server marinating up to date lease information
is more relevant in case of delegated router adding routing information for delegated prefixes into the provider edge router.

Thanks and Regards
Manickavasagam D

.

---

From: Andre Kostur <[email-masked]>
Date: Fri, 9 Apr 2010 08:55:58 -0700

Inline:

> The alteration could be removal of addresses present in the reply message.

There are?  What's the use case of these, and why isn't this being done on the DHCP Server instead of the relay?  Plus modifying a client packet in the relay would break authentication.

--
Andre Kostur                      P: 604-678-2864
Senior Product Design Engineer    F: 604-678-2864
[email-masked]             SIP: [email-masked]
http://www.incognito.com

http://www.incognito.com/uc

---

From: Ted Lemon <[email-masked]>
Date: Fri, 9 Apr 2010 13:43:18 -0400

> There are few cases where DHCPv6 relay agent will alter the reply message address details.

This doesn't make any sense.   Can you elaborate?

---

From: "DEIVANAYAGAM, MANICKAVASAGAM (MANICKAVASAGAM)" <[email-masked]>
Date: Sun, 11 Apr 2010 19:53:59 +0530

In DHCPv6 prefix delegation case edge router acting as a relay agent need to get the prefix information either through snooping or other out-of-band communication.
If the relay could not snoop the prefix due to scaling limit (number of snooped entries to be present in the software/hardware) will result in no traffic forwarded to that prefix.
In this scenario relay could remove the prefix present in the reply message. So that client will not get the prefix.

This is not a standardized behavior and it will break authentication too. If it makes no sense then I agree no need of further discussion.
Thanks to Andre Kostur and Ted Lemon for the feedback.

Thanks and Regards
Manickavasagam D

________________________________
From: Ted Lemon [mailto:[email-masked]]
Sent: Friday, April 09, 2010 11:13 PM
To: DEIVANAYAGAM, MANICKAVASAGAM (MANICKAVASAGAM)
Cc: [email-masked]
Subject: Re: [dhcwg] DHCPv6 relay agent related question