Subject: [dhcwg] DHC WG review of draft-ietf-geopriv-dhcp-lbyr-uri-option requested

From: "James M. Polk" <[email-masked]>
Date: Tue, 18 May 2010 22:14:13 -0500

DHC

In Geopriv - we're almost done with an ID that requests a new DHCP 
Option number. This one is providing a geolocation URI to a client. 
Below is the tools URL to the doc.

http://tools.ietf.org/wg/geopriv/draft-ietf-geopriv-dhcp-lbyr-uri-option/

I'd like to ask for a DHC review of this ID before it progresses 
further within Geopriv.

I know I can't please everyone. For example, the -05 version received 
comments that the Intro was too long. Then the -07 version was said 
to not explain the situation enough within the Intro.  I'd like to 
have a well written doc, but from this WG I'm most concerned about 
what you think of the technical aspects of the ID, much more so then 
the formatting (though I'll take those as well).

There is one unresolved "minor" issue in the issue tracker with this 
ID, and I'm not sure how to respond to it (based on past reactions by 
the DHC WG to the idea of sub-options). I'd like to receive some 
guidance on this as well.
http://tools.ietf.org/wg/geopriv/trac/query?status=new&status=assigned&status=reopened&component=dhcp-lbyr-uri-option

Thanks in advance

James

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 19 May 2010 12:24:52 +0800

I'll explain what I meant by that issue.

 - A version tag is redundant if you are using sub-options.  If you need to create version 2 of the format, you take a new sub-option tag (or tags).

 - Reserved bits are equally redundant with sub-options.  If you need to add some data, you grab another sub-option tag.

I believe that there are other reasons not to do this as well, but I'll let others comment on that.

I hope that this is clearer.

--Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of James M. Polk
> Sent: Wednesday, 19 May 2010 1:14 PM
> To: [email-masked]
> Subject: [dhcwg] DHC WG review of draft-ietf-geopriv-dhcp-lbyr-uri-
> option requested
> 
> DHC
> 
> http://tools.ietf.org/wg/geopriv/trac/query?status=new&status=assigned&
> status=reopened&component=dhcp-lbyr-uri-option
> 
> Thanks in advance
> 
> James
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg