Subject: [dhcwg] Multiple DHCP leases for the same MAC address.

From: GAURAV HALWASIA <[email-masked]>
Date: Sun, 20 Jun 2010 17:44:01 +0530 (IST)

Hi Experts,

I came across a requirement which is talking about the "Multiple DHCP leases for the same MAC address". Not much was mentioned apart from this. I was just querious to understand more about it and need to understand about the possible use cases which might need this.

Any insights/inputs will be highly appreciated.

Thanks & Best Regards,
Gaurav

---

From: [email-masked]
Date: Sun, 20 Jun 2010 16:28:44 +0200 (CEST)

> I came across a requirement which is talking about the "Multiple DHCP leases for the same MAC address". Not much was mentioned apart from this. I was just querious to understand more about it and n…

DHCP clients can be identified by hardware (MAC) address or client
identifier.

If the IP address is available and hardware address/client identifer
doesn't change, a DHCP client is supposed to get the same IP address
every time it asks - thus you wouldn't normally get multiple DHCP
leases for the same MAC address.

What sometimes happens is that the client identifier changes, for
instance due to booting several different operating systems on the
same hardware. In such cases you could definitely get multiple DHCP
leases for the same MAC address.

A fairly common request on the dhcp-users mailing list (ISC DHCP)
is the ability to force the use of MAC address only as the way to
identify clients (and thus preventing multiple leases in the case of
several different client identifiers for the same MAC address).

Steinar Haug, Nethelp consulting, [email-masked]

---

From: "Woundy, Richard" <[email-masked]>
Date: Sun, 20 Jun 2010 20:09:35 -0400

It could be the case that the MAC address has a valid lease on its old IP subnet and another valid lease on its new IP subnet... And it might make sense to retain the old lease until expiration in case the client moves back to its old IP subnet...

-----Original Message-----
From: [email-masked] on behalf of [email-masked]
Sent: Sun 6/20/2010 10:28 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [dhcwg] Multiple DHCP leases for the same MAC address.

Steinar Haug, Nethelp consulting, [email-masked]
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: GAURAV HALWASIA <[email-masked]>
Date: Mon, 21 Jun 2010 22:47:04 +0530 (IST)

Thanks Steinar/Richard for your inputs in this.

Regards,
Gaurav

________________________________
From: "Woundy, Richard" <[email-masked]>
To: [email-masked]; [email-masked]
Cc: [email-masked]
Sent: Mon, 21 June, 2010 5:39:35 AM
Subject: RE: [dhcwg] Multiple DHCP leases for the same MAC address.