Subject: Re: [dhcwg] draft-xu-ipv6-ra-dhcp-server-option-00//re: IETF 77 minutes published.

From: "David W. Hankins" <[email-masked]>
Date: Tue, 22 Jun 2010 16:28:54 -0700

On Tue, May 18, 2010 at 09:30:18AM +0800, Xu Xiaohu wrote:
> Yes, DHCP servers and relays can receive and process multicast packets
> destined to All_DHCP_Relay_Agents_and_Servers address. However, how could
> the switch know which ports DHCP servers and relays are connected to without
> the manual configuration as I mentioned above?

Would you describe this as specifically a DHCPv6 problem, or as
generally an IPv6 link-local multicast problem/need for optimization?

This may be a better discussion for 6man, because I don't see why the
same problem doesn't exist for any other service using link-local
multicast.

-- 
David W. Hankins	BIND 10 needs more DHCP voices.
Software Engineer		There just aren't enough in our heads.
Internet Systems Consortium, Inc.		http://bind10.isc.org/

---

From: Xu Xiaohu <[email-masked]>
Date: Wed, 23 Jun 2010 08:54:49 +0800

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 David
W.
> Hankins
> 发送时间: 2010年6月23日 7:29
> 收件人: DHC WG
> 主题: Re: [dhcwg] draft-xu-ipv6-ra-dhcp-server-option-00//re: IETF
77minutes
> published.

No, this is not a DHCPv6 specific problem. My thought is: if the stateless
DHCPv6 uses unicast rather than multicast, the above problem disappears for
DHCPv6.

Best wishes,
Xiaohu