Subject: Re: [dhcwg] [Ietf-krb-wg] WG LastCall: draft-sakane-dhc-dhcpv6-kdc-option-08

From: Shoichi Sakane <[email-masked]>
Date: Mon, 06 Sep 2010 12:23:45 +0900

Hi Ted,

On 09/02/10 23:47, Ted Lemon wrote:
>> On Sep 2, 2010, at 4:05 AM, Shoichi Sakane wrote:
>>> On 09/02/10 12:06, Ted Lemon wrote:
>>> And in the long run it's harmful, since if we add IPv4 options
>>> to the DHCPv6 protocol now, we are stuck with them forever.
>> Well, could you explain bit precisely why it's harmful.  I would
>> like to convince myself.
>
> More complexity in the protocol. More choices as to where a
> particular piece of configuration information comes from.
> More potential for ambiguity. More to get wrong, basically.

The first and the third are about a documenting issue.
In terms of the operator and the implementation of the server,
the second one is enough for me to understand the reason.

In terms of the client implementation and the transition phase,
if DHCPv6 protocol was able to provide configuration about IPv4 address,
a client would not need to have the DHCPv4 protocol and the parser.
It could save the resouce of a client.  However, in the long run,
I agree with you.  The waste parser routine is harmful.

Thanks, I am convinced.

Shoichi Sakane

P.S.
I apologize that I accidentally removed the dhcwg ML address.
Discussion was kept in the krb-wg ML.  Please find them if interested.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 10 Sep 2010 16:03:48 -0400

The new draft looks fine.   I assume you are only sending on IP address for each KDC because you don't think it's useful to send more than one, not because you feel constrained by the DHCP protocol to only send one.