Subject: [dhcwg] Call for adoption: draft-lemon-dhcpv6-relay-supplied-options

From: Ted Lemon <[email-masked]>
Date: Tue, 14 Sep 2010 11:53:04 -0400

Back in March I published a draft describing a mechanism whereby the relay agent can propose options for the DHCP server to supply to the client:

http://tools.ietf.org/html/draft-lemon-dhcpv6-relay-supplied-options-00

This was motivated by a document in the RFC Editor queue that defined a special mechanism to do this for one particular option; my motivation in proposing the draft was to provide a general mechanism.

I hadn't heard back from the author or shepherd of the document that originally motivated this draft, but now there's a proposal in hokey that does pretty much the same thing, to a different end:

http://tools.ietf.org/html/draft-ietf-hokey-ldn-discovery-03

That being the case, this has become a hot issue again.   When I presented this previously, there seemed to be rough consensus that it was a good idea, but that was a room consensus, so I'd like to take it to the list.

If there's debate about this, please debate it now.   If not, please let me know if you favor adopting this as a working group item, or let me know if you oppose adopting it as a working group item.   Assuming there isn't protracted debate, we'll call the decision on Monday.

---

From: Qin Wu <[email-masked]>
Date: Wed, 15 Sep 2010 08:59:50 +0800

Hi,
I think it is a good idea to specify such generic mechanism as a wheel for many different usages, e.g., MIP bootstrapping, inter-authenticator handover, etc.
When we started draft-ietf-hokey-ldn-discovery, this wheel is not ready and we thought the same idea to invent relay-supplied-options in the initial version
Therefore I favor this draft and would like to support adopting this work.

Regards!
-Qin
----- Original Message ----- 
From: "Ted Lemon" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, September 14, 2010 11:53 PM
Subject: [dhcwg] Call for adoption: draft-lemon-dhcpv6-relay-supplied-options

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 14 Sep 2010 22:19:15 -0400

> If there's debate about this, please debate it now.   If not, please let me know if you favor adopting this as a working group item, or let me know if you oppose adopting it as a working group item…

Oops.   I'd forgotten that we'd already done this step--because the draft went into hibernation due to the lack of feedback from the authors of the hiopt draft, I never came out with a working group document version of the document.   But since we already have agreement to adopt it, there's no need for a second consensus call.

So I'm just going to issue it as a -00 document and add Qin Wu as an editor so that we have a proponent who's invested in forward progress on the document.   Sorry for the confusion.   No need to respond to the call for adoption.   :'}