Subject: [dhcwg] draft-cao-dhc-anqp-option-00

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 29 Jul 2012 14:33:40 +0000

Seems to me the v4 & v6 options can be simplied to remove length_2 as the option length can just be 1 + ((# of addresses) * (address size, ie 4 or 16)).

Or is the intent that if more types are defined, that the data might be: type-1, length-1-2, address list for type[, type-2, length-2-2, address list for type, [...]]?

We should also explore whether type field is needed; why wouldn't a new set of options be defined for a future type? This document is titled ANQP so what other types might there be and would they still be ANQP?

- Berne

---

From: Zhen Cao <[email-masked]>
Date: Sun, 29 Jul 2012 15:49:42 -0700

Hi Bernie,

Thank you for the comments. See inline below.

On Sun, Jul 29, 2012 at 7:33 AM, Bernie Volz (volz) <[email-masked]> wrote:
> Seems to me the v4 & v6 options can be simplied to remove length_2 as the
> option length can just be 1 + ((# of addresses) * (address size, ie 4 or
> 16)).

How to handle the situation that type-1 has two v4 addresses and
type-2 has 1 v4 address.

And even only one address is contained, how to differentiate the 4 v4
address to 1 v6 address?

>
> Or is the intent that if more types are defined, that the data might be:
> type-1, length-1-2, address list for type[, type-2, length-2-2, address list
> for type, [...]]?
>
> We should also explore whether type field is needed; why wouldn't a new set
> of options be defined for a future type? This document is titled ANQP so
> what other types might there be and would they still be ANQP?

We consider this because the IEEE/WFA people have defined many
entities that will need to advertise their address. ANQP is one
example in IEEE 802.11-2012, and RLQP is coming in future specs.

>
> - Berne
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 29 Jul 2012 23:10:52 +0000

So, you are saying there can be (in the future) multiple types (each followed by data)? Perhaps I missed that but it wasn't clear to me from the draft. 

Sent from my iPhone