Subject: [dhcwg] draft-lemon-dhc-dns-pd-01.txt

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 29 Jul 2012 15:01:41 +0000

Ted:

I like this work.

A couple of minor nits:

"DHCP Discover" should be "DHCP Solicit". Might be best to drop DHCP before the DHCPv6 message names as RFC 3315 and others haven't generally done that.

I also think the following deserves some discussion:

     The requesting router MUST silently
   discard any DHCP Advertise message containing a PDZM option that
   indicates a method that was not listed in the PDZP option sent in the
   DHCP Discover message.

This seems a bit severe to me - especially if a server is just configured to return a fixed vale for this option. I could see move this to the end of the list of Advertises to be considered, but to discard it should be a SHOULD - not a MUST.

Though this would likely only work if the "fixed" option specified spoofed, since the others require further communication.

- Bernie

---

From: Ted Lemon <[email-masked]>
Date: Sun, 29 Jul 2012 15:59:02 +0000

On Jul 29, 2012, at 11:01 AM, Bernie Volz (volz) wrote:
"DHCP Discover" should be "DHCP Solicit". Might be best to drop DHCP before the DHCPv6 message names as RFC 3315 and others haven't generally done that.

Oops!

The reason for making this a MUST is that it should never happen.   If we make it a should, people won't actually implement this spec—they'll do what you're suggesting and just make it an option.   The goal here was to do a negotiation, not return a configuration option.   I guess that's what the discussion would be about—do we want this to be a negotiation, or an option, or both?   You can see where I stand on the issue—that's why I wrote it this way... :)

Right.

Thanks for the review!   I'll be curious to hear if other wg members have reactions to the question you've posed!