Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv6-stateful-issues-00 -- multiple adminstrative domains

From: Wuyts Carl <[email-masked]>
Date: Wed, 5 Sep 2012 08:50:13 +0200

I think, as CPE vendor, there's no other possibility then to vote AGAINST this proposal.

I read:
""
Clients may select one or several administrative domains; If multiple, each is a separate state machine
""

In some other discussion some time ago, there was already some proposal on having multiple/separate state machine for dhcpv6 client.  In this proposal, I see the same thing popping up, but in another context.
For CPE devices, this is really a no-go.  Apart from splitting up state machine (and as such, multiplying memory consumption with factor X), it'll also inject extra complexity.  The CPE, the low-end, nearly free-of-charge, device again seems to be victim of these kind of proposal!!

I don't know if some other CPE vendor people are subscribed to this WG, but I'd like to read how they feel about this...

Regs
Carl

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: maandag 20 augustus 2012 15:50
To: Ole Trøan; Ted Lemon
Cc: dhc WG
Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv6-stateful-issues-00 -- multiple adminstrative domains

In the slides I presented at IETF-83 (Paris) and IETF-84 (Vancouver) about this work, the last slide had:

Multiple Administrative Domains
·         Still planning to write new Internet-Draft on multiple administrative domains
·         Basic proposal will be for Advertise to include "Administrative Domain" option which contains an "administrative domain string"
·         Clients treat Advertises with the same administrative domain string as 'equal'
·         Clients may select one or several administrative domains; If multiple, each is a separate state machine

The basic idea here is that if a client sends a Solicit with IA_NA and IA_PD, one server (or set of servers) may respond with IA_NA information and administrative domain string A and another server (or set of servers) may respond with IA_PD and administrative domain string B. This would trigger the client to initiate two separate state machines.

Of course, there is also the possibility that other server(s) may respond with both the IA_NA and IA_PD and administrative domain string C. In which case the client now has to determine whether to use one state machine (and administrative domain C) or two state machines and administrative domain A (IA_NA) & B (IA_PD).

While fairly simple in concept (and for servers [include administrative domain option] and relays [no impact]), it does greatly complicate clients.

One idea would be for clients to implement something similar to what they do for WiFi and SSIDs - a user would be required to select which administrative domains are valid. One interesting twist here is that just like with WiFI, we could also secure this -- add an encryption option which would provide a way to secure the DHCP server(s) with which you are willing to communicate.

I haven't started work on this draft as it wasn't clear how much interest there is and if there are real world requirements for something like this. If there is sufficient interest, I would be happy to start work on it.

- Bernie

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ole Trøan
Sent: Monday, August 20, 2012 8:45 AM
To: Ted Lemon
Cc: dhc WG
Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv6-stateful-issues-00

Ted,

>> could we go forward with this draft that clarifies how multiple stateful options work in a single session, and with the general assumption that a client will choose one DHCP server and that server is authoritative?
>
> My concern is that if you do so, it will essentially result in clients standardizing on whatever behavior you specify, and so whether we write another standard or not, it will not be available in practice.

to turn the question around.
is there anyone who thinks that we should _not_ make multiple stateful options work in a single DHCP session?

cheers,
Ole

---

From: Ole Trøan <[email-masked]>
Date: Wed, 5 Sep 2012 09:48:18 +0200

Carl,

this document assumes a single administrative domain and that multiple administrative domains are _out of scope_.
isn't that in agreement with what you are saying too?

cheers,
Ole

> I think, as CPE vendor, there’s no other possibility then to vote AGAINST this proposal.
>  
> I read:
> “”
> “”
> For CPE devices, this is really a no-go.  Apart from splitting up state machine (and as such, multiplying memory consumption with factor X), it’ll also inject extra complexity.  The CPE, the low-end, nearly free-of-charge, device again seems to be victim of these kind of proposal!!
>  
> I don’t know if some other CPE vendor people are subscribed to this WG, but I’d like to read how they feel about this…
>  
> Regs
> Carl
>  
>  
>  
>  
> ·         Basic proposal will be for Advertise to include “Administrative Domain” option which contains an “administrative domain string”
> ·         Clients treat Advertises with the same administrative domain string as ‘equal’
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ole Trøan

---

From: Wuyts Carl <[email-masked]>
Date: Wed, 5 Sep 2012 09:56:14 +0200

Hi Ole,

"assumes", but what if not ? :-)
anyway, if multiple admin domains are out_of_scope, this could be fine.

Tx and regs
Carl

-----Original Message-----
From: Ole Troan [mailto:[email-masked]] On Behalf Of Ole Trøan
Sent: woensdag 5 september 2012 9:48
To: Wuyts Carl
Cc: Bernie Volz (volz); Ted Lemon; dhc WG
Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv6-stateful-issues-00 -- multiple adminstrative domains

Carl,

cheers,
Ole

> I don't know if some other CPE vendor people are subscribed to this WG, but I'd like to read how they feel about this.
>  
> Regs
> Carl
>  
>  
>  
>