Subject: [dhcwg] WGLC: draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt

From: Ted Lemon <[email-masked]>
Date: Fri, 21 Sep 2012 12:08:41 +0000

The authors have sub,tired a new version of this document to address concerns raised in the previous WGLC. If you participated in the previous WGLC or want to participate now, please review the (short) draft and send comments to the mailing list if you have any.  Also please indicate whether you support advancing the draft at this time or not.

We will evaluate consensus on October 5.

---

From: perl-list <[email-masked]>
Date: Fri, 21 Sep 2012 09:24:03 -0400 (EDT)

I support this draft moving forward. 

----- Original Message -----

> From: "Ted Lemon" <[email-masked]>
> To: "dhc WG" <[email-masked]>
> Sent: Friday, September 21, 2012 8:08:41 AM
> Subject: [dhcwg] WGLC:
> draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt

> The authors have sub,tired a new version of this document to address
> concerns raised in the previous WGLC. If you participated in the
> previous WGLC or want to participate now, please review the (short)
> draft and send comments to the mailing list if you have any. Also
> please indicate whether you support advancing the draft at this time
> or not.

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Simon Hobson <[email-masked]>
Date: Fri, 21 Sep 2012 14:31:21 +0100

Looks good to me. Has my support.

-- 
Simon Hobson

Visit http://www.magpiesnestpublishing.co.uk/ for books by acclaimed
author Gladys Hobson. Novels - poetry - short stories - ideal as
Christmas stocking fillers. Some available as e-books.

---

From: Chuck Anderson <[email-masked]>
Date: Fri, 21 Sep 2012 09:32:32 -0400

> We will evaluate consensus on October 5. 

I support moving this draft forward as-is.

---

From: David Farmer <[email-masked]>
Date: Fri, 21 Sep 2012 08:51:40 -0500

> The authors have sub,tired a new version of this document to address concerns raised in the previous WGLC. If you participated in the previous WGLC or want to participate now, please review the (sh…

I support this draft as-is and hope it is expeditiously moved forward 
both within the IETF and for implementation by vendors of both DHCPv6 
Relay Agents and Servers.

This issue is holding back broader deployment of IPv6, especially in 
enterprise environments, where MAC address tracking is a very common 
part of network security and management practice. This will align DHCPv6 
with such practices and hopefully remove one more road block in the way 
of deployment of IPv6 in many environments.

Thanks
-- 
===============================================
David Farmer               Email:[email-masked]
Office of Information Technology
University of Minnesota	
2218 University Ave SE	    Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Tim Chown <[email-masked]>
Date: Fri, 21 Sep 2012 14:59:52 +0100

Hi,

This also has my support.  It would be something we would use in our deployment.

A little nit though...  

The text says:
"Similarly DHCPv6 Relay or Server cannot glean client link-layer address from the contents of DHCPv6 message received."

and then later in Section 5 the text that's been added in the latest version says:
"This specification does not specify the mechanism for DHCPv6 Server to find out link-layer address of the directly connected clients as a DHCP option as it can obtain it directly from the received message."

This seems a bit contradictory - should the first text say "Similarly DHCPv6 Relay or DHCPv6 Server receiving a relayed message cannot glean"...?

Tim

---

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Fri, 21 Sep 2012 14:16:41 +0000

Hi Tim,

Thanks for supporting the document.

I think the first text which you referred is mentioned in the "Problem Statement" where in we really don't have a way to find out the link-layer address form the "DHCPv6 message header/options." 

Whereas the next text (section 5) is talking about server extracting it from DHCPv6 message L2 header. Not from the DHCPv6 message/options.

Please let me know if you still find it confusing.

Thanks,
Gaurav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tim Chown
Sent: Friday, September 21, 2012 7:30 PM
To: dhc WG
Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt

Hi,

A little nit though...  

The text says:

Tim

---

From: Tim Chown <[email-masked]>
Date: Fri, 21 Sep 2012 15:21:45 +0100

OK, perhaps clarify that then....  "as it can obtain it directly from the L2 header of the received DHCP message" ?

Tim

---

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Fri, 21 Sep 2012 14:27:58 +0000

Tim,

Sure, perhaps, I could change the present text to the following:-

"This specification does not specify the mechanism for DHCPv6 Server to find out link-layer address of the directly connected clients as a DHCP option as it can obtain it directly from the link-layer source address of the received DHCPv6 message"

Thanks,
Gaurav
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tim Chown
Sent: Friday, September 21, 2012 7:52 PM
To: dhc WG
Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt

Tim

On 21 Sep 2012, at 15:16, "Gaurav Halwasia (ghalwasi)" <[email-masked]> wrote:

> Subject: Re: [dhcwg] WGLC:

---

From: "Prashant Jhingran (pjhingra)" <[email-masked]>
Date: Mon, 24 Sep 2012 03:43:31 +0000

+1 , I support this draft.

-
Regards,
Prashant Jhingran

---

From: [email-masked]
Date: Mon, 24 Sep 2012 08:21:52 +0200 (CEST)

> The authors have sub,tired a new version of this document to address concerns raised in the previous WGLC. If you participated in the previous WGLC or want to participate now, please review the (sh…

I support this draft.

Steinar Haug, Nethelp consulting, [email-masked]