Subject: [dhcwg] DHCPv4 INFORM Refresh Time Option

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Mon, 10 Sep 2012 01:43:15 +0000

Hi Team,

We have submitted a new I-D for including Refresh Time option in INFORM message, similar to what DHCPv6 has.

The draft is available at:
http://www.ietf.org/internet-drafts/draft-halwasia-dhc-inform-refresh-time-opt-00.txt

Abstract:
   This document describes a Dynamic Host Configuration Protocol for
   IPv4 (DHCPv4) [RFC2131] option for specifying an upper bound for how
   long a client should wait before refreshing information retrieved
   from DHCPv4 Server by using DHCP INFORM message.  It is used with
   stateless DHCPv4 as there are no addresses or other entities with
   lifetimes that can tell the client when to contact the DHCPv4 server
   to refresh its configuration.

Appreciate your comments and suggestions.   We are also looking to have the WG take this on as a work item.

Thanks,
Gaurav

---

From: Ted Lemon <[email-masked]>
Date: Mon, 10 Sep 2012 02:09:40 +0000

> Appreciate your comments and suggestions.   We are also looking to have the WG take this on as a work item.

Do we have any reasonable expectation that any clients will implement this feature?

---

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Mon, 10 Sep 2012 02:24:10 +0000

>Do we have any reasonable expectation that any clients will implement this feature?
[Gaurav] Yes, I think so. Certainly not going to get implemented by most. Moreover, DHCP INFORM apart from being used by literal end host devices, also gets used in a lot of other deployments/scenarios. One of the vendor uses it for network discovery. In one another use-case, local dhcp servers on Hubs (in Hub and Spoke) kind of deployments needs to periodically refresh the local config parameters from the central server which it can use while replying to dhcp requests on it's LAN. 

Thanks,
Gaurav

---

From: Andre Kostur <[email-masked]>
Date: Sun, 9 Sep 2012 20:31:10 -0700

> [Gaurav] Yes, I think so. Certainly not going to get implemented by most. Moreover, DHCP INFORM apart from being used by literal end host devices, also gets used in a lot of other deployments/scena…

As another option, did you consider using Lease Time/T1/T2 instead of
having a completely new option for this?

-- 
Andre Kostur

---

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Mon, 10 Sep 2012 03:53:22 +0000

Hi Andre,

> As another option, did you consider using Lease Time/T1/T2 instead of having a completely new option for this?

[Gaurav] This is on the lines of DHCPv6. DHCPv6 also has information refresh time option. Moreover, Lease Time/T1/T2 does not make much sense in case of INFORM and anyway standard also does not allow this.

Thanks,
Gaurav
-----Original Message-----
From: Andre Kostur [mailto:[email-masked]] 
Sent: Monday, September 10, 2012 9:01 AM
To: Gaurav Halwasia (ghalwasi)
Cc: Ted Lemon; [email-masked]
Subject: Re: [dhcwg] DHCPv4 INFORM Refresh Time Option

> [Gaurav] Yes, I think so. Certainly not going to get implemented by most. Moreover, DHCP INFORM apart from being used by literal end host devices, also gets used in a lot of other deployments/scena…

As another option, did you consider using Lease Time/T1/T2 instead of having a completely new option for this?

--
Andre Kostur