Subject: [dhcwg] Reg. Use of Link-Address Field for DHCPv6

From: "Anup Kumar Vasudevan (anuvasud)" <[email-masked]>
Date: Fri, 14 Sep 2012 07:44:46 +0000

Hi

We have a query on the Link-Address field in DHCPv6 – for Relay Agents. From the RFC -

20.1.1<http://tools.ietf.org/html/rfc3315#section-20.1.1>. Relaying a Message from a Client

   If the relay agent received the message to be relayed from a client,
   the relay agent places a global or site-scoped address with a prefix
   assigned to the link on which the client should be assigned an
   address in the link-address field.  This address will be used by the
   server to determine the link from which the client should be assigned
   an address and other configuration information.  The hop-count in the
   Relay-forward message is set to 0.

   If the relay agent cannot use the address in the link-address field
   to identify the interface through which the response to the client
   will be relayed, the relay agent MUST include an Interface-id option
   (see section 22.18<http://tools.ietf.org/html/rfc3315#section-22.18>) in the Relay-forward message.  The server will
   include the Interface-id option in its Relay-reply message.  The
   relay agent fills in the link-address field as described in the
   previous paragraph regardless of whether the relay agent includes an
   Interface-id option in the Relay-forward message.

Is the Link-Address field Mandatory? Should Relay-Agents always fill it? Also is it mandatory for Server to use the Link-Address field for Assigning client addresses? If the Server does not have addresses that match the Link-Address field , should it fail the Allocation requests?

We have seen in testing that some of the third party servers don't really use this field for Address Assignment – but I think the ISC implementation is dependent on this field.

Thanks

Anup

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 17 Sep 2012 00:58:25 +0000

Ideally all relay agents would fill in this value. If they don't, it should be set to all 0's (128 bits of 0).

If no address is specified in the link-address field, a server would try an outer Relay-Forw to see if it has a link-address (and so on). If no relay specified the link-address, the server only has either the source address of the packet or the interface on which it was received in order to determine where the client is located. Neither of these is probably correct.

The bottom line is that a relay agent should fill in the link-address field with information about where the client is located that the server can use to assign appropriate addresses or delegate appropriate prefixes.

-          Bernie

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anup Kumar Vasudevan (anuvasud)
Sent: Friday, September 14, 2012 3:45 AM
To: [email-masked]
Cc: G Murali Krishna (gunkrish)
Subject: [dhcwg] Reg. Use of Link-Address Field for DHCPv6

Hi

We have a query on the Link-Address field in DHCPv6 - for Relay Agents. From the RFC -

We have seen in testing that some of the third party servers don't really use this field for Address Assignment - but I think the ISC implementation is dependent on this field.

Thanks

Anup