Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv4-over-ipv6

From: Ted Lemon <[email-masked]>
Date: Thu, 8 Nov 2012 13:26:09 +0000

On Oct 18, 2012, at 10:05 AM, Ted Lemon <[email-masked]> wrote:
> The authors have requested a new working group last call on this document.   The document has been updated based on feedback received during the previous working group last call.   The authors would appreciate review and feedback on this document.   If you favor advancing it, please say so on the mailing list.   If you oppose advancing it, also please say so and say why.
> 
> We will evaluate consensus on November 1.

There was one response in favor of this WGLC.   The document got substantial support in the previous WGLC in June.   Has that support gone away, or did people just not respond because they responded to the previous WGLC?   If you want this document to advance, please do respond to the WGLC.

Thanks!

---

From: Qi Sun <[email-masked]>
Date: Thu, 8 Nov 2012 09:57:02 -0500

Dear Ted ,

I'm in favor of seeing this document moving forward. 

Thanks!

Best Regards!

Qi Sun

On 2012-11-8, at 上午8:26, Ted Lemon wrote:

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Francis Dupont <[email-masked]>
Date: Thu, 08 Nov 2012 16:38:09 +0100

In your previous mail you wrote:

>  Has that support gone away, or did 
>  people just not respond because they responded to the previous WGLC?

=> I am guilty to be in this case...
But as I suggested the right solution is to cross post the WGLC in
the 6man ML.

Regards

[email-masked] (and also [email-masked])

---

From: Stephen Jacob <[email-masked]>
Date: Thu, 8 Nov 2012 18:43:08 -0800

I support advancing this document.

Regards,
Stephen
-- 
 Stephen Jacob | [email-masked] | +1 650 381 6051
 Nominum, Inc. |  http://www.nominum.com/  | +1 650 381 6000

On Thu, Nov 08, 2012 at 01:26:09PM +0000, Ted Lemon wrote:
> > The authors have requested a new working group last call on this document.
> > The document has been updated based on feedback received during the
> > previous working group last call.   The authors would appreciate review and
> > feedback on this document.   If you favor advancing it, please say so on
> > the mailing list.   If you oppose advancing it, also please say so and say
> > why.
> > 
> There was one response in favor of this WGLC.   The document got substantial
> support in the previous WGLC in June.   Has that support gone away, or did
> people just not respond because they responded to the previous WGLC?   If you
> want this document to advance, please do respond to the WGLC.

---

From: Mathias Samuelson <[email-masked]>
Date: Fri, 9 Nov 2012 03:27:36 +0000

Hey Ted,

I support advancing this.

Thanks,
Mathias

On Nov 8, 2012, at 5:26 AM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

On Oct 18, 2012, at 10:05 AM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:
The authors have requested a new working group last call on this document.   The document has been updated based on feedback received during the previous working group last call.   The authors would appreciate review and feedback on this document.   If you favor advancing it, please say so on the mailing list.   If you oppose advancing it, also please say so and say why.

Thanks!

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

Mathias Samuelson
Sr. Product Manager

m: +1.650.491.4193
o: +1.650.381.6225
[email-masked]<mailto:[email-masked]>

www.nominum.com
What is IDEAL?  |
Like  |  Link  |  Follow

---

From: Ole Trøan <[email-masked]>
Date: Fri, 9 Nov 2012 09:19:44 -0500

> We will evaluate consensus on November 1.

irrespectively of the fact that I think this is a bad idea;
this document should await the resolution IPv4 over IPv6 mechanisms in softwire.
depending on the outcome of that, there may or may not be any "users" of this new DHCPv4 infrastructure.

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Fri, 9 Nov 2012 15:57:39 +0000

> this document should await the resolution IPv4 over IPv6 mechanisms in softwire.

Ole, this document is being used by those documents, but the mechanism is general, not specific to lw4over6, and has been adopted as a working group work item.   So I will note that you do not participate in the working group consensus to advance this document, but this specific objection isn't a valid objection.

I would be curious to know what alternate idea you would propose—do you think that DHCPv6 should configure IPv4 stacks, or do you have some third alternative in mind?

---

From: Ole Trøan <[email-masked]>
Date: Fri, 9 Nov 2012 14:59:48 -0500

Ted,

> I would be curious to know what alternate idea you would propose—do you think that DHCPv6 should configure IPv4 stacks, or do you have some third alternative in mind?

it is meaningless to have IPv4 configuration information without a network connection that supports transport of IPv4 packets.
use that transport path to run DHCPv4.

didn't you volunteer (:-)) to figure out how to run DHCPv4 on an interface where you have a shared IPv4 address?
(as in port 67/68 isn't available).

cheers,
Ole

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 9 Nov 2012 20:04:49 +0000

I also support to move forward.

Thanks,
Yiu

From:  Mathias Samuelson <[email-masked]>
Date:  Thursday, November 8, 2012 10:27 PM
To:  Ted Lemon <[email-masked]>
Cc:  "<[email-masked]> WG" <[email-masked]>
Subject:  Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv4-over-ipv6

Hey Ted, 

Thanks,
Mathias

On Nov 8, 2012, at 5:26 AM, Ted Lemon <[email-masked]> wrote:

>> The document has been updated based on feedback received during the previous
>> working group last call.   The authors would appreciate review and feedback
>> on this document.   If you favor advancing it, please say so on the mailing
>> list.   If you oppose advancing it, also please say so and say why.
>> 

Mathias Samuelson
Sr. Product Manager
 
m: +1.650.491.4193
o: +1.650.381.6225
[email-masked]

www.nominum.com
What is IDEAL?  |  
Like  |  Link  |  Follow

---

From: Qiong <[email-masked]>
Date: Sat, 10 Nov 2012 12:20:02 +0800

Dear all,

I support this work to move forward !

Best wishes
Qiong

On Sat, Nov 10, 2012 at 4:04 AM, Lee, Yiu <[email-masked]> wrote:

> There was one response in favor of this WGLC.   The document got
> substantial support in the previous WGLC in June.   Has that support gone
> away, or did people just not respond because they responded to the previous
> WGLC?   If you want this document to advance, please do respond to the WGLC.
>
> Thanks!
>

-- 
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: *http://sourceforge.net/projects/laft6/*
PCP-natcoord:* http://sourceforge.net/projects/pcpportsetdemo/ *
===============================================

---

From: Ted Lemon <[email-masked]>
Date: Sat, 10 Nov 2012 05:13:53 +0000

> use that transport path to run DHCPv4.

Yes, of course, the expectation is that after getting the configuration information from DHCPv4, the client will somehow use a tunnel to get to what remains of the primordial Internet.

> (as in port 67/68 isn't available).

Yes, we understand how to do this.   I am not sure it's documented in a draft yet, but it's certainly an issue that's been talked through and resolved as part of the lw4over6 effort.

---

From: Ole Trøan <[email-masked]>
Date: Mon, 12 Nov 2012 10:46:21 +0100

Ted,

> Yes, we understand how to do this.   I am not sure it's documented in a draft yet, but it's certainly an issue that's been talked through and resolved as part of the lw4over6 effort.

I think Suresh was also talking about writing this up.
would you be able to share what the ideas are for how to do this?

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Mon, 12 Nov 2012 12:43:01 +0000

> would you be able to share what the ideas are for how to do this?

There are two basic options.   We speak of the CRA and the DHCP client as separate entities, but in fact there is no reason to separate them—the DHCP client could simply send a relay-wrapped packet over IPv6 directly.   So that's the simpler solution.  The other solution, if you want to keep the CRA and the DHCP client isolated, is to simply always broadcast, and have the client use a zero source address.   In this way, we are not using the shared IP address for DHCPv4 at all.

---

From: Ole Trøan <[email-masked]>
Date: Mon, 12 Nov 2012 13:47:26 +0100

Ted,

> There are two basic options.   We speak of the CRA and the DHCP client as separate entities, but in fact there is no reason to separate them—the DHCP client could simply send a relay-wrapped packet…

good point, using the unspecified address (0.0.0.0) sending to 255.255.255.255 should work fine on a point to point tunnel.
for this to work for MAP, we'd need to specify that the tunnel to the default (BR) is a p2p tunnel as opposed to a special node on the NBMA link.

if DHCP was only used for other configuration information (DHCPINFORM), would existing clients still use the unspecified address or would the use a global address if available?

cheers,
Ole

---

From: "Ehsan T." <[email-masked]>
Date: Thu, 15 Nov 2012 19:10:21 +0800

Hi There!

I do agree with continuing it.

-----------------------
Yours Sincerely,
Ehsan Taghizadeh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ted Lemon
Sent: Thursday, November 08, 2012 9:26 PM
To: <[email-masked]> WG
Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-dhcpv4-over-ipv6

There was one response in favor of this WGLC.   The document got substantial
support in the previous WGLC in June.   Has that support gone away, or did
people just not respond because they responded to the previous WGLC?   If
you want this document to advance, please do respond to the WGLC.

Thanks!