Subject: [dhcwg] [Technical Errata Reported] RFC3118 (3474)

From: RFC Errata System <[email-masked]>
Date: Sat, 2 Feb 2013 04:27:05 -0800 (PST)

The following errata report has been submitted for RFC3118,
"Authentication for DHCP Messages".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3118&eid=3474

--------------------------------------
Type: Technical
Reported by: Chris Lonvick <[email-masked]>

Section: 2

Original Text
-------------
   If the RDM field contains 0x00, the replay detection field MUST be
   set to the value of a monotonically increasing counter.  Using a
   counter value such as the current time of day (e.g., an NTP-format
   timestamp [4]) can reduce the danger of replay attacks.  This method
   MUST be supported by all protocols.

Corrected Text
--------------
   If the RDM field contains 0x00, the replay detection field MUST be
   set to the value of a strictly increasing counter.  Using a
   counter value such as the time since the epoch (e.g., an NTP-format
   timestamp [4]) can reduce the danger of replay attacks.  This method
   MUST be supported by all protocols.

Notes
-----
The term "monotonically increasing" does not actually mean what the authors and editors hope it means.  :-)  An example of a monotonically increasing sequence is: 
  1, 2, 2, 2, 2, 2, 2...  

Strictly following that definition in the current section 2 would allow replays of captured packets.  Changing the term to "strictly increasing" requires that subsequent values are greater than previous values.  This would mean that a captured packet replayed with the same Authentication Information value would not meet the criteria described in my proposed corrected text, and should consequently be detected as a replay attack by a recipient.

The term monotonically increasing is also used at the end of Section 6 and should also be replaced with strictly increasing.

Also, the use of the term  "time of day" could be problematic.  If the first packet were sent just before midnight, and the second sent just after midnight, then the value of the second would be much lower than the value of the first.  To align with the NTP example, I'm suggesting a change in text to be something that is actually increasing.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3118 (draft-ietf-dhc-authentication-16)
--------------------------------------
Title               : Authentication for DHCP Messages
Publication Date    : June 2001
Author(s)           : R. Droms, W. Arbaugh, Eds.
Category            : PROPOSED STANDARD
Source              : Dynamic Host Configuration
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Ted Lemon <[email-masked]>
Date: Sat, 2 Feb 2013 13:19:57 +0000

> The term "monotonically increasing" does not actually mean what the authors and editors hope it means.  :-)  An example of a monotonically increasing sequence is: 

This is a fairly serious error, which also appears in RFC3315.   :(

---

From: Donald Eastlake <[email-masked]>
Date: Sat, 2 Feb 2013 09:33:33 -0500

I am not sure it was an "error" at all. Monotone means constant.
Monotonically increasing means constantly increasing.

However, see http://planetmath.org/MonotonicallyIncreasing.html (a
site I have noting to do with but just found at the top of a web
search. That does indicate that "strictly increasing" is more
precise...

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Sat, Feb 2, 2013 at 8:19 AM, Ted Lemon <[email-masked]> wrote:
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Sat, 2 Feb 2013 15:28:09 +0000

> Monotonically increasing means constantly increasing.

Wikipedia has a pretty good explanation, complete with graphs of various monotonic and non-monotonic functions:

http://en.wikipedia.org/wiki/Monotonic_function