Subject: [dhcwg] 802.11ai - should IPv6 Gateway be put in the 802.11ai message?

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 20 Mar 2013 18:51:59 +0100

DHC participants,

Should the IPv6 Gateway address be put in the 802.11ai message? (or in
DHCPv6 message?)  Or both?  Or none?

Alex

---

From: Ole Troan <[email-masked]>
Date: Wed, 20 Mar 2013 22:39:45 +0100

> DHCPv6 message?)  Or both?  Or none?

I think we understand the tradeoffs of using ND for router discovery.
(dynamic, fate-sharing, supports multiple provisioning domains).

what are the benefits of using DHCP for this?

and speaking as someone who has very little clue about 802.11ai,
what makes it so different?

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Wed, 20 Mar 2013 21:44:20 +0000

> what are the benefits of using DHCP for this?

The stated goal is to speed up the address assignment process.

> what makes it so different?

The 802.11 stack is fairly heavyweight at this point, so it takes a long time to connect; reducing the address assignment time is one way to decrease the over all connect time.

I think this is going to turn out to be a manageability nightmare, but what do I know?

---

From: Ole Troan <[email-masked]>
Date: Wed, 20 Mar 2013 23:15:31 +0100

> The stated goal is to speed up the address assignment process.

OK, but what does that have to do with router discovery?

> The 802.11 stack is fairly heavyweight at this point, so it takes a long time to connect; reducing the address assignment time is one way to decrease the over all connect time.

reducing connection time seems to be a good goal. has anyone done measurements of what actually takes time?
before we get around to changing specifications I mean.

> I think this is going to turn out to be a manageability nightmare, but what do I know?

or a deployment one...

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Mar 2013 00:14:20 +0000

> OK, but what does that have to do with router discovery?

ND is an extra round trip.

Honestly, the burning question in my mind is how, given that you are getting a new IP address, you avoid glitches on reconnect.   But the bottom line is that this work is being done in the IEEE, not here, so none of this discussion here is going to make much difference.

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 21 Mar 2013 09:30:39 +0900

> The stated goal is to speed up the address assignment process.

Another important goal is to reduce the number of packets,
because PPS (packets per second) of Wifi is limited.

> I think this is going to turn out to be a manageability nightmare,

?

					Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 21 Mar 2013 09:45:43 +0900

Ted Lemon wrote:

> Honestly, the burning question in my mind is how, given that
> you are getting a new IP address, you avoid glitches on reconnect.

By using IP mobility and by simultaneously connecting to both the
current and a new base stations, there are no glitches.

						Masataka Ohta

---

From: Ted Lemon <[email-masked]>
Date: Thu, 21 Mar 2013 01:20:12 +0000

> because PPS (packets per second) of Wifi is limited.

That's adorable.

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 21 Mar 2013 08:35:27 +0100

Le 20/03/2013 22:39, Ole Troan a écrit :
>> Should the IPv6 Gateway address be put in the 802.11ai message? (or
>> in DHCPv6 message?)  Or both?  Or none?
>
> I think we understand the tradeoffs of using ND for router
> discovery. (dynamic, fate-sharing, supports multiple provisioning
> domains).
>

DHCPv6-alone could be provide faster configuration than a combination of
ND and DHCPv6 which is mandatory in some cases.

In IPv4 DHCPv4 could be used alone.

> and speaking as someone who has very little clue about 802.11ai, what
> makes it so different?

I have little clue as well and I am looking for education about 802.11ai.

I also wonder whether 802.11ai could transport IP messages (like 802.11b
does).

Alex

> cheers, Ole

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 21 Mar 2013 08:37:08 +0100

Le 20/03/2013 23:15, Ole Troan a écrit :
>> The 802.11 stack is fairly heavyweight at this point, so it takes
>> a long time to connect; reducing the address assignment time is
>> one way to decrease the over all connect time.
>
> reducing connection time seems to be a good goal. has anyone done
> measurements of what actually takes time? before we get around to
> changing specifications I mean.

We did some measurements about how fast a client can get full yet
minimal configuration in IPv6 with ND and DHCPv6.  Basically it comes
down to reducing from something like 4 to 2 messages (if only DHCPv6
were used).

>> I think this is going to turn out to be a manageability nightmare,

Lets see which one.

Alex

>
> cheers, Ole
>
>
> _______________________________________________ dhcwg mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 21 Mar 2013 08:39:11 +0100

Le 21/03/2013 01:14, Ted Lemon a écrit :
> Honestly, the burning question in my mind is how, given that you are
> getting a new IP address, you avoid glitches on reconnect.   But the
> bottom line is that this work is being done in the IEEE, not here,
> so none of this discussion here is going to make much difference.

I think it could make a little difference.

If the IPv6 Gateway is provided by a link-layer message of 802.11ai then
one must make sure the Router Advertisement sets the Lifetime to 0 (i.e.
imply that the src of that IP packet RA should _not_ be used as default
router).

In this way there is no risk of misconfiguration.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 21 Mar 2013 08:40:14 +0100

Le 21/03/2013 01:30, Masataka Ohta a écrit :
> Another important goal is to reduce the number of packets, because
> PPS (packets per second) of Wifi is limited.

Yes, depending on the bandwidth (from 1Mbit/s up to 1Gbit/s), the number
of packets per second in WiFi is limited to a certain number.

Alex

> Masataka Ohta _______________________________________________ dhcwg
> mailing list [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 21 Mar 2013 08:40:52 +0100

Le 21/03/2013 01:45, Masataka Ohta a écrit :
>> Honestly, the burning question in my mind is how, given that you
>> are getting a new IP address, you avoid glitches on reconnect.
>

But if by IP mobility is meant Mobile IP then that has additional
roundtrips to involve (in addition to address autoconfiguration).

Alex