Subject: [dhcwg] Source address in IP header for DHCPREQUEST generated during REBINDING state?

From: "SPHICAS, PHIL G" <[email-masked]>
Date: Fri, 17 May 2013 15:55:51 +0000

Hello,

What is the correct source IP address for a DHCPREQUEST generated during REBINDING state? Should it be the unicast IP, or 0.0.0.0?

I'm not quite clear on this after combing through RFC 2131 .. any pointers would be appreciated.

RFC 2131
4.3.2 DHCPREQUEST message 
DHCPREQUEST generated during REBINDING state

This message MUST be broadcast to the 0xffffffff IP broadcast address.

-- This doesn't specify the source IP

RFC 2131
4.1 Constructing and sending DHCP messages

DHCP clients MUST use the IP address provided in the 'server identifier' option for any unicast requests to the DHCP server.

-- This is a broadcast request, not a unicast request

DHCP messages broadcast by a client prior to that client obtaining its IP address must have the source address field in the IP header set to 0.

-- This is after the client has obtained an IP address

Thanks,
Phil

---

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Fri, 17 May 2013 16:08:27 +0000

It should be unicast IP allocated by the server.

-Gaurav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of SPHICAS, PHIL G
Sent: Friday, May 17, 2013 9:26 PM
To: [email-masked]
Subject: [dhcwg] Source address in IP header for DHCPREQUEST generated during REBINDING state?

Hello,

RFC 2131

RFC 2131

Thanks,
Phil
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Andre Kostur <[email-masked]>
Date: Fri, 17 May 2013 09:10:29 -0700

On a REBIND I would expect the source IP to be the IP of the client.
At the Rebind state the client still owns the IP address, it's just
that it no longer "trusts" that the server is still there, so now it
is broadcasting to see if any server is willing to continue servicing
this client.

--
Andre Kostur