Subject: [dhcwg] Fwd: [Roll] Request for Review: Fwd: I-D Action: draft-doi-roll-mpl-parameter-configuration-02.txt

From: Yusuke DOI <[email-masked]>
Date: Thu, 01 Aug 2013 17:11:30 +0900

Dear dhc folks,

Just FYI, here is a proposed individual I-D proposed to roll WG. I 
believe it does not make any harm to current DHCP infrastructure because 
this is another stateless option to distribute data among nodes. It's 
still in early stage and will be updated to satisfy the option guideline 
document.

Any feedbacks are welcome.

Regards,

Yusuke

-------- Original Message --------
Subject: [Roll] Request for Review: Fwd: I-D Action: 
draft-doi-roll-mpl-parameter-configuration-02.txt
Date: Wed, 31 Jul 2013 01:19:08 +0900
From: Yusuke DOI <[email-masked]>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]>
To: [email-masked]

Dear roll folks,

I (and Matt Gillmore) have a proposal to make MPL configuration over
DHCP option. I'm on the IETF meeting so I really appriciate if anyone
can take a quick review on it and/or have F2F discussion.

We're thinking of thousands of nodes under a LLNs. And we identified
configuration of MPL parameters is one of missing pieces for manageable
large scale LLN.

Regards,

Yusuke

-------- Original Message --------
Subject: I-D Action: draft-doi-roll-mpl-parameter-configuration-02.txt
Date: Mon, 29 Jul 2013 08:25:09 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : MPL Parameter Configuration Option for DHCPv6
	Author(s)       : Yusuke Doi
                           Matthew Gillmore
	Filename        : draft-doi-roll-mpl-parameter-configuration-02.txt
	Pages           : 8
	Date            : 2013-07-29

Abstract:
    This draft is to define a way to configure MPL parameter via DHCPv6
    option.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-doi-roll-mpl-parameter-configuration

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-doi-roll-mpl-parameter-configuration-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-doi-roll-mpl-parameter-configuration-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 12 Aug 2013 21:29:00 +0000

<WG Chair Hat OFF>

A few comments regarding this draft:

1. Please make sure to look at http://tools.ietf.org/html/draft-ietf-dhc-option-guidelines. This document is being adopted by the DHC WG and is critical to follow.

2. While it may cost a few octets, I would strongly encourage you to use separate fields for some items (such as C_K and DM_K). This will cost you one octet but keeps the encoding simpler (flags, C_K, and DM_K octets).

3. The new data type (Unsigned Short Floating Point) will likely delay implementation in some servers (or require 'manual' encoding). If it is critical that this be used (instead of a more traditional data type), so be it.

4. As stated in draft-ietf-dhc-option-guidelines, this document does specify that multiple instances are allowed (see draft-ietf-dhc-option-guidelines-13, section 16). However, it makes no statement as to whether the order is significant and that is covered in draft-ietf-dhc-option-guidelines-13, section 17 (there should be no IMPLICIT or EXPLICIT ordering with multiple options).

5. You might document the possible length of the options as there seems to be only two choices - X and X+16 (if C=1). Is C even necessary? Could the option length (i.e., if MPL domain address is present) be used to determine this? (It avoids having to test the length if C=1 to make sure it is correct.)

6. I can say nothing about the utility of this option and whether the data contained therein is appropriate as I am not an MPL expert - we would defer to the ROLL WG in these regards.

</WG Chair Hat OFF>

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yusuke DOI
Sent: Thursday, August 01, 2013 4:12 AM
To: [email-masked]
Subject: [dhcwg] Fwd: [Roll] Request for Review: Fwd: I-D Action: draft-doi-roll-mpl-parameter-configuration-02.txt

Dear dhc folks,

Just FYI, here is a proposed individual I-D proposed to roll WG. I believe it does not make any harm to current DHCP infrastructure because this is another stateless option to distribute data among nodes. It's still in early stage and will be updated to satisfy the option guideline document.

Regards,

Yusuke

-------- Original Message --------

Dear roll folks,

I (and Matt Gillmore) have a proposal to make MPL configuration over DHCP option. I'm on the IETF meeting so I really appriciate if anyone can take a quick review on it and/or have F2F discussion.

We're thinking of thousands of nodes under a LLNs. And we identified configuration of MPL parameters is one of missing pieces for manageable large scale LLN.

Regards,

Yusuke

-------- Original Message --------
Subject: I-D Action: draft-doi-roll-mpl-parameter-configuration-02.txt
Date: Mon, 29 Jul 2013 08:25:09 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Yusuke DOI <[email-masked]>
Date: Tue, 13 Aug 2013 11:19:04 +0900

Dear Bernie,

Thank you very much for the review.

(2013-08-13 06:29), Bernie Volz (volz) wrote:

> 1. Please make sure to look at
> http://tools.ietf.org/html/draft-ietf-dhc-option-guidelines. This
> document is being adopted by the DHC WG and is critical to follow.

Thanks, next revision will be with the guideline.

> 2. While it may cost a few octets, I would strongly encourage you to
> use separate fields for some items (such as C_K and DM_K). This will
> cost you one octet but keeps the encoding simpler (flags, C_K, and
> DM_K octets).

Ok, two more octets will make no problem. Though, K>16 seems to be uncommon.

> 3. The new data type (Unsigned Short Floating Point) will likely
> delay implementation in some servers (or require 'manual' encoding).
> If it is critical that this be used (instead of a more traditional
> data type), so be it.

This option is expected to be used in 6lowpan environment and message size matters. Not all DHCP servers are required to implement the options. Manual encoding (over hex) is also not too difficult.

I'll add some implementation details on the next revision.

> 4. As stated in draft-ietf-dhc-option-guidelines, this document does
> specify that multiple instances are allowed (see
> draft-ietf-dhc-option-guidelines-13, section 16). However, it makes
> no statement as to whether the order is significant and that is
> covered in draft-ietf-dhc-option-guidelines-13, section 17 (there
> should be no IMPLICIT or EXPLICIT ordering with multiple options).

Thanks, I'll clarify this. In short, there should be no effect on option order. I think I should explicitly say only one option is allowed for a MPL domain.

> 5. You might document the possible length of the options as there
> seems to be only two choices - X and X+16 (if C=1). Is C even
> necessary? Could the option length (i.e., if MPL domain address is
> present) be used to determine this? (It avoids having to test the
> length if C=1 to make sure it is correct.)

Right. I'll remove the C flag.

> 6. I can say nothing about the utility of this option and whether the
> data contained therein is appropriate as I am not an MPL expert - we
> would defer to the ROLL WG in these regards.
>
> </WG Chair Hat OFF>
>
> - Bernie

Thank you very much and I'll soon submit updated revision.

Yusuke