Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-dhcpv6-failover-design-03 - Respond by August 9, 2013!

From: Marcin Siodelski <[email-masked]>
Date: Fri, 9 Aug 2013 12:40:15 +0200

On Fri, Jul 19, 2013 at 3:59 PM, Bernie Volz (volz) <[email-masked]> wrote:

>  Folks, the authors of draft-ietf-dhc-dhcpv6-failover-design-03 (
> http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-failover-design) believe
> it is ready for working group last call. Please review this draft and
> indicate whether or not you feel it is ready to be published. Your input is
> important!****
>
> ** **
>
> This document is the 2nd series of documents related to DHCPv6 failover –
> the first is
> http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-failover-requirementswhich is currently being reviewed by the IESG for publication approval.
> ****
>
> ** **
>
> At the time of this writing, there is no IPR reported against this draft.*
> ***
>
> ** **
>
> As Tomek is a co-author, I will primarily evaluate consensus after
> 2013-08-09 (August 9th). This is a 3 week last call because of the Berlin
> IETF meeting and also because of summer-time vacations (at least for those
> of us in the northern hemisphere).
>

I read the document from the top to the bottom and made extensive review.
All valid issues I had pointed out were addressed in version -03. Other
comments which were identified as non-issues were responded via email. One
of the comments which I made was referring to the chapter 9.11. where I was
unclear "whether servers are responsive or unresponsive to the clients when
they are in the RESOLUTION-INTERRUPTED state" (see
http://www.ietf.org/mail-archive/web/dhcwg/current/msg14575.html). In the
recent reply to this email thread I clarified the question as it had been
unclear for the authors which part of text I had been referring to. This
question may still need to be responded. I apologize for the late answer.

In general, very good work. I support advancing this document.

Marcin

---

From: Kim Kinnear <[email-masked]>
Date: Fri, 9 Aug 2013 11:01:14 -0400

Marcin, et. al.,

I have responded to Marcin's comments about sections 9.11 and 9.11.1
in his email of Aug 7, since the details all appeared in that email
thread.

My bottom line from that response was:
> 
> 	So, technically, I think the document is accurate and
> 	that there is no conflict in what is described.
> 
> 	That said, you obviously found it obscure enough to raise
> 	this issue, and when we revise the document the next
> 	time, I will add some words to Section 9.11 to try to
> 	clarify that we are motivating the existence of the
> 	RESOLUTION-INTERRUPTED state, not describing how it
> 	operates.

Since this is a relatively minor clarification and not a change
to the document, I don't think any such clarification would
require a republication of the document and another last call (at
least on its own).

The changes I have in mind could be done during the RFC editor
processing, but I'm sure that won't be necessary.  We will certainly
have to make multiple revisions to this document to pass through
the IESG review process (assuming that we even get that far), and
I will make this change when we do those revisions.

If, as I said, we even pass through last call.

Regards -- Kim

On Aug 9, 2013, at 6:40 AM, Marcin Siodelski wrote:

> Folks, the authors of draft-ietf-dhc-dhcpv6-failover-design-03 (http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-failover-design) believe it is ready for working group last call. Please review this draft and indicate whether or not you feel it is ready to be published. Your input is important!
> 
>  
> 
> This document is the 2nd series of documents related to DHCPv6 failover – the first is http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-failover-requirements which is currently being reviewed by the IESG for publication approval.
> 
>  
> 
> At the time of this writing, there is no IPR reported against this draft.
> 
>  
> 
> As Tomek is a co-author, I will primarily evaluate consensus after 2013-08-09 (August 9th). This is a 3 week last call because of the Berlin IETF meeting and also because of summer-time vacations (at least for those of us  in the northern hemisphere).
> 
> 
> I read the document from the top to the bottom and made extensive review. All valid issues I had pointed out were addressed in version -03. Other comments which were identified as non-issues were responded via email. One of the comments which I made was referring to the chapter 9.11. where I was unclear "whether servers are responsive or unresponsive to the clients when they are in the RESOLUTION-INTERRUPTED state" (see http://www.ietf.org/mail-archive/web/dhcwg/current/msg14575.html). In the recent reply to this email thread I clarified the question as it had been unclear for the authors which part of text I had been referring to. This question may still need to be responded. I apologize for the late answer.
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Fri, 9 Aug 2013 11:18:19 -0400

Generally speaking, I strongly encourage you to apply any known updates to the document before submitting it to the IESG—we have to review typically several hundred pages per telechat, so the chances of us noticing the RFC editor's note at the right time are pretty slim.   Of course, comments that are already addressed by RFC editor's notes are easily dealt with, but why make us write them?   :)

That said, you haven't requested publication yet, and I will do an editorial pass over the document before submitting it to the IESG, so this update can wait until that editorial pass has happened.

Thanks!

---

From: Marcin Siodelski <[email-masked]>
Date: Fri, 9 Aug 2013 18:29:00 +0200

> in his email of Aug 7, since the details all appeared in that email
Kim,
I read section 9.11. a couple of times when I got your response. Now
understand what is said in this section. Having said that, I agree that the
document is accurate. It was my misinterpretation.

Regards,
Marcin

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sat, 17 Aug 2013 02:31:49 +0000

I finally had some time to carefully review this document (though it is late). But it turned out that Kim (co-author) was away this past week and so likely not much would have happened with the document anyway (see below). And, a few indicated they would prefer to have a bit more time (given the IETF meeting and vacations).

I do support this document moving forward.

However, the 03 version does have a bunch of mostly nits. And, I have a marked up paper version which I will review with Kim (hopefully over the next few days, but he may be busy catching up after having been away). I'd rather not have to list all of these nits in an email (spelling corrections, wording changes, minor errors). There are several TODOs in the document and a reference (TODO) to a non-existent section (on automatic transition of a server to partner-down after a configured time interval). I'd also suggest dropping some text, such as 8.2 Time Expression, as that belongs in a protocol document, not the design (there's no other text dependent on it). These must be cleaned up before sending the document on.

Reviewing my marked up document with Kim and having him update the document will likely be the best way to go (though of course there is no list to send out). But again, there's no significant flaws or issue that I found. Just a lot of fairly minor cleanup to do.

I hope to discuss the WGLC status with Tomek early next week (8/19) and then we will communicate the results.

If anyone else has any comments in support (or not) of the WGLC on this document, please let us know (by 8/19).

-          Bernie

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Friday, July 19, 2013 9:59 AM
To: [email-masked]
Subject: [dhcwg] WGLC for draft-ietf-dhc-dhcpv6-failover-design-03 - Respond by August 9, 2013!

This document is the 2nd series of documents related to DHCPv6 failover - the first is http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-failover-requirements which is currently being reviewed by the IESG for publication approval.

Thanks,

-          Bernie