Subject: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 11 Nov 2013 16:03:47 +0000

Hi all:

At the Vancouver IETF DHC WG session, there was support for adopting draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00. (You can view the presentation given by Kim Kinnear at http://www.ietf.org/proceedings/88/slides/slides-88-dhc-2.pptx.)

This call is being initiated to confirm whether there is indeed WG consensus to adopt this work as DHC WG item. Please state whether or not you're in favor of the adoption by replying to this mail. If you are not in favor, please also state your objections in your response. This adoption call will complete on November 25, 2013.

The HTML version of the document can be viewed at http://tools.ietf.org/html/draft-raghuvanshi-dhc-dhcpv6-active-leasequery.

Note: As this is not work explicitly mentioned in the Charter (while it is an extension as mentioned under bullet 1, it is not explicitly on the list of topics), we will have a discussion with our AD to get it approved in parallel to this call for adoption (given the level of support expressed at the DHC WG meeting).

Regards,

Tomek & Bernie

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 11 Nov 2013 22:15:16 +0000

I support adopting the document.

-          Bernie

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Monday, November 11, 2013 11:04 AM
To: [email-masked]
Subject: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

Hi all:

Regards,

Tomek & Bernie

---

From: "Weil, Jason" <[email-masked]>
Date: Tue, 12 Nov 2013 08:09:17 -0500

I support as well.

Jason

From: Bernie Volz <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 11, 2013 5:15 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

-          Bernie

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Monday, November 11, 2013 11:04 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

Hi all:

Regards,

Tomek & Bernie

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Kim Kinnear <[email-masked]>
Date: Mon, 18 Nov 2013 10:40:38 -0500

I support adopting this work as a DHC WG work item.

Regards -- Kim

On Nov 11, 2013, at 11:03 AM, Bernie Volz (volz) wrote:

> Hi all:
>  
> At the Vancouver IETF DHC WG session, there was support for adopting draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00. (You can view the presentation given by Kim Kinnear athttp://www.ietf.org/proceedings/88/slides/slides-88-dhc-2.pptx.)
>  
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Darpan Malhotra (damalhot)" <[email-masked]>
Date: Tue, 19 Nov 2013 04:57:19 +0000

I support adopting this document.

Regards,
Darpan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Monday, November 11, 2013 9:34 PM
To: [email-masked]
Subject: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

Hi all:

Regards,

Tomek & Bernie

---

From: Tomek Mrugalski <[email-masked]>
Date: Tue, 19 Nov 2013 11:51:28 +0100

On 11.11.2013 17:03, Bernie Volz (volz) wrote:
> At the Vancouver IETF DHC WG session, there was support for adopting
> draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00. (You can view the
> presentation given by Kim Kinnear at
> http://www.ietf.org/proceedings/88/slides/slides-88-dhc-2.pptx.)
> 
> This call is being initiated to confirm whether there is indeed WG
> consensus to adopt this work as DHC WG item. Please state whether or not
> you're in favor of the adoption by replying to this mail.
(chair hat off)

As a regular participant, I support adoption of this document.

I haven't thoroughly read the draft yet, just browsed it quickly and
have 2 minor editorial comments:

1. abstract/introduction uses 'client' to name the entity that sends
leasequery requests. One can argue that requestor is a special type of a
client, so technically the text is correct, but 'client' context usually
means end device in DHCP. It is better to use term 'requestor' as
defined in RFC5007.

2. Options that define time must be more explicit. They should say that
the content specifies number of seconds since some specific point in
time. If you don't have any strong preference, I suggest to use the same
as with DUID-LLT: seconds since midnight 1 Jan 2000 UTC modulo 2^32.

I hope to do a more thorough review at a later date.

Tomek

---

From: Mathias Samuelson <[email-masked]>
Date: Tue, 19 Nov 2013 17:00:58 +0000

I'm neutral on whether this should be adopted as a DHCPv6 only effort.

Lack of support for DHCPv4 is IMHO problematic since most network operators still operate IPv4 networks of one form or the other, and with my product manager hat on, I think there is a lot of appeal in making products that are consistent across IPv4 and IPv6 (to the greatest extent possible of course).

I would def supporting adopting this work if it was made broader to support DHCPv4 as well.

Thanks
Mathias

On Nov 11, 2013, at 8:03 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:

Hi all:

Regards,
Tomek & Bernie

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

Mathias Samuelson | Sr. Product Manager
mobile: +1.650.491.4193 | office: +1.650.381.6225
Nominum | www.nominum.com<http://www.nominum.com/> | [email-masked]<mailto:[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 19 Nov 2013 12:57:22 -0500

> I would def supporting adopting this work if it was made broader to support DHCPv4 as well.

FWIW, I think DHCPv4 support would be useful too.   I didn't say anything about it at the meeting because I was on the fence, but upon further consideration it seems to me that it's useful to do.

---

From: Kim Kinnear <[email-masked]>
Date: Tue, 19 Nov 2013 13:31:45 -0500

Well, that makes two (or three, counting me) that think 
active leasequery for v4 would also be useful in addition to
v6.

In the short intro I did at IETF, I gave two choices for
moving forward with active leasequery for v4:

  (a) Create combined DHCPv4/DHCPv6 active leasequery draft
  (b) Keep as separate drafts (one for v4 and v6)

Any preferences from either Ted or Mathias (or anyone
else) on this question? I probably lean toward the combined 
draft myself.

I'm not assuming that this would be adopted as a WG work item, of
course, but I just wanted to see where we were on this question.

Thanks -- Kim

---

From: Ted Lemon <[email-masked]>
Date: Tue, 19 Nov 2013 13:32:31 -0500

> else) on this question? I probably lean toward the combined 

If the text would mostly be the same, one draft seems better than two.

---

From: Kim Kinnear <[email-masked]>
Date: Tue, 19 Nov 2013 13:36:39 -0500

I think it would *mostly* be the same.  The underlying bulk leasequery
support is similar (though not identical), and I think we'd end up
with two sections at one point -- one for deltas to v4 bulk leasequery,
and one for deltas to v6 bulk leasequery.  But other than that, I think
it would mostly be a case of v4/v6 options throughout -- which we already
do all the time these days.  So, yes, I think it would mostly be the
same.

Cheers -- Kim

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 19 Nov 2013 18:54:22 +0000

IMHO, I think two (separate v4 and v6) drafts would be better. Much less room for confusion. But, I'll let the authors and WG decide which they'd prefer.

(Also, I suspect it is less work as the drafts already exists :).)

I think if there is interest in the v4, Kim should republish the expired v4 draft. We can then start a WG call for adoption on that.

We the WG adopts both, we can then figure out whether one or two drafts are better. If the WG decides to only go forward with V6 (as appeared to be the inform indication during the WG), then we have nothing further to discuss on this issue.

- Bernie

-----Original Message-----
From: Kim Kinnear (kkinnear) 
Sent: Tuesday, November 19, 2013 1:37 PM
To: Ted Lemon
Cc: Kim Kinnear (kkinnear); Mathias Samuelson; [email-masked]; Bernie Volz (volz)
Subject: Re: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

I think it would *mostly* be the same.  The underlying bulk leasequery support is similar (though not identical), and I think we'd end up with two sections at one point -- one for deltas to v4 bulk leasequery, and one for deltas to v6 bulk leasequery.  But other than that, I think it would mostly be a case of v4/v6 options throughout -- which we already do all the time these days.  So, yes, I think it would mostly be the same.

Cheers -- Kim

On Nov 19, 2013, at 1:32 PM, Ted Lemon wrote:

>> else) on this question? I probably lean toward the combined draft 
>> myself.
>

---

From: Mathias Samuelson <[email-masked]>
Date: Tue, 19 Nov 2013 18:54:37 +0000

I also think it would be nicer if it was a single document.

Thanks
Mathias

Mathias Samuelson | Sr. Product Manager
mobile: +1.650.491.4193 | office: +1.650.381.6225
Nominum | www.nominum.com | [email-masked]

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 19 Nov 2013 18:57:52 +0000

Bad typing day ... let's try that last paragraph again ...

When the WG adopts both, we can then figure out whether one or two drafts are better. If the WG decides to only go forward with V6 (as appeared to be the informal indication during the WG), then we have nothing further to discuss on this issue.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Tuesday, November 19, 2013 1:54 PM
To: Kim Kinnear (kkinnear); Ted Lemon
Cc: [email-masked]
Subject: Re: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

- Bernie

-----Original Message-----
From: Kim Kinnear (kkinnear) 
Sent: Tuesday, November 19, 2013 1:37 PM
To: Ted Lemon
Cc: Kim Kinnear (kkinnear); Mathias Samuelson; [email-masked]; Bernie Volz (volz)
Subject: Re: [dhcwg] WG Adoption Call - draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00 - Ends November 25, 2013

Cheers -- Kim