Subject: [dhcwg] TRA function draft-ietf-dhc-dhcpv4-over-ipv6

From: <[email-masked]>
Date: Tue, 12 Nov 2013 10:03:35 +0100

Hi,

I was just updating the v4-configuration draft after Vancouver and one thing that stands out is the following paragraph in the description of DHCPv4 over IPv6:

It is worth noting that there is no technical reason for using relay
   encapsulation for DHCPv4o6; this approach was taken because the
   authors of the draft originally imagined that it might be used to
   provide configuration information for an unmodified DHCPv4 client.
   However, this turns out not to be a viable approach: in order for
   this to work, there would have to be IPv4 routing on the local link
   to which the client is connected.  In that case, there's no need for
   DHCPv4o6.

   Given that this is the case, there is no technical reason why
   DHCPv4o6 can't simply use the IPv6 transport directly, without any
   relay encapsulation.  This would greatly simplify the specification
   and the implementation, and would still address the requirements
   stated in this document.

As the DHCPv6oIPv6 draft is still being updated (now with an intended Informational status), can we align these two – either by proving that the TRA is necessary (so the text can be removed from the v4-conf draft) or by removing the TRA from the DHCPv4oIPv6 draft?

Cheers,
Ian

---

From: Qi Sun <[email-masked]>
Date: Tue, 12 Nov 2013 21:48:16 +0800

Hi Ian,

This text confuses me a little. Please see inline.

On 2013-11-12, at 下午5:03, <[email-masked]> <[email-masked]> wrote:
>    encapsulation for DHCPv4o6; 
[Qi] What do you mean by "relay encapsulation"? Do you mean the TRA transfers the response
from a unmodified DHCPv4 server into an IPv6 packet? 
Or do you refer to I-D.ietf-dhc-dhcpv4-relay-encapsulation, which is referenced in DHCPv4 over IPv6.
> this approach was taken because the
[Qi] This seems talking about CRA that relays IPv4 messages to TRA or TSV. 
>    to which the client is connected.  In that case, there's no need for
[Qi] I didn't quite get it. Could you please elaborate?
> As the DHCPv6oIPv6 draft is still being updated (now with an intended Informational status), can we align these two – either by proving that the TRA is necessary (so the text can be removed from th…

[Qi] What does the above text in v4-conf draft talk about, CRA or TRA?

Best Regards,
Qi
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg