Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-dhcpv4-over-dhcpv6-03 - Respond by Dec 9, 2013

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 6 Dec 2013 20:20:00 +0000

Fixed the subject ...

Yes, this is a good point. I am not sure initially is any better.

Perhaps this should just be reworded to say that the client uses one of the two methods (multicast to All_DHCP_Relay_Agents_and_Servers) or to the list indicated in the option.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: Friday, December 06, 2013 3:02 PM
To: Bernie Volz (volz); [email-masked]
Subject: Re: [dhcwg] WGLC - draft-ietf-dhc-option-guidelines-12 - Respond by July 15

I've just reviewed all the discussion of Server address and I think what I'm about to say is still relevant. This is just a trivial wording remark.

The last paragraph of Section 4 says:

    Typically, a 4o6 DHCP client communicates with the 4o6 DHCP servers
    using well-known All_DHCP_Relay_Agents_and_Servers multicast address.
    Client SHOULD request the 4o6 Server Address Option from a DHCPv6
    server and the server may be configured to respond to the client with
    one such option that contains one or more unicast addresses of the
    4o6 DHCP Servers.  The server includes 4o6 Server Address Option in
    Advertise and Reply messages.  The format of the option is defined in
    Section 6.3.

The word "typically" in the first sentence seems to clash with "[The] client SHOULD request ..." in the next sentence. Do you mean to say "initially" rather than "typically"?

Tom Taylor

On 01/07/2013 5:44 PM, Bernie Volz (volz) wrote:
> The draft-ietf-dhc-option-guidelines-12,
> http://tools.ietf.org/html/draft-ietf-dhc-option-guidelines-12,
> addresses the comments from the previous (-11) last call. While 
> originally I expected to have a short (1 week) last call for the 
> updated document, I think it best to have the standard 2 weeks given 
> the time of year (and the Independence Day holiday in the US).
>
>
>
> Please review the draft and indicate whether or not you feel this 
> version is ready to be published. Your response matters to the 
> process, so please do respond.
>
>
>
> Do note: While I encourage full reviews, the main focus is to assure 
> we have consensus on the recent changes from the -11. The -11 WGLC 
> support will be taken into consideration.
>
>
>
> As Tomek is an author, I will evaluate consensus after July 15, 2013.
>
>
>
> -          Bernie
>
>
>
>
>
> _______________________________________________ dhcwg mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg
>
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Tom Taylor <[email-masked]>
Date: Fri, 06 Dec 2013 15:49:32 -0500

I think "initially" is correct. When the client first comes up, it does 
not normally have a server unicast address. Even though the client and 
server have not yet agreed on 4o6 provisioning at that point, the client 
has reached the 4o6 server using multicast.

Tom

On 06/12/2013 3:20 PM, Bernie Volz (volz) wrote:
> Perhaps this should just be reworded to say that the client uses one
> of the two methods (multicast to All_DHCP_Relay_Agents_and_Servers)
> or to the list indicated in the option.
>
> - Bernie
>
> -----Original Message----- From: dhcwg
> [mailto:[email-masked]] On Behalf Of Tom Taylor Sent: Friday,
> December 06, 2013 3:02 PM To: Bernie Volz (volz); [email-masked]
> I've just reviewed all the discussion of Server address and I think
> what I'm about to say is still relevant. This is just a trivial
> wording remark.
>
> using well-known All_DHCP_Relay_Agents_and_Servers multicast
> address. Client SHOULD request the 4o6 Server Address Option from a
> DHCPv6 server and the server may be configured to respond to the
> client with one such option that contains one or more unicast
> addresses of the 4o6 DHCP Servers.  The server includes 4o6 Server
> Address Option in Advertise and Reply messages.  The format of the
> option is defined in Section 6.3.
>
> The word "typically" in the first sentence seems to clash with "[The]
> client SHOULD request ..." in the next sentence. Do you mean to say
> "initially" rather than "typically"?
>
> Tom Taylor
>
...

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 6 Dec 2013 21:00:04 +0000

No. That is not the case. The 4o6 DHCP client doesn't start communicating until it has received the option(s) from the DHCPv6 server and then it knows whether it got a list of servers to send to or whether it should use the default multicast address. Read the paragraph previous to the one in question.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: Friday, December 06, 2013 3:50 PM
To: Bernie Volz (volz); [email-masked]
Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-dhcpv4-over-dhcpv6-03 - Respond by Dec 9, 2013

I think "initially" is correct. When the client first comes up, it does not normally have a server unicast address. Even though the client and server have not yet agreed on 4o6 provisioning at that point, the client has reached the 4o6 server using multicast.

Tom

On 06/12/2013 3:20 PM, Bernie Volz (volz) wrote:
> -----Original Message----- From: dhcwg [mailto:[email-masked]] 
> On Behalf Of Tom Taylor Sent: Friday, December 06, 2013 3:02 PM To: 
> Bernie Volz (volz); [email-masked]
> Client SHOULD request the 4o6 Server Address Option from a
...

---

From: Tom Taylor <[email-masked]>
Date: Fri, 06 Dec 2013 21:38:12 -0500

I think this hinges on when the client starts acting as a 4o6 client, 
which is not clear but really doesn't matter. May I suggest the 
following phrasing:

"Again by default, a 4o6 client communicates with the 4o6 DHCP servers
  using the well-known All_DHCP_Relay_Agents_and_Servers multicast
  address.  However, the client SHOULD ...".

Tom Taylor

On 06/12/2013 4:00 PM, Bernie Volz (volz) wrote:
> No. That is not the case. The 4o6 DHCP client doesn't start
> communicating until it has received the option(s) from the DHCPv6
> server and then it knows whether it got a list of servers to send to
> or whether it should use the default multicast address. Read the
> paragraph previous to the one in question.
>
> - Bernie
>
> December 06, 2013 3:50 PM To: Bernie Volz (volz); [email-masked]
> I think "initially" is correct. When the client first comes up, it
> does not normally have a server unicast address. Even though the
> client and server have not yet agreed on 4o6 provisioning at that
> point, the client has reached the 4o6 server using multicast.
>
> Tom
>
>> Perhaps this should just be reworded to say that the client uses
>> one of the two methods (multicast to
>> All_DHCP_Relay_Agents_and_Servers) or to the list indicated in the
>> option.
>>
>> - Bernie
>>
>> [mailto:[email-masked]] On Behalf Of Tom Taylor Sent:
>> Friday, December 06, 2013 3:02 PM To: Bernie Volz (volz);
>> [email-masked] Subject: Re: [dhcwg] WGLC -
>> draft-ietf-dhc-option-guidelines-12 - Respond by July 15
>>
>> I've just reviewed all the discussion of Server address and I
>> think what I'm about to say is still relevant. This is just a
>> trivial wording remark.
>>
>> Typically, a 4o6 DHCP client communicates with the 4o6 DHCP
>> servers using well-known All_DHCP_Relay_Agents_and_Servers
>> multicast address. Client SHOULD request the 4o6 Server Address
>> Option from a DHCPv6 server and the server may be configured to
>> respond to the client with one such option that contains one or
>> more unicast addresses of the 4o6 DHCP Servers.  The server
>> includes 4o6 Server Address Option in Advertise and Reply messages.
>> The format of the option is defined in Section 6.3.
>>
>> The word "typically" in the first sentence seems to clash with
>> "[The] client SHOULD request ..." in the next sentence. Do you mean
>> to say "initially" rather than "typically"?
>>
>> Tom Taylor
>>
> ... _______________________________________________ dhcwg mailing
> list [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg
>