Subject: [dhcwg] WG Adoption Call draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 4 Dec 2013 16:46:38 +0000

Hi all:

This is a WG Call for Adoption for http://tools.ietf.org/html/draft-kinnear-dhc-dhcpv4-active-leasequery-02. This call is being initiated to determine whether there is WG consensus to adopt this work as DHC WG item. Please state whether or not you're in favor of the adoption by replying to this mail. If you are not in favor, please also state your objections in your response. This adoption call will complete on December 18, 2013.

This call is being initiated because during the call for adoption for draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00, which was just adopted, several people asked about the related DHCPv4 work. Kim republished the DHCPv4 draft (with minor updates) as it had expired a while ago. So, we are seeking input as to whether the WG should now also work on the DHCPv4 version of active leasequery, given that the DHCPv6 version was adopted.

Regards,
Tomek & Bernie

-----Original Message-----
From: Kim Kinnear (kkinnear) 
Sent: Wednesday, December 04, 2013 11:25 AM
To: [email-masked]
Cc: Kim Kinnear (kkinnear); Bernie Volz (volz); Tomek Mrugalski
Subject: New Version Notification for draft-kinnear-dhc-dhcpv4-active-leasequery-02.txt

Folks,

During the adoption discussion about DHCPv6 Active Leasequery there was some discussion about having a corresponding DHCPv4 Active Leasequery capability.  If there is sufficient interest in a DHCPv4 Active Leasequery capability to parallel the DHCPv6 capability that was adopted as a DHC WG work item recently, then we can decide whether or not we want to have two drafts moving toward two RFC's, or combine them into one draft.

But the first question is whether or not there is sufficient interest in having a DHCPv4 Active Leasequery capability at all!

In order to help decide this question, I have updated the existing
DHCPv4 Active Leasequery draft from a couple of years ago, and resubmitted it as an individual submission -- as recommended by Bernie and Tomek.

Below you can find the information on how to find this new draft.

Regards -- Kim

Begin forwarded message:

> From: <[email-masked]>
> Subject: New Version Notification for 
> draft-kinnear-dhc-dhcpv4-active-leasequery-02.txt
> Date: December 4, 2013 10:01:03 AM EST
> To: Bernie Volz <[email-masked]>, Mark Stapp <[email-masked]>, Kim 
> Kinnear <[email-masked]>, Neil Russell <[email-masked]>
> 
> 
> A new version of I-D, 
> draft-kinnear-dhc-dhcpv4-active-leasequery-02.txt
> has been successfully submitted by Kim Kinnear and posted to the IETF 
> repository.
> 
> Filename:	 draft-kinnear-dhc-dhcpv4-active-leasequery
> Revision:	 02
> Title:		 Active DHCPv4 Lease Query
> Creation date:	 2013-12-04
> Group:		 Individual Submission
> Number of pages: 22
> URL:             http://www.ietf.org/internet-drafts/draft-kinnear-dhc-dhcpv4-active-leasequery-02.txt
> Status:          http://datatracker.ietf.org/doc/draft-kinnear-dhc-dhcpv4-active-leasequery
> Htmlized:        http://tools.ietf.org/html/draft-kinnear-dhc-dhcpv4-active-leasequery-02
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-kinnear-dhc-dhcpv4-active-leasequery-02
> 
> Abstract:
>   The Dynamic Host Configuration Protocol for IPv4 (DHCPv4) has been
>   extended with a Leasequery capability that allows a client to request
>   information about DHCPv4 bindings.  That mechanism is limited to
>   queries for individual bindings.  In some situations individual
>   binding queries may not be efficient, or even possible.  In addition,
>   continuous update of an external client with Leasequery data is
>   sometimes desired. This document expands on the DHCPv4 Leasequery
>   protocol, and allows for active transfer of near real-time DHCPv4
>   address binding information data via TCP.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Kim Kinnear <[email-masked]>
Date: Mon, 9 Dec 2013 16:07:55 -0500

Perhaps unsurprisingly, I support the working group adopting
this draft as a work item.

Regards -- Kim

---

From: Ted Lemon <[email-masked]>
Date: Mon, 9 Dec 2013 16:59:47 -0500

On Dec 4, 2013, at 11:46 AM, Bernie Volz (volz) <[email-masked]> wrote:
> So, we are seeking input as to whether the WG should now also work on the DHCPv4 version of active leasequery, given that the DHCPv6 version was adopted.

Not at all wearing my AD hat, I think it's worth doing.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 10 Dec 2013 02:38:50 +0000

<WG co-chair hat off>

I support adopting this work - but I am a co-author so that's probably not a big surprise.

As the WG has adopted the DHCPv6 work, this really should be pretty easy, from a IETF standards view, to work on as it is similar extensions to the DHCPv4 bulk leasequery to support this.

<WG co-chair hat on>

While it is an early reminder as we still have more than a week to go, but ... please do forward your thoughts after reviewing the document.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Wednesday, December 04, 2013 11:47 AM
To: Kim Kinnear (kkinnear); [email-masked]
Subject: [dhcwg] WG Adoption Call draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18

Hi all:

Regards,
Tomek & Bernie

---

From: "Deepak Kukrety (dkukrety)" <[email-masked]>
Date: Tue, 10 Dec 2013 04:45:56 +0000

I support adopting this work as DHC WG item.

Regards
Deepak

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Wednesday, December 04, 2013 10:17 PM
To: Kim Kinnear (kkinnear); [email-masked]
Subject: [dhcwg] WG Adoption Call draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18

Hi all:

Regards,
Tomek & Bernie

-----Original Message-----
From: Kim Kinnear (kkinnear) 
Sent: Wednesday, December 04, 2013 11:25 AM
To: [email-masked]
Cc: Kim Kinnear (kkinnear); Bernie Volz (volz); Tomek Mrugalski
Subject: New Version Notification for draft-kinnear-dhc-dhcpv4-active-leasequery-02.txt

Folks,

Regards -- Kim

> submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 10 Dec 2013 06:13:39 +0000

I support the adoption of the document. Useful work.

Sheng

>Sent: Tuesday, December 10, 2013 10:39 AM
>To: [email-masked]
>Subject: Re: [dhcwg] WG Adoption Call
>draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18
>
><WG co-chair hat off>
>
>As the WG has adopted the DHCPv6 work, this really should be pretty easy,
>from a IETF standards view, to work on as it is similar extensions to the
>DHCPv4 bulk leasequery to support this.
>
><WG co-chair hat on>
>
>While it is an early reminder as we still have more than a week to go, but ...
>please do forward your thoughts after reviewing the document.
>
>- Bernie
>
>Subject: [dhcwg] WG Adoption Call
>draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18
>
>Hi all:
>
>This is a WG Call for Adoption for
>http://tools.ietf.org/html/draft-kinnear-dhc-dhcpv4-active-leasequery-02.
>This call is being initiated to determine whether there is WG consensus to
>adopt this work as DHC WG item. Please state whether or not you're in favor
>of the adoption by replying to this mail. If you are not in favor, please also
>state your objections in your response. This adoption call will complete on
>December 18, 2013.
>
>This call is being initiated because during the call for adoption for
>draft-raghuvanshi-dhc-dhcpv6-active-leasequery-00, which was just adopted,
>several people asked about the related DHCPv4 work. Kim republished the
>DHCPv4 draft (with minor updates) as it had expired a while ago. So, we are
>seeking input as to whether the WG should now also work on the DHCPv4
>version of active leasequery, given that the DHCPv6 version was adopted.
>
>Regards,
>Tomek & Bernie
>

---

From: Mathias Samuelson <[email-masked]>
Date: Tue, 10 Dec 2013 21:56:55 +0000

Hi,

I definitely support adopting this as a WG work item.

Thanks
Mathias

>> submission until the htmlized version and diff are available at tools.ietf.org.

Mathias Samuelson | Sr. Product Manager
mobile: +1.650.491.4193 | office: +1.650.381.6225
Nominum | www.nominum.com | [email-masked]

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 19 Dec 2013 14:59:16 +0000

While we are now technically past the respond by date, I will make one last plea for comments regarding adopting this as a WG item.

We did receive responses from two non-authors, but I don't really feel that is strong enough to consider adopting this. No one objected, so that does weigh in favor of adopting it.

Because I am a co-author, I will leave it for Tomek to decide whether this document should be adopted. I will ask him to hold off announcing results until Monday, December 23 (so send your response by Sunday).

Again, if you haven't responded and have a few minutes, please consider whether the WG should adopt or not. We did adopt the DHCPv6 version of this work, so it would not be a stretch to adopt for DHCPv4 as the motivation is identical.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Wednesday, December 04, 2013 11:47 AM
To: Kim Kinnear (kkinnear); [email-masked]
Subject: [dhcwg] WG Adoption Call draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18

Hi all:

Regards,
Tomek & Bernie

-----Original Message-----
From: Kim Kinnear (kkinnear) 
Sent: Wednesday, December 04, 2013 11:25 AM
To: [email-masked]
Cc: Kim Kinnear (kkinnear); Bernie Volz (volz); Tomek Mrugalski
Subject: New Version Notification for draft-kinnear-dhc-dhcpv4-active-leasequery-02.txt

Folks,

Regards -- Kim

---

From: Kim Kinnear <[email-masked]>
Date: Thu, 19 Dec 2013 10:32:24 -0500

Bernie,

I'm confused.  I count responses from 6 non-authors on this work:

Ted Lemon 		12/9/13 4:59pm
Sheng Jiang 		12/10/13 1:13pm
Mathias Samelson 	12/10/13 4:56pm
Dushyant Raghuvanshi 	12/9/13 11:29pm
Darpan Malhotra 	12/12/13 1:31pm
Deepak Kukrety 		12/9/13 11:45pm

Now, my mail reader didn't gather all of these together for me easily, and
I don't know why.  But I do see them in my email.  The times above are
the times in my email reader (EST), for reference.

I'm not saying that we need to adopt this or not, but it seems to me
that we should be counting the folks that responded.

Thanks -- Kim

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 19 Dec 2013 15:48:40 +0000

Kim & DHC WG ...

I excluded Dushyant, Darpan, and Deepak (they aren't authors of the dhcpv4 work, but of the dhcpv6 - except for Darpan but he works with us at Cisco - and I didn't feel that this longer answer was required but I guess I should have include it). They are certainly all valid opinions, but there is some "conflict of interest".

I did miss Sheng's response - not sure why I missed it when I had Outlook search for the draft name in DHC WG email.

In the future I should avoid putting counts in as "rough consensus" is not about "counting votes". And should just state that we are interesting in getting 'more' opinions.

Anyway, let's see what happens ... as I'm leaving the decision up to Tomek (and he should do his own analysis) and we'll see if there is any more interest expressed.

- Bernie

-----Original Message-----
From: Kim Kinnear (kkinnear) 
Sent: Thursday, December 19, 2013 10:32 AM
To: Bernie Volz (volz)
Cc: Kim Kinnear (kkinnear); [email-masked]
Subject: Re: [dhcwg] WG Adoption Call draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18

Bernie,

Ted Lemon 		12/9/13 4:59pm

Now, my mail reader didn't gather all of these together for me easily, and I don't know why.  But I do see them in my email.  The times above are the times in my email reader (EST), for reference.

I'm not saying that we need to adopt this or not, but it seems to me that we should be counting the folks that responded.

Thanks -- Kim

---

From: Mathias Samuelson <[email-masked]>
Date: Sat, 21 Dec 2013 09:29:29 +0000

Bernie, all,

I just wanted to provide some context as for why I think that this work should be adopted.

Most of the CSP customers I work with either operate IPv4 only, or dual-stack IPv4 / IPv6 networks or is progressing in that direction. Native IPv6 and more specifically IPv6-only networks seem to be an outliner *at this point*.

What I also see is that all of our CSP customers using our DHCP server for dual-stack service use the same DHCP servers for both stacks. It would be interesting to hear if others have a different experience, but at least with the data I have the CSPs want to run DHCPv4 and DHCPv6 in the same servers.

>From that point of view alone, I think it makes a lot of sense to adopt the active leasequery work for both DHCPv4 and DHCPv6, or not at all (but I think we should do this work because there is value in having a standardized way of getting a stream of lease binding updates from the DHCP servers).

Someone who will find a use for active leasequery is likely to find a use for it for both stacks. The corollary would be that I think that doing this work for just one or the other of DHCPv4 and DHCPv6 is going to be relatively useless in reality. :-)

Taking my product management hat on, I think it would also suck to be forced into inconsistent feature sets for DHCPv4 and DHCPv6. ;-)

Mathias

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sat, 21 Dec 2013 22:54:16 +0000

Yes, I fully agree. It is also why we added the DHCPv6 capability to our servers after we did DHCPv4 and customers started using it (and as most customers are still v4 centric, the v4 capability was more important to most).

Another point is that while it certainly is extra work, it is much easier to do it again for the 2nd protocol than first time around, even with the v4/v6 differences. And, as this basically extends bulk leasequery, at least much of the packet processing / building code is already in place. And from the draft perspective, the motivation for both are the same.

Thus, the delta to the WG should be fairly small.

(And, when the DHCPv6 failover requirements draft went to the IESG, they were wondering what happened to the V4 failover work ...)

I'm certainly in favor of adopting the v4 work as well. But we need WG participation to make this a success, hence why I think the response from non-involved parties was a bit lower than I would have hoped for.

Perhaps most people don't care either way as there were no objections.

- Bernie

-----Original Message-----
From: Mathias Samuelson [mailto:[email-masked]] 
Sent: Saturday, December 21, 2013 4:29 AM
To: Bernie Volz (volz)
Cc: [email-masked]
Subject: Re: [dhcwg] WG Adoption Call draft-kinnear-dhc-dhcpv4-active-leasequery-02 - Respond by Dec 18

Bernie, all,

Mathias

---

From: Tomek Mrugalski <[email-masked]>
Date: Mon, 23 Dec 2013 12:37:26 +0100

On 04.12.2013, 17:46, Bernie Volz (volz) wrote:
> This call is being initiated to determine whether there is WG
> consensus to adopt this work as DHC WG item. Please state whether or
> not you're in favor of the adoption by replying to this mail. If you
> are not in favor, please also state your objections in your response.
> This adoption call will complete on December 18, 2013.

With my chair hat off, I do not support this work. It is not that I'm
objecting it, either. I would count my vote as abstain. Personally I
thought that having active leasequery standardized for v6 only would be
another (small) incentive to migrate to IPv6. But the reality, as
Mathias nicely described it, is that for the foreseeable future, we will
have v4-only and dual-stack networks and people who intend to deploy
active leasequery will need it for both protocols. So since the v6 draft
is moving forward and the work needed to make its v4 counterpart is
minimal, I suppose it is ok to define the same capability for both
protocols.

With my chair hat on:
As Bernie is co-author of this work, I had to assess this adoption call
on my own. There is support for doing this work, but it is somewhat
smaller than for its v6 counter-part. There were quite a few people
supporting this draft, but many of them were directly or indirectly
involved in the work. There was noone objecting that work.

I made a decision to adopt this work. The draft passed adoption call.
But I wanted to make it clear: the level of support expressed is
disappointing and it will not be sufficient to pass WGLC. If you (the
generic you, I'm addressing all WG participants here) are interested in
moving this work forward, please be more active.

Authors, please upload this draft as WG item.

Tomek