Subject: [dhcwg] Results of WGLC for draft-ietf-dhc-dhcpv4-over-dhcpv6-03 - Respond by Dec 9, 2013

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sat, 14 Dec 2013 15:10:46 +0000

This is to announce the results of the WGLC on draft-ietf-dhc-dhcpv4-over-dhcpv6-03.

There were discussions on several topics and a list of nits, so a new draft will be needed.

Our determination of the rough consensus is that this work should advance. However, as a new draft is required and as a WGLC on the related draft-ietf-dhc-v4configuration-03 is in progress, we will await an updated draft and the outcome of the WGLC on draft-ietf-dhc-v4configuration-03 before finalizing on next steps.

The authors are requested to publish an updated draft to address the points raised during the WGLC.

Given (at least) two people's concerns about this work (which are probably more directed at the conclusion of draft-ietf-dhc-v4configuration), we should remember the original issue was how to configure IPv4 stacks on IPv6 islands. The WG consensus for that was, I believe, clearly to use DHCPv4. And while draft-ietf-dhc-dhcpv4-over-dhcpv6 solves this when 'native' IPv4 communication is not possible, it is not always required - i.e., if 'native' DHCPv4 (over IPv4) is usable. So, the appropriate conclusions from both sets of work are l believe:

1.       Use DHCPv4 for IPv4 configuration.

2.       Use DHCPv4 'as is' when possible.

3.       Use draft-ietf-dhc-dhcpv4-over-dhcpv6 when DHCPv4 'as is' is not possible (i.e., no ability to get native IPv4 packets to a DHCPv4 relay or server).

-          Bernie & Tomek

---

From: Simon Perreault <[email-masked]>
Date: Mon, 16 Dec 2013 09:40:30 -0500

Le 2013-12-14 10:10, Bernie Volz (volz) a écrit :
> WGLC on the related draft-ietf-dhc-v4configuration-03 is in progress

Is this true? I can't find the announcement, and the datatracker doesn't 
show the draft as being in WGLC...

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Tomek Mrugalski <[email-masked]>
Date: Mon, 16 Dec 2013 15:57:50 +0100

> show the draft as being in WGLC...
No, that was a mistake. Bernie and I exchanged preliminary WGLC
announcement text, but due to the discussion about dhcpv4-over-dhcpv6 we
still haven't sent it out. So no - there is no WGLC on v4configuration
yet, but there likely will be in the next couple days.
It will be long enough so people who take holiday + new year vacation
will be able to get back and post their comments when they get back in
January.

Tomek