Subject: [dhcwg] WGLC for draft-ietf-dhc-addr-registration-07.txt - Respond by Sept 29, 2014

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 15 Sep 2014 13:11:44 +0000

Hi all,

This message starts the DHC working group last call to advance "Registering Self-generated IPv6 Addresses in DNS using DHCPv6", draft-ietf-dhc-addr-registration-07, document as a Standards Track RFC. The authors believe that this version is ready.

The draft is available here:
http://tools.ietf.org/html/draft-ietf-dhc-addr-registration-07

Please send your comments by September 29th, 2014. If you do not feel this document should advance, please state your reasons why.

There are no IPR claims reported at this time.

- Tomek & Bernie

-----Original Message-----
From: Sheng Jiang [mailto:[email-masked]] 
Sent: Monday, September 15, 2014 3:21 AM
To: Bernie Volz (volz); Tomek Mrugalski
Cc: [email-masked]
Subject: Ready for WGLC//FW: [dhcwg] I-D Action: draft-ietf-dhc-addr-registration-07.txt

Hi, DHC chairs,

We have just submitted a new version, which addressed all received comments, particularly thorough review from Bernie. We believe this version is ready for WGLC. Could you check it and launch WGLC if proper?

Best regards,

Sheng

>-----Original Message-----
>From: dhcwg [mailto:[email-masked]] On Behalf Of 
>[email-masked]
>Sent: Friday, September 12, 2014 11:20 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [dhcwg] I-D Action: draft-ietf-dhc-addr-registration-07.txt
>
>
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Dynamic Host Configuration Working 
>Group of the IETF.
>
>        Title           : Registering Self-generated IPv6 Addresses in
>DNS using DHCPv6
>        Authors         : Sheng Jiang
>                          Gang Chen
>                          Suresh Krishnan
>                          Rajiv Asati
>	Filename        : draft-ietf-dhc-addr-registration-07.txt
>	Pages           : 10
>	Date            : 2014-09-11
>
>Abstract:
>   In networks that are centrally managed, self-generated addresses
>   cause some traceability issues due to their decentralized nature.
>   One of the most important issues in this regard is the inability to
>   register such addresses in DNS.  This document defines a mechanism to
>   register self-generated and statically configured addresses in DNS
>   through a DHCPv6 server.
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-ietf-dhc-addr-registration/
>
>There's also a htmlized version available at:
>http://tools.ietf.org/html/draft-ietf-dhc-addr-registration-07
>
>A diff from the previous version is available at:
>http://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-addr-registration-07
>
>
>Please note that it may take a couple of minutes from the time of 
>submission until the htmlized version and diff are available at tools.ietf.org.
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>dhcwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Qi Sun <[email-masked]>
Date: Wed, 17 Sep 2014 11:43:00 +0800

Dear all, 

I support this document to move forward. 

Some comments below:
1) Section 3

   After successfully assigning a self-generated IPv6 address on one of
   its interfaces, an end-host implementing this specification SHOULD
   send an ADDR-REGISTRATION-REQUEST message to a DHCPv6 address
   registration server.
What is a ‘DHCPv6 address registration server’? Is it a DHCPv6 server or an address registration server? It was mentioned in the previous section as a 'DHCPv6 (address registration) server’. I think consistence should be maintained.

2) Sec 4
   The DHCPv6 client sends an ADDR-REGISTRATION-REQUEST message to a
   server to request an address to be registered in the DNS. 
This sentence reads odd because the client is requesting to register an address, rather than requesting an address. How about:
   The DHCPv6 client sends an ADDR-REGISTRATION-REQUEST message to a
   server to request the registration of an address in the DNS. 

Hope that helps.

Best Regards,
Qi

---

From: "Zhangdacheng (Dacheng)" <[email-masked]>
Date: Thu, 18 Sep 2014 02:21:31 +0000

I support the adoption of this document.

Cheers

Dacheng

From: dhcwg [mailto:[email-masked]] On Behalf Of Qi Sun
Sent: Wednesday, September 17, 2014 11:43 AM
To: [email-masked]
Cc: Bernie Volz (volz)
Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-addr-registration-07.txt - Respond by Sept 29, 2014

Dear all,

Some comments below:
1) Section 3

   registration server.
What is a 'DHCPv6 address registration server'? Is it a DHCPv6 server or an address registration server? It was mentioned in the previous section as a 'DHCPv6 (address registration) server'. I think consistence should be maintained.

2) Sec 4

Hope that helps.

Best Regards,
Qi

On Sep 15, 2014, at 9:11 PM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

- Tomek & Bernie

-----Original Message-----
From: Sheng Jiang [mailto:[email-masked]]
Sent: Monday, September 15, 2014 3:21 AM
To: Bernie Volz (volz); Tomek Mrugalski
Cc: [email-masked]<mailto:[email-masked]>
Subject: Ready for WGLC//FW: [dhcwg] I-D Action: draft-ietf-dhc-addr-registration-07.txt

Hi, DHC chairs,

Best regards,

Sheng

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of
[email-masked]<mailto:[email-masked]>
Sent: Friday, September 12, 2014 11:20 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [dhcwg] I-D Action: draft-ietf-dhc-addr-registration-07.txt

Abstract:

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg
_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Zhangdacheng (Dacheng)" <[email-masked]>
Date: Thu, 18 Sep 2014 03:09:56 +0000

I just realized that I replied to a wrong email. Actually, I was trying to show my support to [dhcwg] WG Adoption Call - draft-gont-dhc-stable-privacy-addresses-01

Extremely sorry for my negligence.

BR

Dacheng

From: dhcwg [mailto:[email-masked]] On Behalf Of Zhangdacheng (Dacheng)
Sent: Thursday, September 18, 2014 10:22 AM
To: [email-masked]
Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-addr-registration-07.txt - Respond by Sept 29, 2014

Cheers

Dacheng

From: dhcwg [mailto:[email-masked]] On Behalf Of Qi Sun
Sent: Wednesday, September 17, 2014 11:43 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Bernie Volz (volz)
Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-addr-registration-07.txt - Respond by Sept 29, 2014

Dear all,

Some comments below:
1) Section 3

   registration server.

2) Sec 4

Hope that helps.

Best Regards,
Qi

Hi all,

- Tomek & Bernie

-----Original Message-----
From: Sheng Jiang [mailto:[email-masked]]
Sent: Monday, September 15, 2014 3:21 AM
To: Bernie Volz (volz); Tomek Mrugalski
Cc: [email-masked]<mailto:[email-masked]>
Subject: Ready for WGLC//FW: [dhcwg] I-D Action: draft-ietf-dhc-addr-registration-07.txt

Hi, DHC chairs,

Best regards,

Sheng

-----Original Message-----

Abstract:

---

From: "Liubing (Leo)" <[email-masked]>
Date: Mon, 22 Sep 2014 08:54:20 +0000

Hi all,

I support the publication of the draft.

This draft had been discussed for a long time in the WG. And finally the use case of DNS registration reached consensus. I also think it is a solid use case.

I only have a general comment:
Currently, the title and the solution description are binding to the DNS registration use case. However, I think the DHCPv6 address registration messages are actually natural to any use cases. If in the future we identify new use cases besides DNS registration, the address registration messages would be still valid. If my understanding is correctly, maybe the draft needs to explicitly state this?

Best regards,
Bing

> From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz
> (volz)
> Sent: Monday, September 15, 2014 9:12 PM
> To: [email-masked]
> Subject: [dhcwg] WGLC for draft-ietf-dhc-addr-registration-07.txt - Respond
> by Sept 29, 2014
> 
> Hi all,
> 
> This message starts the DHC working group last call to advance "Registering
> Self-generated IPv6 Addresses in DNS using DHCPv6",
> draft-ietf-dhc-addr-registration-07, document as a Standards Track RFC. The
> authors believe that this version is ready.
> 
> Please send your comments by September 29th, 2014. If you do not feel this
> document should advance, please state your reasons why.
> 
> We have just submitted a new version, which addressed all received
> comments, particularly thorough review from Bernie. We believe this version
> is ready for WGLC. Could you check it and launch WGLC if proper?
> 
> Best regards,
> 
> Sheng
>

---

From: "Zhangdacheng (Dacheng)" <[email-masked]>
Date: Wed, 24 Sep 2014 02:18:59 +0000

Hi all,

I spent some time on reading this document and would like to support to forward this draft for publication.

This draft proposes a solution which meets the requirements for domain name management. The deployment scenarios is a reasonable extension from the current IP address model in many networks.

Best regards,

Dacheng

Cheers

Dacheng

Dear all,

Some comments below:
1) Section 3

   registration server.

2) Sec 4

Hope that helps.

Best Regards,
Qi

Hi all,

- Tomek & Bernie

-----Original Message-----
From: Sheng Jiang [mailto:[email-masked]]
Sent: Monday, September 15, 2014 3:21 AM
To: Bernie Volz (volz); Tomek Mrugalski
Cc: [email-masked]<mailto:[email-masked]>
Subject: Ready for WGLC//FW: [dhcwg] I-D Action: draft-ietf-dhc-addr-registration-07.txt

Hi, DHC chairs,

Best regards,

Sheng

-----Original Message-----

Abstract:

---

From: "Guangqing Deng" <[email-masked]>
Date: Thu, 25 Sep 2014 22:49:38 +0800

Hi all, I think it is time to move forward this draft to publication. While I suggest expanding FQDN into "Fully Qualified Domain Name" at the first use, though there are some references (RFC 4703, 4704) listed.

Guangqing Deng
CNNIC 
 
From: Zhangdacheng (Dacheng)
Date: 2014-09-24 10:18
To: [email-masked]
Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-addr-registration-07.txt - Respond by Sept 29, 2014
Hi all,

 
Best regards,
 
Dacheng

 
Cheers
 
Dacheng

Dear all, 

Some comments below:
1) Section 3
 
   After successfully assigning a self-generated IPv6 address on one of   its interfaces, an end-host implementing this specification SHOULD   send an ADDR-REGISTRATION-REQUEST message to a DHCPv6 address   registration server.
What is a ‘DHCPv6 address registration server’? Is it a DHCPv6 server or an address registration server? It was mentioned in the previous section as a 'DHCPv6 (address registration) server’. I think consistence should be maintained.
 
2) Sec 4
   The DHCPv6 client sends an ADDR-REGISTRATION-REQUEST message to a   server to request an address to be registered in the DNS. 
This sentence reads odd because the client is requesting to register an address, rather than requesting an address. How about:
   The DHCPv6 client sends an ADDR-REGISTRATION-REQUEST message to a   server to request the registration of an address in the DNS. 
 
Hope that helps.
 
Best Regards,
Qi

Hi all,

- Tomek & Bernie

-----Original Message-----
From: Sheng Jiang [mailto:[email-masked]] 
Sent: Monday, September 15, 2014 3:21 AM
To: Bernie Volz (volz); Tomek Mrugalski
Cc: [email-masked]
Subject: Ready for WGLC//FW: [dhcwg] I-D Action: draft-ietf-dhc-addr-registration-07.txt

Hi, DHC chairs,

Best regards,

Sheng

-----Original Message-----

Abstract: