Subject: [dhcwg] RFC3315 and Hop Limit

From: Michael Richardson <[email-masked]>
Date: Tue, 21 Oct 2014 17:53:54 -0400

I could not find any advice in RFC3315 as to what to set the IPv6
HOP Limit to for multicast'ed DHCPv6 messages.

I would have thought that the sender should set it to 255, and the
sender should validate that it is 255, to be sure that it's onlink.
This is what mDNS/Bonjour does, but maybe 3315 predates that thinking.

Should 3315bis say something different?
(Clearly, it has to be backwards compatible for awhile)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Ralph Droms <[email-masked]>
Date: Tue, 21 Oct 2014 18:31:04 -0400

> This is what mDNS/Bonjour does, but maybe 3315 predates that thinking.

I don't think the 255 hop count limit from RFC 6762 applies.  RFC 6762 mentions the use of the 255 hop count limit, but only for backward compatibility.  RFC 6762 does not mandate the use of the 255 hop count limit as a mandatory requirement of mDNS.  I read RFC 6762 to specify that mDNS depends on the network infrastructure for limiting the distance of over which datagrams with a link-scope multicast address are forwarded.

DHCPv6 uses a link-scope multicast address for All_DHCP_Relay_Agents and a site-scope multicast address for All_DHCP_Servers.  In my opinion, it is fine for DHCPv6 to trust the network infrastructure to limit the forwarding of datagrams sent to both of those multicast addresses.

- Ralph

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Michael Richardson <[email-masked]>
Date: Wed, 22 Oct 2014 12:43:10 -0400

Ralph Droms <[email-masked]> wrote:
    >> I could not find any advice in RFC3315 as to what to set the IPv6 HOP
    >> Limit to for multicast'ed DHCPv6 messages.
    >>

    > I don't think the 255 hop count limit from RFC 6762 applies.  RFC 6762
    > mentions the use of the 255 hop count limit, but only for backward
    > compatibility.  RFC 6762 does not mandate the use of the 255 hop count

Ah, I know that we argued back and forth about whether or not HOP Limit=1,
or HOP Limit=255 was a better way to keep things link-local, and I was
surprised upon examining 3315 that there was no talk at all about that,
then I realized that it predated that discussion.

I'd always figured that if someone was going to screw up routing so much,
as to wind up forwarding multicast is if it was unicast, that they likely
also didn't decrement the TTL either....