Subject: Re: [dhcwg] WG Adoption Call - draft-jiang-dhc-dhcp-privacy & draft-krishnan-dhc-dhcpv6-privacy

From: "Leaf Yeh" <[email-masked]>
Date: Thu, 5 Feb 2015 18:39:46 +0800

Bernie - I believe these would be Informational as they will not propose
anything to implement. … Other drafts being worked on will document how one
might mitigate some or all of these privacy concerns.

I‘ve read draft-krishnan-dhc-dhcpv6-privacy. Have we got any output on the
requirement for the DHCPv6 client implementation? Do we believe the DUID of
DHCPv6 client (or even IAID) should not be a permanent ‘stable’
identifier? and they should have no relation with the MAC address of the
client?

Best Regards,

Leaf

From: Bernie Volz (volz) [mailto:[email-masked]] 
Sent: Friday, January 23, 2015 12:52 PM
To: Leaf Yeh; [email-masked]
Subject: RE: [dhcwg] WG Adoption Call - draft-jiang-dhc-dhcp-privacy &
draft-krishnan-dhc-dhcpv6-privacy

I believe these would be Informational as they will not propose anything to
implement.

They presently are specified as being Standards Track – we would probably
want to make sure they are adopted as Informational.

Other drafts being worked on will document how one might mitigate some or
all of these privacy concerns.

-          Bernie

From: Leaf Yeh [mailto:[email-masked]] 
Sent: Thursday, January 22, 2015 11:43 PM
To: Bernie Volz (volz); [email-masked]
Subject: RE: [dhcwg] WG Adoption Call - draft-jiang-dhc-dhcp-privacy &
draft-krishnan-dhc-dhcpv6-privacy

Q: Will these 2 drafts be put into standard track?

Best Regards,

Leaf

From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Friday, January 23, 2015 2:38 AM
To: [email-masked]
Subject: [dhcwg] WG Adoption Call - draft-jiang-dhc-dhcp-privacy &
draft-krishnan-dhc-dhcpv6-privacy

Hello:

During the Honolulu IETF-91 meeting, there was consensus to adopt the
following documents as working group items:

draft-jiang-dhc-dhcp-privacy-00  Privacy considerations for DHCP

draft-krishnan-dhc-dhcpv6-privacy-00      Privacy considerations for DHCPv6

If you do NOT favor the adoption of one or both, please reply to this mail
and also state your objections. This adoption call will end on Feb 4, 2015,
and unless we hear objections, these documents will be adopted.

You may also indicate your support for adopting them, but because of the WG
meeting consensus, this is not necessary.

The HTML version of the documents can be viewed at
http://tools.ietf.org/html/draft-jiang-dhc-dhcp-privacy-00 and http://tools.
ietf.org/html/draft-krishnan-dhc-dhcpv6-privacy-00.

Thanks!

- Tomek & Bernie

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 5 Feb 2015 12:03:04 +0000

Yes, these documents will most likely end up as informational - this can be fixed when published as wg docs.

- Bernie (from iPad)

On Feb 5, 2015, at 5:39 AM, Leaf Yeh <[email-masked]<mailto:[email-masked]>> wrote:

Bernie - I believe these would be Informational as they will not propose anything to implement. … Other drafts being worked on will document how one might mitigate some or all of these privacy concerns.

I‘ve read draft-krishnan-dhc-dhcpv6-privacy. Have we got any output on the requirement for the DHCPv6 client implementation? Do we believe the DUID of DHCPv6 client (or even IAID) should not be a permanent ‘stable’ identifier? and they should have no relation with the MAC address of the client?

Best Regards,
Leaf

From: Bernie Volz (volz) [mailto:[email-masked]]
Sent: Friday, January 23, 2015 12:52 PM
To: Leaf Yeh; [email-masked]<mailto:[email-masked]>
Subject: RE: [dhcwg] WG Adoption Call - draft-jiang-dhc-dhcp-privacy & draft-krishnan-dhc-dhcpv6-privacy

I believe these would be Informational as they will not propose anything to implement.

They presently are specified as being Standards Track – we would probably want to make sure they are adopted as Informational.

Other drafts being worked on will document how one might mitigate some or all of these privacy concerns.

-          Bernie

From: Leaf Yeh [mailto:[email-masked]]
Sent: Thursday, January 22, 2015 11:43 PM
To: Bernie Volz (volz); [email-masked]<mailto:[email-masked]>
Subject: RE: [dhcwg] WG Adoption Call - draft-jiang-dhc-dhcp-privacy & draft-krishnan-dhc-dhcpv6-privacy

Best Regards,
Leaf

From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Friday, January 23, 2015 2:38 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [dhcwg] WG Adoption Call - draft-jiang-dhc-dhcp-privacy & draft-krishnan-dhc-dhcpv6-privacy

Hello:

During the Honolulu IETF-91 meeting, there was consensus to adopt the following documents as working group items:

If you do NOT favor the adoption of one or both, please reply to this mail and also state your objections. This adoption call will end on Feb 4, 2015, and unless we hear objections, these documents will be adopted.

You may also indicate your support for adopting them, but because of the WG meeting consensus, this is not necessary.

The HTML version of the documents can be viewed at http://tools.ietf.org/html/draft-jiang-dhc-dhcp-privacy-00 and http://tools.ietf.org/html/draft-krishnan-dhc-dhcpv6-privacy-00.

Thanks!

- Tomek & Bernie

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 5 Feb 2015 12:18:50 +0000

Hi:

The chairs have decided there is consenus to adopt this work.

The authors are requested to publish WG versions of these documents - please also assure they are Informational and not Standards Track documents.

Thanks.

- Bernie (from iPad)

On Jan 22, 2015, at 1:37 PM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:

Hello:

Thanks!

- Tomek & Bernie