Subject: [dhcwg] DHCP hackathon in Prague?

From: Tomek Mrugalski <[email-masked]>
Date: Wed, 13 May 2015 23:06:16 +0200

IETF is about rough consensus and running code. We had a lot of the
consensus part lately, how about a bit of running code for a change? ;)

Possible DHCP hackathon in Prague was mentioned briefly during Dallas
meeting. I'd like to follow up on the idea. I'm not sure if you recall,
but there was a hackathon in Dallas. Folks who participated found it
very useful and had good results (outcome of the last one:
https://www.ietf.org/proceedings/92/slides/slides-92-iesg-opsplenary-3.pdf,
more details
https://www.ietf.org/registration/MeetingWiki/wiki/ietfhackathon)

I'd love to hear your opinion on this. The hackathon would likely take
two days (Saturday and Sunday preceding IETF). Interested people would
meet, decide on common unresolved software issues, exchange ideas, hack
the code and maybe even do a bit of interop testing!

For now, we don't have any specific topics agreed on, but the ones
mentioned so far are:

- stateful issues - the draft got IESG approval recently. It would be
good to check what sort of tweaking is required for existing
implementations.
- secure dhcpv6 - that's a challenging one. We could check whether there
are existing implementations that could support this already. If not, we
could develop a plan to extend existing code base and start writing code.
- privacy - there's a lot of going on in the DHCP privacy area. We could
work on existing implementations or even start working on a privacy
oriented client from scratch. I know of at least one DHCP library that
would make this feasible in 2 days.

Other areas could be worked on, too. For example shared v4 allocation,
dhcpv6 load balancing, stable privacy addresses or maybe YANG modules
for dhcp? Feel free to propose your own topics.

In my opinion, it would make sense to go ahead with the hackathon if
there is enough people willing to work on specific topics. So the
questions are:

1. are you willing to participate in the DHCP hackathon, i.e. travel to
Prague 2 days earlier and spend your time with fellow DHCP geeks hacking
the code?
2. what topics are of particular interest for you?
3. do you have your own implementation or a patch for existing one? If
not, that's ok, there's plenty of open source projects that could
benefit from your time and skills.

Question 3 is completely optional. If you don't want to reveal your
secret plans, that's perfectly ok. I'm merely asking to gauge which
areas are likely to have the biggest code base, so perhaps we could plan
some sort of interop testing.

If there's enough interest, Bernie and I will submit this proposal to
whoever is in charge of the hackathon planning. We'll probably organize
a wiki somewhere and move the detailed discussion off the dhc list.
(There was a separate list for '92 hackathon.)

Bernie & Tomek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 20 May 2015 14:51:46 +0000

Hi:

While difficult to know how much time I'll have before the Hackathon, I'd welcome testing around the Stateful Issues document (hopefully it will be an RFC within a few days). I'd have (or modify on-site) our Cisco Prime Network Registrar DHCP server to support various aspects so if there are some DHCPv6 clients, we could run some tests.

I'm less sure of the other suggested areas (secure DHCPv6 and Privacy). One other area to consider might be other recent RFCs, such as RFC 6977, Triggering DHCPv6 Reconfiguration from Relay Agents - but I have nothing specific to those at present.

Open to suggestions from others and willing to do what I can to support what others might want to do.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Wednesday, May 13, 2015 5:06 PM
To: dhcwg
Subject: [dhcwg] DHCP hackathon in Prague?

Bernie & Tomek

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Christian Huitema <[email-masked]>
Date: Wed, 20 May 2015 17:25:23 +0000

> While difficult to know how much time I'll have before the Hackathon, I'd
> welcome testing around the Stateful Issues document (hopefully it will be an RFC
> within a few days). I'd have (or modify on-site) our Cisco Prime Network
> Registrar DHCP server to support various aspects so if there are some DHCPv6
> clients, we could run some tests.
> 
> I'm less sure of the other suggested areas (secure DHCPv6 and Privacy). One
> other area to consider might be other recent RFCs, such as RFC 6977, Triggering
> DHCPv6 Reconfiguration from Relay Agents - but I have nothing specific to those
> at present.

My team at Microsoft should have an experimental version of DHCP privacy ready in time for Prague. Definitely not an official Windows product, probably running only on some test builds of Windows 10, but we would be happy to go into interop testing and find out potential issues.

-- Christian Huitema

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 20 May 2015 21:01:01 +0000

I am not sure that I could contribute, but I am very interested in secure DHCPv6.

Thanks - Fred
[email-masked]

> Sent: Wednesday, May 13, 2015 2:06 PM
> To: dhcwg