Subject: [dhcwg] Kathleen Moriarty's No Objection on draft-ietf-dhc-dynamic-shared-v4allocation-07: (with COMMENT)

From: "Kathleen Moriarty" <[email-masked]>
Date: Wed, 27 May 2015 16:39:31 -0700

Kathleen Moriarty has entered the following ballot position for
draft-ietf-dhc-dynamic-shared-v4allocation-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dynamic-shared-v4allocation/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have many of the same questions as Stephen, so I support his discuss
and comments.  In particular, I'd like to see text int he security
considerations about sending traffic to the wrong host and how that is
prevented as well as risks.  Stephen hits on this in his comments and I'd
like to see it addressed in the security considerations section.  Since
that's the point of the draft (multiple hosts using the same IPs), it is
a major consideration.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 27 May 2015 23:11:54 -0400

> that's the point of the draft (multiple hosts using the same IPs), it is

If you are concerned about this, the time to have objected would have been when A+P got standardized a few months ago. There is no way to address that concern in this document, which is just about configuring A+P clients. FWIW it was talked about and, I think, addressed adequately in the base specifications.

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 28 May 2015 07:42:03 -0400

Sent from my iPhone

> On May 27, 2015, at 11:11 PM, Ted Lemon <[email-masked]> wrote:
> 

Thanks, Ted.  I didn't see a reference from the Security Considerations section.  If that's all that is needed, let's add it.  I'll look at the base spec.

Thanks,
Kathleen

---

From: Ted Lemon <[email-masked]>
Date: Thu, 28 May 2015 09:48:02 -0400

> Thanks, Ted.  I didn't see a reference from the Security Considerations section.  If that's all that is needed, let's add it.  I'll look at the base spec.

I don't understand why such a reference would be useful. Will implementors of DHCP servers or clients that support this extension need to know about this in order to avoid some flaw in their implementation of this specification?  If yes, can you explain what you think might be missing?   If you can't think of an articulable gap here, I don't see any point in mentioning this.