Subject: [dhcwg] I-D Action: draft-ietf-dhc-access-network-identifier-07.txt

From: [email-masked]
Date: Thu, 21 May 2015 07:27:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Dynamic Host Configuration Working Group of the IETF.

        Title           : Access Network Identifier Option in DHCP
        Authors         : Shwetha Bhandari
                          Sri Gundavelli
                          Mark Grayson
                          Bernie Volz
                          Jouni Korhonen
	Filename        : draft-ietf-dhc-access-network-identifier-07.txt
	Pages           : 18
	Date            : 2015-05-21

Abstract:
   This document specifies the format and mechanism that is to be used
   for encoding access network identifiers in DHCPv4 and DHCPv6 messages
   by defining new access network identifier options and sub-options.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-access-network-identifier/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dhc-access-network-identifier-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-access-network-identifier-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Christian Huitema <[email-masked]>
Date: Thu, 21 May 2015 17:38:56 +0000

>    by defining new access network identifier options and sub-options.

The security considerations of this document appear to be very dependent on the usage scenario. If I understand correctly, this option is meant to be inserted by relay agents and processed by servers, without ever being sent to or from clients. Is that really true? In any case, that scenario should be spelled out early in the draft, and probably summarized in the abstract. 

It would also be nice to describe how the network identifiers are meant to be used. I believe I understand that based on the parameters provider by the server to the client can be dependent on the ANI, the classic example being a "guest" SSID and a "private" SSID advertised by the same Wi-Fi access point. But I had to read the text in section 2 (Motivation) several times to understand that.

As far as privacy is concerned, I am a bit concerned that this could allow some fancy interception techniques, deploying fake relays, MITM between relay and server, etc. If we want relays to insert sensitive information, maybe we should take a careful look at the security of the relay to server connection.

-- Christian Huitema