Subject: Re: [dhcwg] Fw:New Version Notification for draft-cui-dhc-dhcpv6-encryption-00.txt

From: 神明達哉 <[email-masked]>
Date: Fri, 10 Jul 2015 11:08:23 -0700

On Thu, Jun 4, 2015 at 5:06 AM, Lishan Li <[email-masked]> wrote:

> We have submitted a new draft about DHCPv6 Authentication and Encryption
> mechanism.
> This document discusses two possible solutions to achieve the authentication
> and encryption between DHCPv6 server and client. One solution needs to be
> selected to solve the DHCPv6 privacy problem. We are not sure which one the
> WG would prefer.
> Could you please review the draft and any comments are welcome.

I don't have a strong opinion either way, but since "Solution B" would
require a substantial change to the original protocol anyway (as
described in Section 4.4), "Solution A" seems a bit better.

Some other random thoughts:

- Especially if we use "Solution A", wouldn't it be better to use a
  symmetric key after authentication, rather than keep using
  public/private keys?  For a client that may not matter much, but for
  a busy server the performance overhead difference might be
  substantial.
- And, to this end, would it be feasible to use a separate encryption
  mechanism such as DTLS rather than introducing a built-in mechanism
  for DHCP(v6)?  (In case of DTLS we should at least consider how to
  handle multicast traffic, though).
- If (one of) the main purpose for encryption is to hide clients'
  identity, we'll probably also need to consider the identify
  disclosure via the certificate or public key.
- The draft seems to (implicitly?) assume this encryption will be used
  for stateful DHCPv6 sessions starting with a SOLICIT message.  Would
  it also be expected to be used for stateless sessions beginning with
  INFORMATION-REQUEST?

--
JINMEI, Tatuya

---

From: 神明達哉 <[email-masked]>
Date: Mon, 13 Jul 2015 09:32:12 -0700

At Mon, 13 Jul 2015 15:54:55 +0800 (CST),
"Lishan Li" <[email-masked]> wrote:

> [Lishan] I agree that the server's performance would be affected if keeping using public/private keys. But if we use symmetric key for encryption, the problem would be how to transmit the symmetric key securely.
> How about firstly we use the asymmetric key mechanism to achieve the encrypted transmission of the symmetric key, and then encrypt DHCPv6 messages with the symmetric keys.

That will be a usual practice to deal with this kind of concern.  But
I don't know if the performance concern is actually substantial or
it's just an imaginary one; it was just part of my *random* thoughts.
Some experiments may help before we even discuss this further.

> [Lishan] I have considered "DHCP over DTLS" in the initial thoughts / version. However, for the typical use case with relays, I am afraid that the relay would not recognize the 'secured' DHCP messages, so that may drop the  DTLS  messages.  Do you think this concern is valid?

Ah, okay.  I see it will be very tricky (if not unsolvable).  It would
be helpful if you include this discussion in the draft.

--
JINMEI, Tatuya