Subject: Re: [dhcwg] two comments on draft-cui-dhc-dhcpv6-prefix-length-hint-issue

From: tianxiang li <[email-masked]>
Date: Mon, 27 Jul 2015 21:11:26 +0800

Thank you for providing the comments.

For #1 I agree with Bernie and Alexandru. There are two cases when a server
cannot provide a prefix:

1.  Servers which support prefix delegation, will not include an IA_PD
option in the Advertise   message.

2. Servers which support prefix delegation but cannot provide a prefix and
the time being, will return a status code of Noaddrsavail in the IA_PD
option.

The current document does assume all the servers could support prefix
delegation. I think we could add some text in “Receipt of Advertise message
by the Client” (section 3.3&4.3) describing these cases.

For #2 Yes, the client should stop sending RAs on its other interfaces. I
think we could add this text to section 4.1 “Creation of Solicit Message by
the Client”

> On Jul 23, 2015, at 6:38 AM, Alexandru Petrescu <alexandru.petrescu at gmail.com> wrote:
>
> Hello,
>
> I just read draft-cui-dhc-dhcpv6-prefix-length-hint-issue-00.
>
> I am happy this draft exists and I have two comments.  One is more
> general question in this context, and the other a potential improvement,
> but not a request.
>
> The draft assumes the Client is a Host which may request a prefix len at
> some point, and another one maybe later.  It seems the prefix is to be
> used on the interface which has issued that Solicit.  And it seems to
> face a Server sure to be willing to deliver a prefix.
>
> 1. What is the best way to query a DHCPv6 Server to ask it whether or
> not it supports Prefix Delegation at all?
>
> 2. when this Router changes mind and requests a different prefix, maybe
> with a different length, a specification like
> draft-cui-dhc-dhcpv6-prefix-length-hint-issue could recommend to
> deprecate that prefix with specific consideration to below it, not just
> to the Server.
>
> I mean this something like this:
>
> Current text:
>> 1.Deprecate the old prefix right away by sending a Release message to
>> the server, and switch over to the new prefix.
>
> New text:
>> 1.Deprecate the old prefix right away by sending a Release message to
>> the server, and switch over to the new prefix.  And by stopping
>> sending RAs on its other interfaces with the old prefix, stop
>> propagating it in the routing protocol.
>
> Alex
>
> _______________________________________________
> dhcwg mailing list
> dhcwg at ietf.org
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 27 Jul 2015 14:55:44 +0000

Please let’s keep this document focused on the prefix length hint issue. It already is clear that this is only applicable when implementing RFC 3633.

   DHCPv6 Prefix Delegation [RFC3633<https://tools.ietf.org/html/rfc3633>] allows a client to set a hint
   value in the prefix-length field of the IA_PD option to indicate a
   preference for the size of the prefix to be delegated, but is unclear
   about how the client and server should act in different situations
   involving the prefix length hint.  This document provides a summary
   of the existing problems with the prefix length hint and guidance on
   what the client and server could do in the different situation
   involving the the prefix length hint.

I’d also like to stay away from other issues (such as sending RAs). That should already be pretty clear – it would be dumb to send RAs about a prefix which has been released or is no longer valid (valid lifetime has expired) and is not a new problem related to the hints but normal operation when prefixes change (through some configuration mechanism) and is not really related to DHCPv6 at all. If you want to work on those issues, I would recommend you consider 6man.

And again, just for correctness, NoPrefixAvail is the Status Code related to PD.

-          Bernie

From: tianxiang li [mailto:[email-masked]]
Sent: Monday, July 27, 2015 9:11 AM
To: Bernie Volz (volz); [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [dhcwg] two comments on draft-cui-dhc-dhcpv6-prefix-length-hint-issue

For #1 I agree with Bernie and Alexandru. There are two cases when a server cannot provide a prefix:

1.  Servers which support prefix delegation, will not include an IA_PD option in the Advertise   message.
2. Servers which support prefix delegation but cannot provide a prefix and the time being, will return a status code of Noaddrsavail in the IA_PD option.

The current document does assume all the servers could support prefix delegation. I think we could add some text in “Receipt of Advertise message by the Client” (section 3.3&4.3) describing these cases.

For #2 Yes, the client should stop sending RAs on its other interfaces. I think we could add this text to section 4.1 “Creation of Solicit Message by the Client”

> On Jul 23, 2015, at 6:38 AM, Alexandru Petrescu <alexandru.petrescu at gmail.com<http://gmail.com>> wrote:

> dhcwg at ietf.org<http://ietf.org>