Subject: [dhcwg] OT: Multiple IPv6 addresses and routing policies

From: Simon Hobson <[email-masked]>
Date: Mon, 28 Sep 2015 11:08:37 +0100

I know it's (mostly) off topic for this list, but I also know there are people here who will have some valuable input - particularly suggestions for an appropriate forum in which to ask. The question was prompted by a query I saw on another list I'm subscribed to, and one that'll be relevant to my situation once I get round to IPv6 enabling my second connection at work.

With IPv4 and the prevalence of NAT - it's fairly easy to make routing decisions in the router based on whatever site specific policies are in place. So it's easy to route (say) the bulk of traffic via one ISP where bandwidth is plentiful and cheap, and other (eg time/latency sensitive VoIP traffic) via another ISP with lower latency & congestion.

Without NAT, whether IPv4 (not an option for most), or particularly in IPv6 where AIUI NAT was removed from the specs - that is not an option and effectively routing decisions are now made by the end nodes through choice of source address.

So the question is really about how to manage that ? How is one supposed to indicate preferences for routes ? Short of manual configuration of individual software packages, how is one supposed to arrange for certain protocols to use one prefix while everything else uses another ? And having gone down the route of manually configuring stuff, how does one then manage failover gracefully - eg if having configured a package to use a specific prefix, how is that then supposed to react if that prefix disappears due to a network connection being down ?

I'm guessing that in pre-NAT (and pre huge routing tables) days, IPv4 would largely be managed by getting PI address allocations which would allow the routing decisions to be done at the border. But I doubt it's practical these days for every "techie home" and small business to get a PI IPv6 allocation ?

---

From: Erik Kline <[email-masked]>
Date: Mon, 28 Sep 2015 20:37:59 +0900

You might try the v6ops working group...

On 28 September 2015 at 19:08, Simon Hobson <[email-masked]> wrote:
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg