Subject: Re: [dhcwg] I-D Action: draft-boucadair-mptcp-dhc-05.txt

From: Ted Lemon <[email-masked]>
Date: Mon, 9 May 2016 13:25:18 -0400

On Mon, May 9, 2016 at 8:24 AM, <[email-masked]> wrote:

>    This document focuses on the explicit deployment scheme where the
>    identity of the MPTCP Concentrator(s) is explicitly configured on
>    connected hosts.  This document specifies DHCP (IPv4 and IPv6)
>    options to configure hosts with Multipath TCP (MPTCP) parameters.
>

It occurs to me that in principle you don't actually need (and probably
don't want the security implications of) explicit configuration of MPTCP.

Why not instead just have an intelligent gateway that is aware that its
network is multihomed.   When it sees a TCP connection come from a node on
the network that solicits MPTCP, and sees a reply back from the target
server that does not support MPTCP, it drops the SYN+ACK and redirects the
connection through an MPTCP concentrator on the provider network using both
available links.

Oh, or is that what you actually had in mind, and the DHCP option is just
to tell the edge routers how to contact the concentrator?

---

From: <[email-masked]>
Date: Thu, 12 May 2016 11:25:51 +0000

Hi Ted,

This draft specifies DHCP options to tell a CPE how to contact its MPTCP concentrator(s).

Not all TCP connections issued from the LAN side are eligible to be relayed into MPTCP connections to benefit from WAN aggregation features. Only a subset of them will be selected according to a set of policies that are provisioned to the CPE and/or the concentrator. These polices are out of scope of this draft.

Cheers,
Med

De : dhcwg [mailto:[email-masked]] De la part de Ted Lemon
Envoyé : lundi 9 mai 2016 19:25
À : [email-masked]
Objet : Re: [dhcwg] I-D Action: draft-boucadair-mptcp-dhc-05.txt

On Mon, May 9, 2016 at 8:24 AM, <[email-masked]<mailto:[email-masked]>> wrote:

It occurs to me that in principle you don't actually need (and probably don't want the security implications of) explicit configuration of MPTCP.

Why not instead just have an intelligent gateway that is aware that its network is multihomed.   When it sees a TCP connection come from a node on the network that solicits MPTCP, and sees a reply back from the target server that does not support MPTCP, it drops the SYN+ACK and redirects the connection through an MPTCP concentrator on the provider network using both available links.

Oh, or is that what you actually had in mind, and the DHCP option is just to tell the edge routers how to contact the concentrator?

---

From: Ted Lemon <[email-masked]>
Date: Thu, 12 May 2016 09:50:12 -0400

Okay, but I was really asking about the deployment model, not about which
connections would be eligible for mptcp.   I'm trying to understand how
this would actually work.   Is this something you guys have working in the
lab?

On Thu, May 12, 2016 at 7:25 AM, <[email-masked]> wrote:

> Not all TCP connections issued from the LAN side are eligible to be
> relayed into MPTCP connections to benefit from WAN aggregation features.
> Only a subset of them will be selected according to a set of policies that
> are provisioned to the CPE and/or the concentrator. These polices are out
> of scope of this draft.
>
>
>
> Cheers,
>
> Med
>
>
>
> *De :* dhcwg [mailto:[email-masked]] *De la part de* Ted Lemon
> *Envoyé :* lundi 9 mai 2016 19:25
> *À :* [email-masked]
> *Obje**t :* Re: [dhcwg] I-D Action: draft-boucadair-mptcp-dhc-05.txt
>
>
>

---

From: <[email-masked]>
Date: Fri, 13 May 2016 07:01:29 +0000

Hi Ted,

Our (target) deployment model is what is depicted here: https://www.ietf.org/proceedings/95/slides/slides-95-mptcp-1.pdf

The work is not only in the lab.

Cheers,
Med

De : Ted Lemon [mailto:[email-masked]]
Envoyé : jeudi 12 mai 2016 15:50
À : BOUCADAIR Mohamed IMT/OLN
Cc : [email-masked]
Objet : Re: [dhcwg] I-D Action: draft-boucadair-mptcp-dhc-05.txt

Okay, but I was really asking about the deployment model, not about which connections would be eligible for mptcp.   I'm trying to understand how this would actually work.   Is this something you guys have working in the lab?

On Thu, May 12, 2016 at 7:25 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ted,

Cheers,
Med

De : dhcwg [mailto:[email-masked]<mailto:[email-masked]>] De la part de Ted Lemon
Envoyé : lundi 9 mai 2016 19:25
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [dhcwg] I-D Action: draft-boucadair-mptcp-dhc-05.txt