Subject: [dhcwg] Mail regarding draft-ietf-dhc-dhcpv6-prefix-length-hint-issue

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 25 Jul 2016 12:47:51 +0000

Hi:

Here's some comments related to the draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-02 version.

Section 1:

-          "as it just help a client" -> change help to helps?

-          Same area, perhaps mention that 3315bis is dropping use of the lifetime hints?

-          Later - "handle the prefixes which lengths are different" - "handle prefixes with lengths different from the prefix-length hint"?

I wonder whether a "general solution" section should be added which says something like:

"Therefore, the recommendation to address the issues discussed in this document, is for a client that wants (at least) to have a delegated prefix of a specific prefix length to always include an IAPREFIX option with just the prefix length hint in addition to any IAPREFIX options it has included for each IA_PD in any Solicit, Request, Renew, and Rebind messages it sends. While a server is free to ignore the hint, servers that do not choose to ignore the hint should attempt to assign a prefix of at least the hint length (or shorter) if one is available. Whether a server favors the hint or avoiding a renumbering event is a matter of policy for the server."

Note that this could actually be taken as one way to interpret the original RFC 3633 text, which said:

   The requesting router may include prefixes in the IA_PDs as a hint to
   the delegating router about specific prefixes for which the
   requesting router has a preference.

This text was as part of the Solicit discussion, but perhaps it was intended to apply to subsequent transactions as well (Request, Renew, Rebind).

-          Bernie

---

From: tianxiang li <[email-masked]>
Date: Tue, 26 Jul 2016 15:59:07 +0800

Hi Bernie,

Thank you for the comments， we will update a new version of the draft very
soon.
During the ietf 96 meeting, comments were raised about changing the term
"requesting router / delegating router" to "client / server". Should we
change it in the updated version?

Cheers,
Tianxiang

2016-07-25 20:47 GMT+08:00 Bernie Volz (volz) <[email-masked]>:

> Hi:
>
>
>
> Here’s some comments related to the
> draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-02 version.
>
>
>
> Section 1:
>
> -          “as it just help a client” -> change help to helps?
>
> -          Later – “handle the prefixes which lengths are different” –
> “handle prefixes with lengths different from the prefix-length hint”?
>
>
>
> I wonder whether a “general solution” section should be added which says
> something like:
>
>
>
> “Therefore, the recommendation to address the issues discussed in this
> document, is for a client that wants (at least) to have a delegated prefix
> of a specific prefix length to always include an IAPREFIX option with just
> the prefix length hint in addition to any IAPREFIX options it has included
> for each IA_PD in any Solicit, Request, Renew, and Rebind messages it
> sends. While a server is free to ignore the hint, servers that do not
> choose to ignore the hint should attempt to assign a prefix of at least the
> hint length (or shorter) if one is available. Whether a server favors the
> hint or avoiding a renumbering event is a matter of policy for the server.”
>
>
>
> This text was as part of the Solicit discussion, but perhaps it was
> intended to apply to subsequent transactions as well (Request, Renew,
> Rebind).
>
>
>
> -          Bernie
>
>
>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 26 Jul 2016 10:14:06 +0000

Yes. We will also be doing that change in 3315bis but keep some references to older terms.

- Bernie (from iPad)

On Jul 26, 2016, at 3:59 AM, tianxiang li <[email-masked]<mailto:[email-masked]>> wrote:

Hi Bernie,

Thank you for the comments? we will update a new version of the draft very soon.
During the ietf 96 meeting, comments were raised about changing the term "requesting router / delegating router" to "client / server". Should we change it in the updated version?

Cheers,
Tianxiang

2016-07-25 20:47 GMT+08:00 Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>>:
Hi:

Section 1:

-          Bernie