Subject: Re: [dhcwg] WGLC on draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-03 - Respond by 10/10/2016

From: yogendra pal <[email-masked]>
Date: Sun, 2 Oct 2016 00:05:44 +0530

I support moving this document forward. As we're implementer of PD in our
product, I see value in clear guidance from this document.

Thanks,
Yogendra Pal

On Wed, Sep 28, 2016 at 9:04 AM, tianxiang li <[email-masked]> wrote:

> Being one of the co-authors of this document, I support advancing this
> document.
>
> The prefix-length hint issues draft clarifies the client and server
> behavior regarding the DHCPv6 prefix-length hint, which was not specified
> in any previous documents, and it meets the actual need of  some operators.
> The draft has been presented several times in the previous IETF meetings,
> and has received a substantial number of reviews and comments. We'd like to
> thank all the people who helped out with this draft and provided their
> valuable comments. We've resolved most issues regarding the prefix-length
> hint and we believe that the document is ready to move forward.
>
> Thank you,
> Tianxiang
>
> 2016-09-27 10:34 GMT+08:00 Bernie Volz (volz) <[email-masked]>:
>
>> Hi all,
>>
>>
>>
>> This message starts the DHC Working Group Last Call to advance
>> draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-03, DHCPv6 Prefix Length
>> Hint Issues. This document¹s intended status is Proposed Standard. At
>> present, there is no IPR file against this document.
>>
>>
>>
>> Please send your comments by October 10, 2016. If you do not feel this
>>  document should advance, please state your reasons why.
>>
>>
>>
>> Bernie Volz is the assigned shepherd.
>>
>>
>>
>> - Tomek & Bernie
>>
>>
>>
>> _______________________________________________
>> dhcwg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dhcwg
>>
>>
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>
>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 2 Oct 2016 22:23:15 +0000

Hi:

(WG chair hat off)

I do support this document moving forward. I believe this document is ready to forward on.

There are a few nits in the document:

1.       "for a explicit address" should be "for an explicit address" (Section 1).

2.       Persistant is misspelled (persistent). Section 3.1.

3.       Indiction is misspelled (indication). Section 3.1.

4.       Avaiable is misspelled (available). Section 3.1.

5.       Solicted is misspelled (Solicted). Section 3.3. This probably also should be lower case? Or reword: "If the client sent a Solicit with only IA_PDs" ... That might be best? Note that the last paragraph as a similar issue with use of Solicited (though spelled correctly there).

6.       Best to capitalize "Servers" - first word of problem statement for Section 3.4.

7.       "it's lifetime expires" in Section 3.5 should be "its lifetime expires".

8.       And, we might as well also fix the two places spaces are missing:

a.       In Section 1: Prefix Option(IAPREFIX option),

b.      In Section 3.5: bindings(e.g. a

I do think while this document should be published on its own, we should plan to update draft-ietf-dhc-rfc3315bis with just the section 3.6, General Recommendation. Currently, this means adding text to 17.1.2 (Request Messages) as this does not mention the prefix length hint. 17.1.1 (Solicit) and 17.1.4 (Renew) do mention it. (17.1.5 (Rebind) references 17.1.4 (Renew) so doesn't need it explicitly). We might also update 17.2.1 (Receipt of Solicit), though 17.2.9 (Advertise) does, 17.2.2 (Receipt of Request) and 17.2.5 (Receipt of Rebind) to mention the prefix length hint (17.2.4, Receipt of Renew) - or figure out another way to handle it for Reply's. And, perhaps 20.22 (IAPREFIX option) should mention that the client SHOULD include this option in each Solicit, Request, Renew, or Rebind it sends if it chooses to make use of sending a prefix length hint. So that text which is now (in the -05):
   A requesting router may set the IPv6 prefix field to zero and a given
   value in the prefix-length field to indicate a preference for the
   size of the prefix to be delegated.
Would be:

   A requesting router may set the IPv6 prefix field to zero and a given

   value in the prefix-length field to indicate a preference for the

   size of the prefix to be delegated. The requesting router SHOULD send

   this prefix-length hint in any Solicit, Request, Renew, or Rebind

   that it sends.

Anyway, we can deal with that later as per https://trac.tools.ietf.org/group/dhcpv6bis/ticket/114.

-          Bernie

From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Monday, September 26, 2016 10:34 PM
To: [email-masked]
Subject: [dhcwg] WGLC on draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-03 - Respond by 10/10/2016

Hi all,

This message starts the DHC Working Group Last Call to advance draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-03, DHCPv6 Prefix Length Hint Issues. This document¹s intended status is Proposed Standard. At present, there is no IPR file against this document.

Please send your comments by October 10, 2016. If you do not feel this  document should advance, please state your reasons why.

- Tomek & Bernie

---

From: Linhui Sun <[email-masked]>
Date: Sat, 8 Oct 2016 15:58:18 +0800

As one of the reviewers, I support moving this draft forward.

Best,
Linhui

---

From: Marcin Siodelski <[email-masked]>
Date: Tue, 11 Oct 2016 09:50:47 +0200

I am sorry I am a bit late with this.... I support this document move
forward.

Marcin