Subject: [dhcwg] Adoption call for draft-shen-dhc-client-port-03 - Respond by October 24, 2016

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 7 Oct 2016 14:44:48 +0000

Hi:

This message initiates a two week long WG adoption call (respond by Oct 24, 2016) on:

Title: Generalized Source UDP Port of DHCP Relay

Pages: 7

Date: 2016-08-19

Document: draft-shen-dhc-client-port-03

Link: https://tools.ietf.org/html/draft-shen-dhc-client-port-03

This was presented at the Berlin IETF-96 (see https://www.ietf.org/proceedings/96/slides/slides-96-dhc-3.pdf). The hum after the presentation for adoption was soft for adoption, and silent against.

Substantive comments and statements of support for adopting this document should be directed to the mailing list. Minor editorial suggestions can be sent to the authors. The co-chairs will determine the consensus after October 24, 2016.

-          Tomek & Bernie

---

From: "Naiming Shen (naiming)" <[email-masked]>
Date: Sat, 8 Oct 2016 20:56:13 +0000

Support the adoption as a co-author.

We have encountered this issue in scalable wireless controllers.

This dhc draft/extension is better than the other approaches:
 (1) have a front-end process to cache and remember the
     dhcp client information, when the return message
     comes back from the DHCP/DHCPv6 server, will
     do the match and dispatch the message to the correct process.
     This sort of defeats the purpose of using multi-processes
 (2) each relay process uses a different IP addresses.
     it's probably fine for IPv6 addresses, but for
     IPv4, that's not a good solution. And this also
     puts the restriction on the relay to server domain
     has to be a private IP address domain.
     Besides, the multiple IP addresses increases the
     operational management and provisioning, and the
     mechanism can be prone to user errors.

and it’s optional for dhcp relay.

thanks.
- Naiming

On Oct 7, 2016, at 7:44 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:

Hi:

-          Tomek & Bernie

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Naiming Shen (naiming)" <[email-masked]>
Date: Mon, 10 Oct 2016 22:29:53 +0000

Kishore,

We have mentioned in the security considerations, that firewall
rules may need to be modified not to match both sides DHCP
port numbers. Any suggestions from your engineering team
will be good.

- Naiming

On Oct 10, 2016, at 3:08 PM, Kishore Seshadri <[email-masked]<mailto:[email-masked]>> wrote:

Naiming
Makes sense to me. Don't see why anyone would object and why - are the objections from a security/acl concern?

I've talked to the engineering team here and will let you know in the next day or two.

Kishore

On Sat, Oct 8, 2016 at 1:56 PM, Naiming Shen (naiming) <[email-masked]<mailto:[email-masked]>> wrote:

thanks.
- Naiming

Hi:

-          Tomek & Bernie

--
---------------------------------------------------
Kishore Seshadri
[email-masked]<mailto:[email-masked]>

---

From: "Peter Arberg" <[email-masked]>
Date: Tue, 11 Oct 2016 10:38:01 +0200

I support this document moving forward.

thanks,

Peter

On Oct 7, 2016, at 7:44 AM, Bernie Volz (volz) < <mailto:[email-masked]> [email-masked]> wrote:

Hi:

Pages: 7

Date: 2016-08-19

Link:  <https://tools.ietf.org/html/draft-shen-dhc-client-port-03> https://tools.ietf.org/html/draft-shen-dhc-client-port-03

This was presented at the Berlin IETF-96 (see  <https://www.ietf.org/proceedings/96/slides/slides-96-dhc-3.pdf> https://www.ietf.org/proceedings/96/slides/slides-96-dhc-3.pdf). The hum after the presentation for adoption was soft for adoption, and silent against.

-          Tomek & Bernie

_______________________________________________
dhcwg mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/dhcwg> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Oct 2016 13:24:29 -0400

I support adoption.   There are some issues with the way it updates
2131 and 3315; I don't think that's the right approach.   But that's a
minor issue; otherwise the work appears to be worth doing, and the
document is generally solid.

On Tue, Oct 11, 2016 at 4:38 AM, Peter Arberg <[email-masked]> wrote:
> On Oct 7, 2016, at 7:44 AM, Bernie Volz (volz) <[email-masked]> wrote:
>
>
>
> Hi:
>
>
>
> This was presented at the Berlin IETF-96 (see
> https://www.ietf.org/proceedings/96/slides/slides-96-dhc-3.pdf). The hum
> after the presentation for adoption was soft for adoption, and silent
> against.
>
>
>
> Substantive comments and statements of support for adopting this document
> should be directed to the mailing list. Minor editorial suggestions can be
> sent to the authors. The co-chairs will determine the consensus after
> October 24, 2016.
>
>
>
> -          Tomek & Bernie
>
>
>
> [email-masked]
> [email-masked]

---

From: "Naiming Shen (naiming)" <[email-masked]>
Date: Tue, 11 Oct 2016 18:29:32 +0000

Hi Ted,

It will be good if you can suggest some text to modify the current
wording for the next version.

thanks.
- Naiming

> On Oct 11, 2016, at 10:24 AM, Ted Lemon <[email-masked]> wrote:
>

---

From: Enke Chen <[email-masked]>
Date: Fri, 14 Oct 2016 15:38:58 -0700

Yes, support as a co-author. The draft is useful in certain scaling applications.

Thanks.  -- Enke

On 10/14/16 3:21 PM, Naiming Shen (naiming) wrote:
> 
> 
> 
> *From: *"Bernie Volz (volz)" <[email-masked] <mailto:[email-masked]>>
> *Subject: **[dhcwg] Adoption call for draft-shen-dhc-client-port-03 - Respond by October 24, 2016*
> *Date: *October 7, 2016 at 7:44:48 AM PDT
> *To: *"[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> 
> Hi:
>  
> [email-masked] <mailto:[email-masked]>