Subject: [dhcwg] URIs for backend storage

From: Tony Finch <[email-masked]>
Date: Mon, 19 Mar 2018 22:39:15 +0000

One of the questions that arose in the DHC WG meeting this afternoon was
about a standard YANG netconf way to describe backend storage for leases.
IIRC, someone asked if a URL would be enough and the general response was
um, maybe?

There is a de-facto quasi-standard for database connection URLs used by
JDBC - pretty much all SQL databases and some noSQL databases (including
Cassandra) have a spec for describing connection details in a URL,
including when there are multiple possible servers.

Of course, instead of a JDBC URL, you could also configure your DHCP
server with a file: URL for old school lease storage.

I found out about this from PostgreSQL -
https://www.postgresql.org/docs/current/static/libpq-connect.html#LIBPQ-CONNSTRING

I haven't found a good description of C* JDBC URLs other than
https://stackoverflow.com/questions/30743272/what-is-the-connection-url-to-be-used-for-cassandra#30795079
which suggests that they use `--` for separating hostnames (which from
my pedantic hostmaster point of view is mildly problematic...!)

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/  -  I xn--zr8h punycode
Sole, Lundy, Fastnet: Northeast 5 to 7, becoming variable 3 or 4. Moderate or
rough. Mainly fair. Good.

---

From: [email-masked]
Date: Tue, 20 Mar 2018 14:18:11 +0000

Hi Tony,

Thanks for the input. In some previous drafts I’ve worked on, the URI has proved to be problematic in that there are some protocol URI’s that are conspicuous by their absence (SSH?).

However, in this case, I don’t expect it to be a problem if de-facto URIs are well enough implemented. The URI leaf would be purely a place to store this information and wouldn’t place any additional requirements that specific (standard) URI formats are supported.

If there’s no objections, we’ll add this into the next update.

Thanks,
Ian

> On 19. Mar 2018, at 22:39, Tony Finch <[email-masked]> wrote:
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg