Subject: Re: [dhcwg] Some questions regarding draft-bvtm-dhc-mac-assign-00

From: 何林 <[email-masked]>
Date: Sun, 15 Apr 2018 15:52:13 +0800

Hi:

Few notes inline (LH>) below.

2018-03-06 6:57 GMT+08:00 Tomek Mrugalski <[email-masked]>:

> Hi,
>
> Thanks to Bernie for pushing forward, editing and uploading the draft.
>
> This is an initial proposal for a new mechanism in DHCPv6. It looks a
> bit odd at first (why would a device request MAC address if it's able to
> transmit DHCPv6 packets already), but there are at least two scenarios
> where this is justified.
>
> I'd like to encourage people to read the draft. It short - 4 pages of
> the actual proposal text (or 7 if you count option format sections).
>
> There are couple questions we'd like to hear your comments on:
>
> 1. Does it make sense to reuse DHCPv6 mechanisms to solve this problem?
> Several current and former IESG members think so, but we'd like to hear
> your opinion on this.
>
> ​LH> Make sense.

> 2. Would such a topic be interesting to the WG?
>
> ​LH> Yes,
​I think it's an interesting topic
.

3. Do we want to allow or even mandate Reconfigure here? One of the
> objections raised to DHCPv6 protocol in general was that it's not always
> possible to change the configuration at moment's notice.
>
> 4. We haven't really figured out whether it would be better to have
> always one LLADDR per IA_LL or one or more? Arguments can be made both
> ways. We're eager to hear what's the preference here.
>
> ​LH> I think it's better to allow any number of LLADDR per IA_LL. Firstly,
this provides flexibility and allows clients to request different types of
link-layer addresses just in one Solicit message (Although I don't know
whether such scenarios exist). Secondly, one LLADDR per IA_LL can be just
considered as a special case.

> On a related note, we organized the repo for this work here:
> https://github.com/dhcwg/dhcp-mac. Feel free to comment on existing
> issues or open new ones. Keep the discussion on dhcwg list, though.
>
> Thanks,
>
> Bernie & Tomek
>
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>

-- 

    Yours Sincerely,

*   Lin He*

---

From: 何林 <[email-masked]>
Date: Mon, 16 Apr 2018 17:54:09 +0800

Another question: should we consider solutions for IPv4-only hypervisors
and LoT devices?

-- 

    Yours Sincerely,

*   Lin He*

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 17 Apr 2018 02:19:40 +0000

IPv4, what’s that?

But, seriously, IPv6 link-local is all that is needed if the DHCPv6 server is on the local link and that really isn’t a high bar? Yes, if you need relays you need them to be able to communicate to the servers over IPv6.

My feeling is that we probably don’t want to consider it. But it may be something to consider later when this work is further along, perhaps using DHCPv6 over v4?

Also, IEEE is looking at protocols to do this (that would probably use direct Ethernet layer packets and not IP) and so maybe those environments could use that?

-          Bernie

From: dhcwg <[email-masked]> On Behalf Of ??
Sent: Monday, April 16, 2018 5:54 AM
To: Tomek Mrugalski <[email-masked]>
Cc: dhcwg <[email-masked]>
Subject: Re: [dhcwg] Some questions regarding draft-bvtm-dhc-mac-assign-00

Another question: should we consider solutions for IPv4-only hypervisors and LoT devices?

2018-03-06 6:57 GMT+08:00 Tomek Mrugalski <[email-masked]<mailto:[email-masked]>>:
Hi,

Thanks,

Bernie & Tomek

_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

--

    Yours Sincerely,

   Lin He