Subject: Re: [dhcwg] Request for adoption of draft-fkhp-dhc-dhcpv6-pd-relay-requirements

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 1 Oct 2019 12:35:13 +0200

Le 01/10/2019 à 05:37, Naveen Kottapalli a écrit :
> The document started with problem statement and how it can be addressed. 
> The approach we to address the problem is by defining the requirements 
> of the node that are to be handled.

In this case, it should have Intended Status: INFORMATIONAL. (not Stds 
Track), I think.

Alex

> 
> On Mon, 30 Sep 2019, 18:25 Alexandre Petrescu, 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Is this a requirements draft, a problem statement draft or a
>     solution draft?
> 
>     The filename has 'requirements' in it, but there are two sections:
>     'Problems Observed' and 'Requirements'.  The former makes for a Problem
>     Statement draft.
> 
>     Its Intended Status is 'Standards Track'.  But typical Requirement and
>     Problem Statement drafts are intended as INFORMATIONAL.
> 
>     Alex
> 
>     Le 26/09/2019 à 09:42, Alexandre Petrescu a écrit :
>      > Hi,
>      >
>      > If the question on whether or not adoption is supported, then my
>     answer
>      > is yes, I support adoption.
>      >
>      > If the question is to receive feedback of the draft, then my
>     answer is
>      > this: I support requirement R-1 'relay MUST maintain a local routing
>      > table dynamically updated with prefixes and next hops as they [the
>      > prefixes] are delegated to clients'.
>      >
>      > Alex
>      >
>      > Le 26/09/2019 à 08:58, Naveen Kottapalli a écrit :
>      >> Hello DHC WG,
>      >>
>      >> We would like to request for the adoption of our draft
>      >> draft-fkhp-dhc-dhcpv6-pd-relay-requirements
>      >>
>     <https://datatracker.ietf.org/doc/html/draft-fkhp-dhc-dhcpv6-pd-relay-requirements> that
> 
>      >> was submitted in June-2019.  As a background, please find the
>     details
>      >> of draft below.
>      >>
>      >> The draft addresses the below problems by defining the
>     requirements of
>      >> a DHCPv6 Relay agent when relaying the delegated prefixes.
>      >>
>      >> 1.  Client / Relay / Server goes out of sync resulting in route
>      >> mismanagement which in turn results in traffic issues.
>      >> 2.  Relay rejects client messages due to unknown or stale prefix.
>      >> 3.  Relay generates messages ‘on behalf’ of the server
>      >> 4.  Issues observed when more than 1 prefix is delegated to clients
>      >>
>      >> We would like to hear feedback from the forum on the draft and
>     will be
>      >> happy to address the issues in draft (if any).
>      >>
>      >> Yours,
>      >> Naveen.
>      >>
>      >> _______________________________________________
>      >> dhcwg mailing list
>      >> [email-masked] <mailto:[email-masked]>
>      >> https://www.ietf.org/mailman/listinfo/dhcwg
>      >>
>      >
>      > _______________________________________________
>      > dhcwg mailing list
>      > [email-masked] <mailto:[email-masked]>
>      > https://www.ietf.org/mailman/listinfo/dhcwg
> 
>     _______________________________________________
>     dhcwg mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/dhcwg
>

---

From: Naveen Kottapalli <[email-masked]>
Date: Wed, 2 Oct 2019 22:06:24 +0530

Sure. Will change in next update.

On Tue, 1 Oct 2019, 16:05 Alexandre Petrescu, <[email-masked]>
wrote:

> >     <
> https://datatracker.ietf.org/doc/html/draft-fkhp-dhc-dhcpv6-pd-relay-requirements
> > that
> >