Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-10.txt

From: [email-masked]
Date: Mon, 04 Nov 2019 05:42:48 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Authors         : Yong Cui
                          Linhui Sun
                          Ian Farrer
                          Sladjana Zechlin
                          Zihao He
                          Michal Nowikowski
	Filename        : draft-ietf-dhc-dhcpv6-yang-10.txt
	Pages           : 74
	Date            : 2019-11-04

Abstract:
   This document describes several YANG data modules for the
   configuration and management of DHCPv6 servers, relays, and clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-yang-10
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: [email-masked]
Date: Mon, 4 Nov 2019 14:55:18 +0100

Hi,

We’ve just posted -10, with  the changes proposed during the presentation at the DHC WG session at IETF104. It’s a pretty significant update:

* Reduced scope, focusing only on RFC8415 functionality
* Most of the modules have been rewritten with better structures
* Common functionality with groupings used by multiple element modules (replaces the old ’types’ module)
* Option definitions in a separate module, only containing RFC8415 options. A new mechanism for re-using the options between different elements has been designed. 
* An example of how new DHCP options can be defined and integrated with the existing structure is included in the Appendix. Some guidelines for writing option modules are given.
* We’ve also move out vendor specific configuration and client class selection functions from the main modules. These are now described as examples in the appendices as there is not enough commonality 

Please send any comments or suggestions. The draft is on the agenda for discussion in Singapore as well.

Thanks,
Ian

> On 4. Nov 2019, at 14:42, [email-masked] wrote:
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg