Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-11.txt

From: [email-masked]
Date: Wed, 17 Jun 2020 07:44:26 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Authors         : Yong Cui
                          Linhui Sun
                          Ian Farrer
                          Sladjana Zechlin
                          Zihao He
                          Michal Nowikowski
	Filename        : draft-ietf-dhc-dhcpv6-yang-11.txt
	Pages           : 78
	Date            : 2020-06-17

Abstract:
   This document describes several YANG data modules for the
   configuration and management of DHCPv6 servers, relays, and clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-yang-11
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-11

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: [email-masked]
Date: Wed, 17 Jun 2020 16:45:59 +0200

Hi,

I’ve just posted an update to the DHCPv6 YANG module. The main changes in this version:

*  Added if-feature to prefix delegation notification to resolve a lint dependancy problem

*  Fixes to line lengths in yang modules throughout

*  Updated references to RFC8415, removing the obsoleted references.

*  Removed portset-params (no longer needed)

*  Added text to the Security Considerations section

*  Reworked the interface and address configuration section of the example server module

*  Updated class selector example in line with changes to other models (augmentation path changes)

*  Renamed notifications

*  Relocated the active-leases sub-tree to the correct location.

*  Wording and description cleanup. Changes to re-align text with updates to the nodes in yang modules

*  Removed mandatory true nodes in server resource config 

*  Simplified the example server config file in the Appendix removing Cassandra config and improving the way that access to remote databases are configured.

As ever, all reviews, comments or suggestions appreciated.

Thanks,
Ian 

> On 17. Jun 2020, at 16:44, [email-masked] wrote:
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg